FlightAware Discussions

Multiple Feeders, one Raspberry

Hello everyone.
What is the safest way to install multiple feeders on one pi?
I want to feed to FA,FR24,RB24,PF and ADSBx.
I have already installed BusterLite after that Piaware and then RB24,FR24 and finally ADSBx.
However occasionally MLAT in my Flighaware page is red(fixed when restarting Piaware). Furthermore Pi24 MLAT shows off sometimes and encountered problems with ADSBx too(seems not to feed sometimes).
I use RPi4 B 1Gb RAM and a 8Gb SD card. A new one RPi4 B 4Gb is on its way.
I searched forums and chats but couldn’t find something like a tutorial for doing this properly.
Excuse me if I raise this topic again(probably is somewhere answered and couldn’t find it)
Thanks in advance!

I did this last week with one of my ADS-B RPis. I first installed Piaware, then run the scripts for each of the other services, as shown on their respective webpages. The only exception is ADSBx. I cannot get it to install/work properly. Gave up on it.

What was the issue?
I’ve never had a problem.

Can you be more specific?

The most common cause is an insufficient power supply or a bad USB extension connecting the SDR.

Which site is having MLAT issues? Has the location/height been set correctly and the device restarted?

I see only only one site and it looks OK to me

Sometimes during the day MLAT shows red on status page of Flight aware. Besides RB24 station page the local time is wrong and on ADSBx status page I can see red dots in sync errors. Is it probably an issue with NTPsyncing???I don’t know how to do this.

If there are not enough aircraft in the region then MLAT will not work.
NTP is not used by Flightware. The timing is from an internal clock on the USB Dongle.

So is it normal that sometimes MLAT is red? And the time from the internal clock is it possible to give wrong time to the other feeders? I use Blue stick pro plus

There are just not enough aircraft in the region for MLAT to work correctly.
I just looked at your site and it said MLAT was enabled but not synced with any other feeders. When I looked a few hours ago it was synced with more than a dozen other feeders.

One of my sites is synced with 400+ other receivers. I am in busy NYC. There are a few aircraft flying and lots of receivers in the area.

Ok thank you so much for answering!

1 Like

Might not be you unless it’s lots of peers.
The most likely cause is that you didn’t provide a position that was precise enough when asked by the setup script.
Otherwise it can be an insufficient power supply.

Anyhow troubleshooting is better suited to the adsbexchange forum or discord if you want to go that way.

Not sure what RB displays in regards to local time.
What do you mean it’s off, by 1 hour or 2 hours exactly?
Probably just rbfeeder showing the local time of the RPi and the RPi defaults to UTC unless you configure your timezone.

On my 3 RPis, I successfully used the install script which I wrote myself, but never advertised it. If you face difficulty in installing official one, try mine:

https://github.com/abcd567a/adsbexchange/blob/master/README.md

 

@abcd567

Worked perfectly on the first run. Less than 5 minutes from start to finish.

Thanks!!!

I see ADSB Exchange is using a different map now. Need to figure out how to see my data on the map.

@abcd567

Wow…I’m peering with you, among others, over a 400 km distance?

Is this correct or am I reading this wrong?

400km is possible; you both need to see the same ADS-B aircraft reliably for synchronization, and that aircraft could be between you at about 200km range.

Yes, I missed this ‘little’ detail. I can ‘see’ out to around 300 km, so this makes it a normal occurrence.

Yes, it’s the NA-EU path more or less. If I had my antenna outside and high, I could theoretically see TO’s airspace I think.