More Receivers one account


#1

If I have more then one receiver maybe two or three can I use it with one account? Or I need to create new accounts? At the moment I have two different positions but the second one will not show at my ads-b Web page that I can set position and height. I have only one the first one. How can I use a second or third one?


#2

You can have more then one site per account.


#3

If you claim the second/third receiver, they should then show up on your stats page and you can set a position etc.


#4

I have two on my account. I have seen members with 6 or 8.
It can take a while for them to show up. Try refreshing your browser.

Have you checked the receiver logs to ensure that data is being sent to FA?


#5

The second receiver is connected and running. How did I get informations that my receiver send data or not? I start this yesterday and no error will show. But it was not visible on my status page.

Thanks for your help.


#6

Look at the piaware log file, usually in /tmp , /tmp/piaware.out for me.

I am running a different version of dump1090 so yours may look a little different
01/19/2016 13:09:05 129212 msgs recv’d from dump1090-mutabi (287 in last 5m); 129212 msgs sent to FlightAware
01/19/2016 13:14:05 129550 msgs recv’d from dump1090-mutabi (338 in last 5m); 129550 msgs sent to FlightAware
01/19/2016 13:14:34 mlat(647): Receiver status: connected
01/19/2016 13:14:34 mlat(647): Server status: synchronized with 37 nearby receivers
01/19/2016 13:14:34 mlat(647): Receiver: 156.3 msg/s received 2.6kB/s from receiver
01/19/2016 13:14:34 mlat(647): Server: 0.7 kB/s from server 0.0kB/s TCP to server 1.0kB/s UDP to server
01/19/2016 13:14:34 mlat(647): Results: 331.9 positions/minute
01/19/2016 13:14:34 mlat(647): Aircraft: 15 of 20 Mode S, 7 of 8 ADS-B used
01/19/2016 13:19:05 129911 msgs recv’d from dump1090-mutabi (361 in last 5m); 129911 msgs sent to FlightAware
01/19/2016 13:24:05 130453 msgs recv’d from dump1090-mutabi (542 in last 5m); 130453 msgs sent to FlightAware

Did you set your username and password on your device?
sudo piaware-config -user EDVEaware -password


#7

01/19/2016 15:07:21 3737 msgs recv’d from dump1090 (43 in last 5m); 3737 msgs sent to FlightAware
01/19/2016 15:10:37 mlat(10302): Receiver status: connected
01/19/2016 15:10:37 mlat(10302): Server status: not synchronized with any nearby receivers
01/19/2016 15:10:37 mlat(10302): Receiver: 9.0 msg/s received 0.2kB/s from receiver
01/19/2016 15:10:37 mlat(10302): Server: 1.0 kB/s from server 0.0kB/s TCP to server 0.0kB/s UDP to server
01/19/2016 15:10:37 mlat(10302): Results: 472.7 positions/minute
01/19/2016 15:10:37 mlat(10302): Aircraft: 0 of 3 Mode S, 0 of 1 ADS-B used
01/19/2016 15:12:21 3760 msgs recv’d from dump1090 (23 in last 5m); 3760 msgs sent to FlightAware
01/19/2016 15:17:21 3778 msgs recv’d from dump1090 (18 in last 5m); 3778 msgs sent to FlightAware
01/19/2016 15:22:21 3800 msgs recv’d from dump1090 (22 in last 5m); 3800 msgs sent to FlightAware
01/19/2016 15:25:37 mlat(10302): Receiver status: connected
01/19/2016 15:25:37 mlat(10302): Server status: not synchronized with any nearby receivers
01/19/2016 15:25:37 mlat(10302): Receiver: 4.5 msg/s received 0.1kB/s from receiver
01/19/2016 15:25:37 mlat(10302): Server: 1.2 kB/s from server 0.0kB/s TCP to server 0.0kB/s UDP to server
01/19/2016 15:25:37 mlat(10302): Results: 564.0 positions/minute
01/19/2016 15:25:37 mlat(10302): Aircraft: 0 of 3 Mode S, 0 of 2 ADS-B used
01/19/2016 15:27:21 3824 msgs recv’d from dump1090 (24 in last 5m); 3824 msgs sent to FlightAware
01/19/2016 15:32:21 3849 msgs recv’d from dump1090 (25 in last 5m); 3849 msgs sent to FlightAware
01/19/2016 15:07:21 3737 msgs recv’d from dump1090 (43 in last 5m); 3737 msgs sent to FlightAware
01/19/2016 15:10:37 mlat(10302): Receiver status: connected
01/19/2016 15:10:37 mlat(10302): Server status: not synchronized with any nearby receivers
01/19/2016 15:10:37 mlat(10302): Receiver: 9.0 msg/s received 0.2kB/s from receiver
01/19/2016 15:10:37 mlat(10302): Server: 1.0 kB/s from server 0.0kB/s TCP to server 0.0kB/s UDP to server
01/19/2016 15:10:37 mlat(10302): Results: 472.7 positions/minute
01/19/2016 15:10:37 mlat(10302): Aircraft: 0 of 3 Mode S, 0 of 1 ADS-B used
01/19/2016 15:12:21 3760 msgs recv’d from dump1090 (23 in last 5m); 3760 msgs sent to FlightAware
01/19/2016 15:17:21 3778 msgs recv’d from dump1090 (18 in last 5m); 3778 msgs sent to FlightAware
01/19/2016 15:22:21 3800 msgs recv’d from dump1090 (22 in last 5m); 3800 msgs sent to FlightAware
01/19/2016 15:25:37 mlat(10302): Receiver status: connected
01/19/2016 15:25:37 mlat(10302): Server status: not synchronized with any nearby receivers
01/19/2016 15:25:37 mlat(10302): Receiver: 4.5 msg/s received 0.1kB/s from receiver
01/19/2016 15:25:37 mlat(10302): Server: 1.2 kB/s from server 0.0kB/s TCP to server 0.0kB/s UDP to server
01/19/2016 15:25:37 mlat(10302): Results: 564.0 positions/minute
01/19/2016 15:25:37 mlat(10302): Aircraft: 0 of 3 Mode S, 0 of 2 ADS-B used
01/19/2016 15:27:21 3824 msgs recv’d from dump1090 (24 in last 5m); 3824 msgs sent to FlightAware
01/19/2016 15:32:21 3849 msgs recv’d from dump1090 (25 in last 5m); 3849 msgs sent to FlightAware

And

01/19/2016 15:37:44 FlightAware server SSL certificate validated
01/19/2016 15:37:44 encrypted session established with FlightAware
01/19/2016 15:37:44 autoUpdate in adept config is enabled, allowing update
01/19/2016 15:37:44 manualUpdate in adept config is enabled, allowing update
01/19/2016 15:37:44 multilateration support enabled (use piaware-config to disable)
01/19/2016 15:37:44 logged in to FlightAware as user EDVEaware
01/19/2016 15:37:45 multilateration support enabled (use piaware-config to disable)
01/19/2016 15:37:45 multilateration data requested, enabling mlat client

As you can see all is fine i think. Yes i set username and passwort and restart after this. Any further hints?

Thanks for your help.


#8

Try sudo piaware-status (I got this from the post below)

This looks relevant to your issue
post186625.html?hilit=piaware%20status#p186625


#9

This MAC address is already associated with a different user account. Has the hardware changed hands recently?


#10

dump1090 is running.
faup1090 is running.
piaware is running.
dump1090 is listening for connections on port 30005.
faup1090 is connected to port 30005.
piaware is connected to FlightAware.
dump1090 is producing data on port 30005.

Can you specify which mac address? Otherwise i hope so that this mac address is another one then what i posted before. It’s another receiver! For two different receivers you must have different mac addresses…

So what i did in past is to change my username by flightaware.

What i do is following: I use WLAN dongle for connection. I put the first receiver who works fine with dongle on another place where i don’t need this dongle and connect it via ethernet. The dongle now mount on a new receiver.

But you write that i use this MAC Address with another account. I use only one account here. Only thing what happens is that my username would be changed in past. But after change this wlan dongle works fine with first receiver.

Obj, can you get in touch with my issue and fix it?


#11

Oh look it’s another ARM board that has duplicated MAC addresses. Sigh.

@EDVEaware - I sent you a PM.


#12

Sounds like it’s time to get away from using MAC addresses as site IDs. Use username instead?


#13

Yeah I am discussing what to do here. (username doesn’t work, you want multiple sites for one user)


#14

At this point I have two options. First I use another dongle or second I must change the mac address.

Thanks for help.


#15

I don’t think changing the dongle will help as the MAC address is associated with the pi’s LAN port. Changing the mac address sounds like the option needed.


#16

Correct, it is the ethernet MAC address that is important (even if the ethernet port is not in use), not the wifi MAC.


#17

Oh well then I must change the mac address indeed…
Thank you for this information.


#18

New MAC Address do the job. Now i have two receivers in my account. Thanks for help!


#19

For those with the same issue with odroids try this


sudo rm /etc/smsc95xx_mac_addr
sudo reboot

Thanks.