No Active FlightAware ADS-B Sites For This User

I installed PiAware and can view ads-b aircraft by using the :8080 in my browser. My IP is up to date on flight aware website but i still get the “No Active FlightAware ADS-B Sites for this user” error. What gives?!?!

The site needs to be registered to your account. Did you try to claim your piaware:

Also the local logs will show connection and startup problems. They are located in /tmp/piaware.out
If the logs are showing sent x message to FlightAware then everything is working fine on your device.

FlightAware Support here.

The PiAware feed was claimed using a different account and has now been reassigned.

How do we go about getting a receiver reassigned to our own account please?

My receiver was associated with another account for some reason and I am receiving MLAT feeds for a site near Paris, although I am based near Ipswich in the UK?

What is the MAC address of your receiver?


That MAC address is a duplicate of an existing receiver. What is the hardware?

Raspberry Pi Model B

OK, that should be fine in terms of being unique. Where did you get it - is it new, second hand, etc? Are you doing anything to override the MAC address?

2nd hand from eBay last week - no, not doing anything to override the MAC address.

Its a clean installation using the scripts here

Then I would guess that the previous owner is the other feeder and they have overridden the MAC address on their new device so it conflicts with your Pi.

I’ll send them an email.

OK, great thanks.

According to a post here (, the last three bytes of the mac address should match the last three bytes of the serial number. I can confirm that this is correct on my device.

I am having the exact same problem. Can see flights I am tracking on :8080, but cannot claim my account that used to work.

Your piaware is configured with the wrong password. Fix it and restart piaware (or, better, remove the username and password entirely and let it log in by MAC)

Any joy with this?

I had taken my receiver offline - but put it back online again now and am still not any feed in my profile.

Am I better off spoofing the MAC address to something else?

I thought we sorted this out via PM and you had it working; what did you change?

Yes, I was using a spoofed MAC address.

Just wondering if you had received a response from the other user though, as I don’t really want to have use a spoofed address if I can help it.

As I said in PMs at the time, I have been in contact with the other user and it is a CPU serial number collision so yes, you will have to continue to spoof a different MAC. That hasn’t changed.

OK thanks, understood.