Mode S Beast going into overload


#1

Hi,

I hope this isn’t a silly question or something covered elsewhere, but I have recently upgraded my PiAware and am having a problem.

I started with the new Rasbian Stretch Lite distribution and the built PiAware on top of that following the build instructions here:-

https://flightaware.com/adsb/piaware/build

Upon startup my Mode S Beast receiver immediately shows “output overload” (the blue LED on continuously).

I’ve not changed the Beast config, I have AC frames disabled in the config but that doesn’t help.

Reverting to a FlightAware Pro Stick RTL SDR receiver works ok- but not giving the same performance I had earlier (but probably comparable to earlier setups using the same dongle).

I do tend to have high message rates and my PiAware has usually been in the top 50 or so but I’ve never seen the output overload LED come on before.

Does anyone have any ideas? Things to check?

Thanks in advance,

Andy.


#2

I’m as much in the dark as you are with the Beast … but you have set Receiver_Type Beast in the config file OK? That’s all you need to do on the Pi IN AN IMAGE SD … I guess it’s the same with a built SD …

Kind Regards


#3

Hi,

Yes, set it to Beast in the config file. So in theory I expected it to just work to…

I’ll have to have another look- I see something in the notes about setting beast-splitter to auto start. Maybe there is a little extra config required for my approach?

Thanks for your thoughts.

Andy.


#4

Is beast-splitter running?

Note that I have not done any testing on Stretch yet, so you’re mostly on your own there. If you’re installing from binary packages then there’s a good chance that the underlying dependencies (notably Boost) have moved enough between jessie and stretch to make beast-splitter misbehave.


#5

Thanks for the suggestions.

Yes, I must admit I was wondering about the beast-splitter and if it being stopped (or not installed properly) would give me those results.

I’ll take another look over the next couple of days and see if I can identify what the problem a little more precisely!


#6

IIRC the overload indicator only turns on after the (usb-)serial port has been opened at least once, so it’d be consistent with beast-splitter starting up, opening the serial port, then crashing (e.g. because of incompatible libraries)


#7

The overload indicator is a filled buffer indicator.

When a message is seen the beast puts it into the local buffer and waits for another device to grab the message (in piaware case it grabs the message through the USB port) . If nothing grabs the message the buffer fills up and turns on the overload indicator.

I think the overload indicator turns on with just the power and antenna connected. The beast buffer will start to fill and it usually takes a second or so to fill.

Definitely, check the status of beast_splitter.