Change "beast" to "rtlsdr"


#1

This may well be a very ignorant question but … my “beast” configuration works well.

If I shut down the system and alter receiver type in piaware-config.txt to “rtlsdr”, reconfigure the hardware & reboot it remains in beast mode.

Something stupid that I’ve done?

Kind Regards


#2

I think we need more information. Maybe send us the contents of sudo piaware-config -showall (without usernames or passwords).
Did you replace a mode S beast with an RTL-SDR?
I have found that the mode s beast works much better with an amp. Like the uputronics amp/filter.


#3

the rtlsdr mode is only available via the piaware sd card image.

if you installed it another way the “receiver-type” setting is basically not used.

mine automatically uses the dump1090-fa that is running.

which in turn can be configured via /etc/default/dump1090-fa

But stating your setup and what exactly you want to change would be nice to know.
And how do you know it stays in beast mode? the mlat client saying beast-mode just means that’s the protocol used to get data.


#4

He is using the piaware sd card image


#5

Yes, I am …

I’m modifying the config file using text edit.

“rtlsdr” set but then no aircraft visible with an orange dongle … change text to “beast”, reinstate the Beast and all is ok …

Kind Regards

Hugh


#7

-10 is well documented and you would need one more option to toggle automatic gain otherwise.
dump1090-fa --help says “–gain Set gain (default: max gain. Use -10 for auto-gain)”

They are now running dump1090-fa as a service so it basically looks to piaware like a beast receiver offering data over the network. (The option was probably used for starting dump1090 via piaware)

Why would you change the settings if it’s working? :slight_smile:


#8

The Beast option is for a mode S beast connected by a USB
Receiver Types
RTL-SDR
This is the traditional setup with a RTL-SDR dongle directly connected to the Pi. PiAware will connect to localhost:30005 for ADS-B data. Set “receiver-type” to “rtlsdr” and (on SD card image installs only) configure the other rtlsdr-* values if needed.

Beast (SD card image installs only)
This configures PiAware to talk to a Mode S Beast connected by USB directly to the Pi. Set “receiver-type” to “beast”. No further configuration is needed.

It is documented here


#11

So: thank you all for your comments and discussion.

The conclusion seems to be - there is no conclusion!

I’ll write a new card from scratch and that should be the solution.

Thanks again -

Hugh


#12

Found it!

My Orange dongle has died - substituted an RTL-SDR metal dongle and all is well apart from no speed or altitude yet …

Kind Regards

Hugh