FlightAware Discussions

MLAT states my location is not configured

Receiver has been running for two years, recently I replaced the dongle and decided to turn on MLAT. In the config file I have changed MLAT to yes after removing the #. Updated my location as I had moved for longitude and Latitude N is 39.06470 and W is -78.09740 . Did a save and returned the Micro SD card to the Raspberry Pi. Site tells me MLAT receiver location not configured. PiAware and Flight Aware show green.
Any suggestions as to what I missed or did wrong?

Thanks Steve ag4so@outlook.com

Hi Steve,

SITE 72335 – KOKV
States
Nearest Airport: Winchester Rgnl (Winchester, VA) (KOKV)

Location: (38.98, -77.85)
Location Set: 18 January 2018 10:48 PM
Location Source: FlightAware estimated.

Feeder Check-In: a few seconds ago
Feeder Type: PiAware (SD Card) 3.8.1
Feeder Mode: Mode-S (1090 MHz)
Multilateration (MLAT): Supported / Receiver location not configured

Have you rebooted or restarted piaware after updating the Flightware location details?

Jon

Yes can do so again just in case

Just tried 2 resets no joy pi screen says malt not enabled

Your post and the location in FA are about 22 miles apart.
I know FA allows you to set the accuracy but 22 miles seems a little far.

If you point your FA location into something like google maps, is it correct?
It needs to be within a hundred feet or so.

Are there any messages in the message log? either on FA or on the RPI itself.

Flight aware reports MLAT supported rx location not configured and pi reports MLAT is not enabled.

Got the gps coordinates from the ftm100 about 3 feet from the pi receiver .

I’m not sure where you updated the location, but the location is not configured on the sdcard. You need to update the location via your stats page (https://flightaware.com/adsb/stats/user/ag4so, click on the white-on-grey gear, select edit location).

Currently, that site does not have a location manually configured, which is why mlat is disabled:

Location Source: FlightAware estimated.

1 Like

Thanks for the information I have been trying to enter the coordinates for a while tonight as you instructed however I have a problem. First I went to google maps and found the location my radio was giving is way off so scratch that and went to Google Earth to pinpoint my location. I entered the new coordinates 39.0647 and -78.0975. I save and recheck it looks on until I restart the Pi I recheck and the numbers are changed each time to a different location. for example the last one was 39.97676 -77.85162. Of course MLAT is not accepting I also entered my antenna height using the height from Google Earth plus 10’. Any idea what I am doing wrong?

Where are you entering your coordinates? In Pi or at your Flightaware stats site?

For Beginners - How-to Set Receiver Location

Disable piaware using gpsd if you have that:

sudo piaware-config use-gpsd no
sudo systemctl restart piaware

Looks like I am making progress new message on razberry pi under MLAT Local clock source unstable.

So is that the razberry pi or the dongle that’s unstable?

Give it some time. The clock issue is the clock inside the USB dongle. There is a clock inside that is used for MLAT.
Your neighbours don’t have a lot of MLAT aircraft. I suspect that you should have some by the end of the day.

73
Jon

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.