MLAT from PiAware not plotting on Planeplotter


#1

Hi, I’ve just setup PiAware with an RTL dongle and everthing is plotting on Skyview including Mlat aircraft.

However, the Mlat aircraft are not plotting on planeplotter.

My PP settings are:

I/o settings Mode-S/ADS-B —> RTL > RPi+Dump1090
Mode S Receiver RTL Dongle RPi Dump —> 192.168.1.44:30005

Are the settings incorrect.

Thanks


#2

you may wish the review the flightaware Mlat conditions of use


#3

I’m only looking at plotting the Mlat’s on planeplotter on my LAN.


#4

take a look at this diagram: https://flightaware.com/adsb/piaware/about

It indicates you need to get the mlat positions separately connecting to either 30105 or 30106.

I’m not familiar with VRS but i believe you need to set up a separate source / input with one of those ports.


#5

Ah - not relevant then.
Try port 30106


#6

Ok, tried the following ports:

30005 —> plots all except Mlat
30105 —> plots Mlat only
30106 —> plots nothing

Is it possible to merge the two ports ?


#7

It appears that ModeSMixer2 is the solution.

With PiAware installed is it possible to install ModeSMixer2 on the RP or does it have to be installed on a PC.


#8

With VRS? It should be, iirc you can merge the feeds of two feeders, so you probably can make a adsb feed, a mlat feed and then a combined feed of the two?!


#9

YES

How-to Get VRS-Like Coverage Map on RPi

.


#10

hi

in addition to code by @abcd567

For RPi 2/3
COPY-PASTE following text to blank file mm2.sh

/home/pi/mm2/modesmixer2 \
 --inConnectId 127.0.0.1:30005:ADSB \
 --inConnectId 127.0.0.1:30105:MLAT \
 --web 8787 \
 --location xx.xxxx:yy.yyyy \

you need a line like this --outServer beast :40005 \

and a change in your PP line Mode S Receiver RTL Dongle RPi Dump —> 192.168.1.44:40005

this outServer works similar to VRS Rebroadcast server


#11

Thanks.

Deviating a bit from the original subject - can you feed flightaware from the RP with dump1090 without having to install PiAware?


#12

not sure, I think I saw something in this forum, maybe by user @abcd567, about using original dump1090 by Malcolm Robb.


#13

Thanks, I’ll have a search on it.

Does VNC work with PiAware ?


#14

sorry, I do not know.


#15

I may be mistaken, some will say I always am :sweat_smile:, but VNC is useful as a remote desktop, which implies a GUI. There is no GUI in Piaware by default, but it can be installed.

I do use VNC, with the full version of Raspbian. With Piaware, I use Putty.


#16

With VRS? Sure. Create a Merged feed using the VRS ‘receivers’ you have now, typically your RTL-SDR dongle and MLAT (if enabled), but you may have more than two VRS ‘receivers’ set up.


#17

I don’t think so. Whether Piaware was part of the SD image, or installed later manually, I believe it has to be present if you want to feed FA.


#18

Thanks, I’ll try Putty.

Going through the instructions, when I get to step 8 and enter ./mm2.sh & disown I get:

./modesmixer2: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file. No such file or directory


#19

you may need to install openssl and/or libssl-dev and reboot.
sudo apt-get install -y libssl-dev

I think though that you want modesmixer to feed your planeplotter in which case
it is easier to run modesmixer in your PC.
you need the runtime executables msvcr / msvcp you can download from Microsoft.
then in the modesmixer folder add / edit a file mm2.bat.
add the following lines and run it.

echo "modesmixer v 9/2017 - web 9779"
@echo off
cmd /c mm2.exe ^
--web 9779 ^
--location your LAT:your LON ^
--inConnect your RPi IP:30005 ^
--inConnect your RPi IP:30105 ^
--outServer beast:40005

PAUSE
exit

now change the PP line for the receiver 127.0.0.1:40005

note: you must download the windows version from xdeco.org

note: you can rename modesmixer2.exe to mm2.exe. if not then the above cmd line
must change to cmd /c modesmixer.exe ^

note: on your browser enter 127.0.0.1:9779 to view the modesmixer output.

note: in RPi SSH must be enabled via raspi-config or via an empty file named ssh.


#20

openssl was already installed and installing libssl-dev doesn’t change anything.

I’ve installed putty on the RP and PC. I created an empty ssh file on the RP root directory. When I “ssh pi@piaware” is says connection refused ?