PlanePlotter not working with PiAware MLAT data

With the recent upgrade to PlanePlotter, the display of MLAT data from PiAware has stopped working.

Bev has indicated that changes were made in the most recent PlanePlotter upgrade that prevent specially tagged PiAware MLAT position reports from being uploaded to the PlanePlotter servers - a good thing. However, any data stream containing MLAT position reports seems to prevent PlanePlotter from displaying any of the aircraft, but only on the latest version. works just fine.

I have a bit of a unique setup. However, at least one other user has reported similar issues using dump1090.

Besides running PiAware with MLAT enabled, I start up three processes in my Pi startup script:

modesmixer2 --inSerial /dev/ttyUSB0:3000000:hardware --outServer beast:30005

This simply emulates what dump1090 does, making the USB/Serial data available on port 30005. Connecting to port 30005 with both the newest and older revisions displays this data from the Beast receiver fine.

I then start ppup1090:

ppup1090 --quiet --net-pp-ipaddr

The IP address in the previous command is the static address of my PlanePlotter PC.

I also run a second instance of modesmixer2.

modesmixer2 --inConnect localhost:30005 --inServer 30004 --outServer beast:30015 --web 8080 --location 41.900000:-88.300000

This combines the Beast output data on localhost port 30005 from the first instance of modesmixer2 with the PiAware MLAT data on localhost port 30004. The combined output is sent to port 30015, which is where I point PlanePlotter to display the local receiver data as well as the MLAT data from PiAware.

The second instance also activates the modesmixer2 web server with the combined data.

Of course I have sharing uploads disabled in PlanePlotter to avoid feeding PiAware MLAT positions to the PP sharing system.

As I said, this works perfectly in PP, but does not work in

I tried isolating the PiAware MLAT data on port 30015 with a modified invocation of the second modesmixer2 instance:

modesmixer2 --inServer 30004 --outServer beast:30015 --web 8080 --location 41.900000:-88.300000

This eliminates the data from the Beast receiver from what PP tries to display, leaving only the MLAT data from PiAware. This also works perfectly in PP, but does not work in

Anyone seeing anything similar?



I can’t speak for the PP parts, but if you also did a piaware upgrade to 2.1-3 at about the same time, be aware that the default port for mlat data changed to 30104 (mostly so that you have to make a deliberate decision to use it)

I spotted that, but I am still on the older release of PiAware with the ports that match my modesmixer2 configuration.


There have been threads on the planeplotter yahoo group on the subject. I haven’t been following too closely as I don’t have a horse in that race.

Working with the PlanePlotter author, this appears to have been an anomaly in version I have a test build that fixes the issue completely. Until then, I would stay on release if you should encounter this issue.

The presence of the special PiAware MLAT Beast binary packets with the signature timestamp seem to prevent display of any aircraft, as well as inhibiting their upload to the PlanePlotter servers in v6.4.3.5. The code was only meant to prevent uploading of PiAware MLAT data to the PlanePlotter sharing system, while allowing local display.



The recently-released PlanePlotter solves this issue of PiAware MLAT packets not displaying and locking up display of all aircraft.