FlightAware Discussions

Kali Linux 2020.4 - 32bit + Raspberry 4 (2Gb Ram) didn't like PiAware

Hi every one!
My config
Kali Linux 2020.4 ARM - 32bit + Raspberry 4 (2Gb Ram (that’s why 32bit OS) ) + RTL-SDR v3:

Blockquote
#uname -a
Linux raspberrypi 5.4.42-v8+ #1319 SMP PREEMPT Wed May 20 14:1restart8:56 BST 2020 aarch64 GNU/Linux

Blockquote
#lsb_release -a
No LSB modules are available.
Distributor ID: Kali
Description: Kali GNU/Linux Rolling
Release: 2020.4
Codename: kali-rolling

So first of all, I try to instal dump1090-fa + PiAware => but to fail. (Examples in attachment)

Then, I try combination dump1090-mutability ver 1.15~dev + FR24 Feeder => but to fail with dump1090-mutability, but FR24 armhf.deb installing OK.

At last, I try combination:

  • List item
    ModeSDeco2 ==> OK
    PiAware = to fail :frowning: (piaware-repository_3.7.2_all.deb or piaware-repository_4.0_all.deb)
    FR24 = OK (install_fr24_rpi.sh)
    Planefinder Feeder = OK (pfclient_4.1.1_armhf.deb)

Now, my system work with:
Kali Linux 32 bit ARM + ModeSDeco2 + FR24 + Planefinder Feeder

Perhaps, someone has ideas for solving the problem with PiAware
or someone has test builds for Kali Linix?

Manual for install take here:

UPD: Sorry, new users can only put one embedded media item in a post.
So, another screenshots I will add later :innocent:

@ivan2ko

Try this:

sudo apt-get install liblimesuite-dev   

sudo apt-get install dump1090-fa 

sudo reboot  

 

1 Like

I guess you’ll need to rebuild the packages from source, as it looks like Kali is different enough to Raspbian that the prebuilt Raspbian packages will not work.

Here’s some starting points:

2 Likes

THK for info, I write recovery image to SD (without feeders and dump1090) & try both variants.

Just be aware you must install only one decoder that talks to the SDR.

If you don’t want to deal with manually compiling a recent one: Automatic installation for readsb · wiedehopf/adsb-scripts Wiki · GitHub
or manually: Building readsb from source · wiedehopf/adsb-wiki Wiki · GitHub

The 2nd link is pretty much the same process dump1090-fa is compiled.

Anyhow you run one decoder and then point everything to the beast output on 30005.
piaware is by default going to check there for data, so will the adsbexchange feed client.

fr24 if there is already dump1090-fa/readsb running will automatically configure on installation to use port 30002 and AVR … not sure why they do that you can configure it for beast on 30005 as well.

Not sure if for example graphs1090 will work but if you’re interested it’s linked here:
Raspbian Lite: ADS B receiver · wiedehopf/adsb-wiki Wiki · GitHub
Also has some instructions on an fr24 service that’s not quite as ugly as the existing one though the binary is still horrible.

Dear, Wiedehopf,
I try to understand:

what’s different between ModeSDeco2 & dump1090-retro-html, they both send info to the the beast output on 30005. But PiAware didn’t want to install, another feeders work…
ModeSDeco2 + FR24 + Planefinder Feeder
But, I try your variant too. THX

As an alternate to ModeSDeco2, you can install dump1090-fa

kali@kali:~$ uname -a
Linux kali 4.19.118-Re4son-v7l+ #1 SMP Wed May 6 16:33:16 AEST 2020 armv7l GNU/Linux
kali@kali:~$ cat /etc/os-release
PRETTY_NAME="Kali GNU/Linux Rolling"
NAME="Kali GNU/Linux"
ID=kali
VERSION="2020.4"

The package building and install method for amd64 and armel / armhf is almost same.

First install some extra dependencies for armhf / armel version of Kali

sudo nano /etc/apt/sources.list

Uncomment following line (i.e. remove # at the start of line), and save File.

#deb-src http://http.kali.org/kali kali-rolling main contrib non-free

Update apt

sudo apt-get update

Now install; dependencies

sudo apt-get install debhelper pkg-config   

wget http://ftp.us.debian.org/debian/pool/main/d/debhelper/dh-systemd_13.2.1_all.deb   

sudo dpkg -i dh-systemd_13.2.1_all.deb  

 

Next run the following automated install script for Debian/Ubuntu/Kali AMD64

 

image

 

1 Like

Dear, abcd567,
THX, your recommendations helped.
The dump1090 ADS-B receiver (FlightAware customization) now works with FR24,
but PiAware didn’t want to install again.

Perhaps you have some customization ideas for it? :innocent:

I will have to try to build it from surce code and see how it goes. Main issue expected is of dependencies. Anyway, if I succeed, I will post the method.

1 Like

@ivan2ko

While installing dump1090-fa, you have edited file /etc/apt/sources.list and have installed tools debhelper, pkg-config, dh-systemd. Therefore you dont have to do it again. Just run the bash script below and it will install piaware

NOTE:

The above script installs lot of dependency packages. Installation of many of these packages takes very long time, and often you will feel that the Pi has hanged. Be patient.

When you will issue the above command, after short while it will ask for kali’s password. Once you enter the password rest of process is automatic. Go to kitchen, make two cups of coffee, sit by your computer sipping the coffee. When your 2nd cup of coffee will be about to finish, the process will announce installation is completed :wink: :slightly_smiling_face:

 

image

 

image

2 Likes

Continuing my experiments …
after installing dump1090 ADS-B receiver (FlightAware customization) , I decided to install the graphs1090 module. Everything worked.

sudo bash -c "$(wget -q -O - https://raw.githubusercontent.com/wiedehopf/graphs1090/master/install.sh)"
install GRAPHS_1090 - KALI LINUX (32bit) for Pi4_2Gb RAM.txt

But then I decided to do :sunglasses:

sudo apt upgrade
sudo apt dist-upgrade
sudo reboot

and now the pages http://192.168.x.x/dump1090-fa/ & http://192.168.x.x/graphs1090/ are not displayed,
but the services are running and the dump transmits data to the feeder :thinking:

After (sudo apt upgrade and sudo apt dist-upgrade) - web page dump1090-fa - FAIL

Okay, I’ll try now.
Despite the broken pages http://192.168.x.x/dump1090-fa/ & http://192.168.x.x/graphs1090/ , but worked dump1090

Clear browser cache, then reload browser
Ctrl+Shift+Delete
Ctrl+F5

I tried in different browsers - problem is same.
In some browsers - page try reload itself many times, but didn’t show anything

Lesson learned: don’t upgrade if the system is working OK
There is a famous saying “dont fix it if it ain’t broke” :wink:

1 Like

You’re lighttpd config is broken.
My guess would be you had dump1090 installed which adds a configuration which creates an issue with the dump1090-fa lighttpd config.

sudo rm /etc/lighttpd/conf-enabled/89-dump1090.conf
sudo systemctl restart lighttpd

If that doesn’t help check the lighttpd log: Debug commands · wiedehopf/adsb-wiki Wiki · GitHub

Thank YOU GENIUS :innocent:

:floppy_disk: Now PiAware 4 likes Kali Linux 2020.4 - 32bit + Raspberry 4 (2Gb Ram) didn’t like PiAware :floppy_disk:

Results of PiAware 4.0 new srcript instal for Kali Linux.txt

@wiedehopf

READSB

kali@kali:~$ sudo bash -c "$(wget -q -O - https://raw.githubusercontent.com/wiedehopf/adsb-scripts/master/readsb-install.sh)"

dpkg-checkbuilddeps: error: Unmet build dependencies: debhelper (>= 9) libusb-1.0-0-dev pkg-config dh-systemd librtlsdr-dev
dpkg-buildpackage: warning: build dependencies/conflicts unsatisfied; aborting
dpkg-buildpackage: warning: (Use -d flag to override.)
Something went wrong building the debian package, exiting!
kali@kali:~$

WORKAROUND

sudo nano /etc/apt/sources.list

## Uncommented following line (i.e. remove # which was at the start of line
deb-src http://http.kali.org/kali kali-rolling main contrib non-free

## Updated apt
sudo apt-get update 

Now installed dependencies

sudo apt-get install debhelper libusb-1.0-0-dev pkg-config librtlsdr-dev  

sudo apt-get install dh-systemd
E: Unable to locate package dh-systemd. 
## Installed it this way:
wget http://ftp.us.debian.org/debian/pool/main/d/debhelper/dh-systemd_13.2.1_all.deb   

sudo dpkg -i dh-systemd_13.2.1_all.deb  

Ran script again, got this error:

Delete 89-dump1090.conf + restart lighttpd

I have no clue why your lighttpd config would be so screwed up …

Interesting that it was working before 14:31 … if you’re gonna install all kinds of crazy stuff … well broken install is kinda expected.
It tells you which file is the issue … check for the duplicate entries mentioned :stuck_out_tongue_winking_eye:
Good luck.

Or your hard drive is broken or something … because those errors are kinda strange.
Have never seen mime type issues.

1 Like