FlightAware Discussions

I can not get PiAware to boot on my New RPi 4 Running Buster

As the subject says I can not boot PiAware. I tried burning image to a SD card that I can burn and boot Buster on. I tried burning image using Etcher on both a Windows and Mac machines. I downloaded PiAware twice, same results. Anyone have any ideas for me to try? Thanks.

Which image did you try to burn?
The FA image from here https://flightaware.com/adsb/piaware/build
or an image from raspberrypi.org ?

You cannot boot Piaware, or cannot connect (ssh) to Pi4?
Are you using wired connection to router, or WiFI?

Please disregard. I found out that Buster boots with a single monitor plugged into either hdmi port, PiAware needs the monitor plugged into port 0. It boots just fine for me now.

4 Likes

There is a known issue with the overlay, but it looks like the most recent version of piaware resolved it. As I just booted up a clean install on a Pi4 headless.

At one point I did have this issue with another image not piaware related, and this is the url I used to find my solution.

HotPlug settings had to be modified.

https://www.raspberrypi.org/forums/viewtopic.php?t=253312

The piaware sdcard image has hdmi_force_hotplug=1 by default.

The issue with the Pi 4 is that there is a pi4-specific video setting in config.txt needed to enable mirroring to both HDMI ports; but that setting also breaks plymouth, so the piaware sdcard disables it by default and you need to use the primary HDMI port only.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.