FlightAware Discussions

Flashed 3.8.0 to SD card but it won't boot on a Pi4

With the release of 3.8.0, I’ve flashed a copy to an SD card to be used in a Pi4. This is a fresh installation, taken straight from the Flightaware download page.
Installing it into my Pi4, all I get is the initial ‘rainbow’ splash screen & nothing else.

Is the version on the Flightaware now based on Buster, or is it still on Stretch?

I have flashed the img file to 2 separate SD cards with the same outcome.

Earlier, I updated my existing 3.7.2 image to 3.8.0 in my Pi 3b, without incident.

Any helpful suggestions as to what’s happening with the new images would be welcome.

Thanks,
Graham

Which HDMI port are you using on the Pi4? Can you try both?

The new image is based on buster.

I just tried and downloaded it here http://piaware.flightcdn.com/piaware-sd-card-3.8.0.img.zip, unzipped it and flashed it with windiskimager on a sd card where I had deleted all existing partitions beforehand, then added wlan, pw and feeder-id to piaware-config.txt, put it in a RPi 4, and it worked. Not sure what it shows on the display, though.

Edit: Ok, it also only shows the splash screen. Not sure if that has always been the case or not, but that does not mean it doesn’t work. [using the other hdmi-port solved this]

1 Like

I was using the HDMI part furthest away from the power connector, simply because I use an HDMI adapter & in the connector closest to the power connector puts a strain on the latter’s connection to the board.
Squeezing it into the one nearest one brings it up OK. Normally, I’ve had no problems using the one I normally use, as Buster should be able to send a signal to either connector to allow for multiple screens.
I’m just testing if it will work at the moment, so was a little surprised when nothing happened!
It seems to work OK in a 3B but that can accept a Stretch-based distro.
I haven’t done anything to the config file as yet - as it didn’t boot from its raw state I hadn’t got that far.
I would expect the image to use either HDMI output. It seems not to at present.

Graham

PS I use BalenaEtcher to copy images on a Mac. Unfortunately, Etcher won’t work on Catalina, the latest version of the MacOS (not sure but it might be 32 bit & Catalina will only allow 64 bit programs to work on it) - BalenaEtcher is the same basic software but works with Catalina

That is the “right” one, hdmi 0, I think, when you just use one monitor.
[Actually it is hdmi1, and some people had issues with when a single monitor was plugged in there instead of hdmi0, which is the one close to the usb-c power. Maybe that is the issue here]

I get only the rainbow screen, too, it still boots properly in the background.

Not sure if that is a new thing, or if older versions showed a command prompt. I have always edited piaware-config.txt in the boot partition and added an empty file named ssh to the boot partion, and then ssh into it whenever I need.

If you really need a command prompt, then I guess you have to install a buster image and the piaware add-on.

I haven’t booted to the command prompt as such but I do get a screen which gives various bits of basic information, such as the IP address & whether it’s connected to Flightaware etc. - useful to make sure its working OK.
I have mine in the loft with a vertical dipole & have an old monitor I connect when I first boot it or when I’ve had to change something with it - checking it works before I come down from there saves having to keep climbing the ladder to check it out!
Normally only remotely connect using Dump1090. Knowing the IP address before I start means I don’t have to do a network scan to find it.

Or just log into your router to find it?

Just connected an monitor to an older test system with 3.71 and booted, it really had a nice splash screen and then showed some basic info of the receiver, I had never noticed that before, and now it is gone… :slight_smile:

[Edit: all good, it is still there when you connect to hdmi 0, which is the one close to the usb-c power]

Made the image with balenaEtcher today and installed on the Pi4 today with no issue. The main HDMI is closest to the power. I did add the empty ssh file before booting and then added my current ID once up and running using: piaware-config feeder-id enter ID from status page.
I just need to figure our how to install dump978 now and use my orange stick for that!

https://flightaware.com/adsb/piaware/advanced_configuration#uatsteps

I had to disable some of the Pi 4 specific video stuff as it broke Plymouth. That’s probably why the signal isn’t being mirrored to the second port. This is the diff that the piaware image build applies if you want to try reversing that change:

diff --git a/stage1/00-boot-files/files/config.txt b/stage1/00-boot-files/files/config.txt
index 665147f..bbb5288 100644
--- a/stage1/00-boot-files/files/config.txt
+++ b/stage1/00-boot-files/files/config.txt
@@ -57,11 +57,3 @@ dtparam=audio=on
 
 # increase max USB current on more recent models
 max_usb_current=1
-
-[pi4]
-# Enable DRM VC4 V3D driver on top of the dispmanx display stack
-dtoverlay=vc4-fkms-v3d
-max_framebuffers=2
-
-[all]
-#dtoverlay=vc4-fkms-v3d

There’s a getty (console login) on one of the other virtual consoles (alt-f2). The main console status screen tells you this.

My mistake, is still all there there, you just not see it when you connect your monitor to hdmi 1, which is the one further away from the usb-c power.

Using hmdi1 apparently can cause problems, eg https://www.raspberrypi.org/forums/viewtopic.php?t=243899.

The Pi is in an amor case, and I did not remember correctly which hdmi port was 0 and 1.

I assume Plymouth is the latest version of the Flightaware software - not come across the name before.
Although some may find the diff file information useful, I’m afraid it means nothing to me. Is this something to do with Github? Haven’t managed to get my head around Github - lots of filenames, no idea what to do with them.

Not quite.

It’s a tool for customizing the Raspbian boot screen.

@obj
Have you looked into just hacking something together which does autologin on the first console and displays all the stuff that way?

The problem was that plymouth just wouldn’t work at all on the Pi 4, it’d blank out the screen entirely. I didn’t want to spend a lot of time diagnosing it, since I saw the same thing with stock Raspbian on a Pi 4 too…

The point of the splashscreen is to get something showing up very early on during boot.

It describes the changes I made to config.txt. Lines starting with - were removed. So you can reverse that by adding the lines back if you want.

I presume that by the term ‘hacking’ you mean programming.
What comes up now is perfectly adequate for my needs. The ‘rainbow’ screen alone suggested that the boot process had stalled, though - hence my initial question.