FlightAware Discussions

How-to install AcarsDeco2 on a Rasberry PI already running dump1090


#1

I have two Raspberry Pi’s running at once. My first one is only running PiAware image feeding Flightaware. The second Pi is running ADS-B Reviever scripts and image on Stretch. I want to do is install AcarsDecoder2 (AD2) on either Pi’s with a RTL-SDR V3 dongle that is serialized by me. Is this possible?


#2

Here is the download link. I use the windows version and works great.

http://xdeco.org/?page_id=30


#3

How-to Install AcarsDeco2 on Pi2 or Pi3 already running Raspbian Stretch and dump1090 (mutability or fa)

STEP-1, ALTERNATIVE-1

1.1.1 - Download on Desktop/Laptop, the AcarsDeco2 file from http://xdeco.org/?page_id=30

Raspberry Pi 2/3 (Broadcom SoC BCM2836/37 ARMv7 Quad Core) Raspbian GNU/Linux 9.0 (Stretch):
acarsdeco2_rpi2-3_deb9_20180603.tgz

1.1.2 - Copy the downloaded file acarsdeco2_rpi2-3_deb9_20180603.tgz to RPi’s folder /home/pi using WinSCp or FileZilla

1.1.3 - In RPi, create a folder acars to hold AcarsDeco2 files, and move the file acarsdeco2_rpi2-3_deb9_20180603.tgz into it

pi@raspberrypi:~ $ sudo mkdir acars  
pi@raspberrypi:~ $ sudo mv acarsdeco2_rpi2-3_deb9_20180603.tgz  acars/  

.

STEP-1, ALTERNATIVE-2

1.2.1 - In RPi, create a folder acars to hold AcarsDeco2 files

pi@raspberrypi:~ $ sudo mkdir acars 

.
1.2.2 - I have uploaded acarsdeco2_rpi2-3_deb9_20180603.tgz to my DropBox account. Using wget command, you can directly download it from my Drop-Box to RPi and save it in newly created folder acars

pi@raspberrypi:~ $ sudo wget -O  acars/acarsdeco2_rpi2-3_deb9_20180603.tgz  "https://www.dropbox.com/s/q5tjkkrodsyert7/acarsdeco2_rpi2-3_deb9_20180603.tgz?dl=1"  

.

STEP-2

2.1 - Move into folder acars

pi@raspberrypi:~ $ cd acars

2.2 - Extract downloaded .tgz file

pi@raspberrypi:~/acars $ sudo tar xzvf acarsdeco2_rpi2-3_deb9_20180603.tgz
acarsdeco2
acarsdeco2.readme
acars_signals_sdrsharp_ppm_error_corr_1.jpg
LICENSE.MIT
datasets/
datasets/aircrafts_p.txt
datasets/acars_mls.txt
datasets/aircrafts_s.txt
datasets/airlines.txt

.

STEP-3

3.1 - Serializ two DVB-T / Prostick dongles
Dongle 1 (for dump1090-mutability): Serial # 00000000
Dongle 2 (for AcarsDeco2): Serial # 00000001

Instruction to serialize are here:
How to Change Serial Number of Dongle - ADSB 1090 + UAT 978 Dongles Plugged Into Same Pi

3.2 - Plug Both Dongles in Pi

3.3 - Reboot Pi

sudo reboot

.

STEP-4

Check what AcarsDeco2 has detected as DVB-T / Prostick dongles available and their serial numbers

pi@raspberrypi:~ $ cd acars

pi@raspberrypi:~/acars $ ./acarsdeco2 --device-list
AcarSDeco2 v.20180603
Available Devices:
 0 mnf: Realtek prod: RTL2832U serial: 00000000
 1 mnf: Realtek prod: RTL2832UFA serial: 00000001

.

STEP-5; Run AcarSDeco2 Manually

pi@raspberrypi:~/acars $ ./acarsdeco2 --device-index 1 --gain 49.6 --freq 131550000 131725000 --http-port 8686 &
[1] 981
pi@raspberrypi:~/acars $ AcarSDeco2 v.20180603
Using device:  1 mnf: Realtek prod: RTL2832UFA serial: 00000001
Sampling rate: 1400000.018544 sps
Supported Gains (dB):  0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6
Freq: 131.637 MHz
Freq Correction: 0 ppm
Gain: 49.6 dB
Trying to use 16 buffers in memory explicitly allocated to support zero-copy

.

STEP-6 : Automated start at boot / reboot

6.1 - Create a blank file ad2.sh, make it executable, and open it for editing

pi@raspberrypi:~ $ cd acars
pi@raspberrypi:~/acars $ sudo touch ad2.sh
pi@raspberrypi:~/acars $ sudo chmod +x  ad2.sh
pi@raspberrypi:~/acars $ sudo nano ad2.sh

6.2 - Copy-paste following code in new blank file ad2.sh

/home/pi/acars/./acarsdeco2 \
 --device-index 1 \
 --gain 49.6 \
 --freq 131550000 131725000 \
 --http-port 8686 \

6.3 - Save (Ctrl+o) and Close (Ctrl+x)

6.4 - Open file rc.local for editing

sudo nano /etc/rc.local

6.5 - Copy-paste following line in file rc.local just above last line (i.e. just above exit 0)

/home/pi/acars/ad2.sh &

6.6 - Save (Ctrl+o) and Close (Ctrl+x)

STEP-7

IP-OF-PI:8686

.
.

LOG

.
.

FLIGHTS


#4

This is good. Here is my argument line on the windows version;
@echo off
cmd /c acarsdeco2.exe --http-port 8888 --device-serial V3-2 --gain 19.7 --freq 131550000 --freq 131725000 --freq 131875000 --freq 131125000 --outConnectUdp pp:127.0.0.1:9742 --silhouettes C:\acarsdeco2\silhouettes --frdb C:\acarsdeco2\flightroute.sqb --db C:\acarsdeco2\basestation.sqb --banners C:\acarsdeco2\logos --outServer sbs:30008 --outServer ad2:31008 --vrs-url http://127.0.0.1 --logfile c:\acarsdeco2\logs\ACARS
exit
Is it possible to feed Plane Plotter with this line --outConnectUdp pp:127.0.0.1:9742? To my windows computer where Plane Plotter resides?


#5

.
It should be possible. You can try by adding --outConnectUdp pp:xxx.xxx.xxx.xxx:9742 to the file ad2.sh.

The text in file ad2.sh will now becomes like this:
(Replace xxx.xxx.xxx.xxx by actual LOCAL IP OF WINDOWS DESKTOP)

/home/pi/ad2/./acarsdeco2 \
 --device-index 1 \
 --gain 49.6 \
 --freq 131550000 131725000 \
 --http-port 8686 \
 --outConnectUdp pp:xxx.xxx.xxx.xxx:9742 \

.
I cannot check it, as I dont have plane plotter on my windows.
However I did above modification to ad2.sh and started acarsdeco2. It seems to start sending data to a non-existant planeplotter, as shown in second-last line below:

pi@raspberrypi:~/ad2 $ ./ad2.sh
AcarSDeco2 v.20180603
Using device:  1 mnf: Realtek prod: RTL2832UFA serial: 00000001
2018-07-22 11:20:53.213  INFO     outConnectUdp(PP:192.168.0.10:9742) started
Sampling rate: 1400000.018544 sps
Supported Gains (dB):  0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6
Freq: 131.637 MHz
Freq Correction: 0 ppm
Gain: 49.6 dB
2018-07-22 11:20:53.846  INFO     outConnectUdp(PP:192.168.0.10:9742) start sending
Trying to use 16 buffers in memory explicitly allocated to support zero-copy

#6

exactly ! it works, provided the user has enabled port forwarding for port 9742 in his/her router for the IP of the machine running Planeplotter.


#7

So far success. I forgot about the port forward. When I did configure my modem I had to use my lan ip address instead of the local ip. now to finish up.


#8

Also remember to select what type of connection, for example TCP or UDP. UDP is the correct one.


#9

@glennblum
@evangelyul

I have just now edited the how-to and made following modification:

The name of the folder which holds AcarsDeco2 files was originally ad2.
I have now changed it to acars.

This is to avoid confusion as name ad2 was used for a folder as well as for the script file ad2.sh.

Now folder name is acars and script file name is ad2.sh.


#10

I am having a problem. when I cun the command line test all is great. acarsdeco2 is providing data to my copy of planeplotter. When I set it up to run the ad2.sh automatically the program runs but no data input to my copy of plane plotter.

/home/pi/acars/./acarsdeco2
–device-index 1
–gain 19.7
–freq 131550000 131725000 131875000 131125000
–http-port 8686
–outConnectUdp pp:192.168.0.100:9742

While running a test:
./acarsdeco2 --device-index 1 --http-port 8686 --gain 19.7 --freq 131550000 --freq 131725000 --freq 131875000 --freq 131125000 --outConnectUdp pp:192.168.0.100:9742


#11

.
Try following:
.
(1) In file ad2.sh, delete the above code, and COPY-PASTE the code given below:

/home/pi/acars/./acarsdeco2 \
  --device-index 1 \
   --gain 19.7 \
  --freq 131550000 \
  --freq 131725000 \
  --freq 131875000 \
  --freq 131125000 \
  --http-port 8686 \
  --outConnectUdp pp:192.168.0.100:9742 \

.
(2) If above fails, then in file ad2.sh, COPY-PASTE the single-line code given below:
It is a long line. Scroll right to see it in full.

/home/pi/acars/./acarsdeco2 --device-index 1 --http-port 8686 --gain 19.7 --freq 131550000 --freq 131725000 --freq 131875000 --freq 131125000 --outConnectUdp pp:192.168.0.100:9742    

#12

No luck with either configurations, however the program runs in either way. I still dont get UDP traffic to PP under the ad2.sh.


#13

.
Try again after adding sudo at start of first line in file ad2.sh. The first line will then become like below:

sudo /home/pi/acars/./acarsdeco2 \

#14

Still no luck.I even checked my port forward just incase. but right now I have PUTTY open up as a terminal running the command line and it works sending data to Plane Plotter but if I use ad2.sh no luck.


#15

No idea why this is happening :confused:
Hopefully someone else comes up with a solution.


#16

abcd567,
Your help (like always) is very appreciated!


#17

abcd567, is it possible that running the program from the command line with a console is the only way to have output across a local domain? Right now I am running dumpvdl2 from the Pi’s command line console with Udp output to Plane plotter on my windows computer.


#18

@glennblum

I have no idea. Never tried this.


#19

I suppose you have run sudo chmod +x ad2.sh ?
do you see acars messages in the web interface ?
one thing to note, the frequencies should not be spaced longer than 1Mhz, ie 131.5 132.5 or 136.9 (vdl)


#20

Thank you… works like a charm