FlightAware Discussions

HELP: Multiple data collection on single pi

For some time I have had a few raspberry pi devices independently collecting aviation data and making these available to various other places.

With the pi4 having a bit more oomph I’d like to combine things a bit and then place them up on my roof to give better coverage than some currently have.

I have seen several websites which talk about various combinatios but mostly they seem to be written for people who are comfortable with linux - that isn’t me.

Is there a simple guide somewhere that shows how to install and run a multiple data system on a single pi?

I would like it to have:
adsb (it will replace my current feed to flightaware)
acars
vdl2
rtl-airband (to feed single channel from local airfield)

Powering it all/antennas etc. aren’t a problem and I already have all sorts of sdr kit (all serialised for convenience/or by design), it’s the getting the software all onto the same device and using it’s own receiver that I need help with.

TIA

Download and burn Piaware SD card image to microSD card
Howto : Piaware SD card image 3.8.0 Quickstart Guide

.

Issue following command, and it will install and configure AcarSDeco2 on RPi

sudo bash -c "$(wget -O - https://raw.githubusercontent.com/abcd567a/ad2/master/install-ad2.sh)"       

For instructions:
https://github.com/abcd567a/ad2/blob/master/README.md

NOTE: You will need to serialize dongles so that correct dongle is picked by each software. Use method in following post, and choose a different serial number for dongle you want to use for AcarSDeco2, such as 00001234

How-to Serialize Dongles for ES1090 + UAT978

Then do this:

sudo nano /usr/share/ad2/ad2.conf 

## In the file opened by above command, 
## the 4th line (`--device-serial 00001234`) will not be there. Add it

--freq 131550000
--freq 131725000
--http-port 8686
--device-serial 00001234

.

This may help:

January 15, 2020
Using a KerberosSDR to Monitor Air Traffic Control Voice, ADS-B, ACARS & VDL2 Simultaneously on a Raspberry Pi 3B+

It may be possible to use 4 DVB-T Dongles connected to RPi, instead of following 4-channel SDR

Thanks.
Now that the piaware image is based on Buster it’s a reasonable starting point instead of a pi foundation image.
All of my devices are uniquely serialised (allows me to store the chipset and other data easily) so that’s not a problem.
I currently use TLeconte acarsdec and will check that it can take the device serial as an ID. If not I’ll have a look at the one you suggest.

All the bits and pieces collected on the desk ready…
It looks straightforward enough…but I often think that with linux stuff and end up with nothing working :wink:

AcarSDeco2 on my RPi Model 2B running Piaware SD card 3.8.0 (Buster)


.

.

1 Like

Some progress made. Though I’ll be using a Pi4 and have been building based on that I have tested the SD card in the Pi3 that is running my flightaware feed. It’s not a busy time of day but:
dump1090-fa
dumpvdl2
acarsdec
rtl-airband
are all running with individual rtl devices on the single Pi. Outputs not yet exactly how I want them but that can wait until the morning.

Thanks to @abcd567 for the pointers and the confidence boost to try it :wink:

Glad to know you are progressing. :+1:

.

Can you please briefly tell how you installed above three?

I now have a completely different problem in that everything was working fine when tested then but today when I have time to go back to it it’s as though only piaware is on the SDcard. Other software including the wiedehopf auto-gain has disappeared. I tried instaling dumpvdl2 again but get fatal errors when I run cmake. This is why I get frustrated with linux and give up :frowning:

The answer to your question seems a waste but:
I installed them one at a time following the instructions as given. To keep things simple I started with a brand new image downloaded from flightaware then installed the other software in turn making sure all the pre-requesites were installed first. Tested it all using two powered hubs to make sure the rtl-devices would get enough juice and all seemed well (except the display of things but that wasn’t an immediate cocern).
At this point I installed ‘wiedehopf’ auto-gain script and ran it manually with the result saying that the gain wasn’t adjusted as it was withing range at 2.blah% (can’t remember the exact wording)

How can it be that days later is it as though only piaware is present (and feeding fine)? Does flightware completely overwrite the image during an update? If so, why would it do something so idiotic?

I dont think so, but if you feel that way, better download the Raspbian Lite image, and write to microSD card.

https://downloads.raspberrypi.org/raspbian_lite_latest

Then install packages of piaware and dump1090-fa as per instruction here:

https://flightaware.com/adsb/piaware/install

 

I don’t have a problem installing raspbian from the foundation - all of my other pis are set up from that - piaware image only used on this occasion as it seemed a simple way to start from scratch on something that would be primarily for piaware (and they had updated the base version).

I cannot see any way that all the additional stuff would have disappeared except by intervention from flightaware updates. The device hasn’t been touched since the weekend and the only things running on it were the autogain script and dump1090-fa (along with anything those things might happen to use).
I can’t see any logical reason why such updates would work that way.

The next thing will be to set up an SD card with everything EXCEPT the piaware stuff and leave that on the windowsill doing nothing for a week to see if that suffers from strange vanishing software. If it doesn’t I’ll manually add in dump1090-fa and see what happens then.

Being able to feed to flightaware isn’t of any importance to me in as much as I don’t use flightaware for anything.

We don’t do anything like that on an update; updates are literally an “apt-get install” or “apt-get update” and the packages won’t touch anything outside the files they own (you can check for which files the packages own via e.g. dpkg -L piaware). We also haven’t pushed out any auto-updates recently anyway, so unless you manually requested an update, no FA updates will have happened recently.

I would be suspicious about your sdcard; it’s not unheard of to get counterfeit sdcards that e.g. are smaller capacity than claimed and just outright throw away data written to them. Things will appear to “work” until a reboot.

Yes, seemed odd that flightaware would do something so drastic.

No reboot by me after it was left running at the weekend.
autogain script run manually (via putty) once after a couple of days with same result as initially - gain deemed ok and not changed.

Device left running and was still running yesterday when I logged in to start looking at getting all of the data in a more useable format. At that time it was still feeding flightaware - you’ll see it still is.

SD card is fine, genuine Lexar with which I have never had a problem (used in my work life as well).
Out of interest I have written 10GB of photographs to the SD card (it’s still feeding) and then copied them back randomly without any issues. If the card was incorrectly reporting it’s size it would not be able to store the photos. Rebooted. Photos still retreivable.

Only custom ports allowed except for piaware which is largely flightaware default settings. Router locked down to mac addresses as well as wpa.
One thing I did notice was that my ISP had a four hour outage on Monday morning ‘for essential maintenance’. I don’t know if that was all services or just some aspects.

Really don’t understand this but as I said to start with…I’m not comfortable with linux. Without abcd567’s gentle encouragement I probably wouldn’t have even tried to do this.

I’m currently setting up another card and that won’t have piaware on it. If that behaves I will try adding piaware back. If it doesn’t then piaware won’t be having it’s antenna on the roof. Feeding companies like flightaware has always been ‘because i can’ rather than any kind of need or interest.

@morfis

I understand your concern. The incident has naturally upset you, but I am fully convinced what has happened is NOT caused by piaware/flightaware.

I am running 2 Pis for last 5 years with piaware + other data feeders, and never had any such thing caused by piaware.

New card set up and everything installed. dumpvdl2 and acarsdec working fine for two hours rtlsdr airband works but not left running.
So I have now put dump1090-fa on it (not feeding to flightaware but the original should still be doing so).

Post edited:
dump1090-fa / acarsdec / dumpvdl2 running simultaneously on single pi3

Bear in mind they are using the same antenna via a multicoupler and that antenna is tuned for 4m so not suited to this application (just not in use so convenient for some signal).

1 Like

soory to jump on this tread late in the day but id like to doo exactly this i have a pi feeding serveral ads-b sites using a single dongle but id also like to decode acars as well what else do i need to do this im fairly linux ok and can folllowish instructions

so just need to know what else i need and what packages i need im running pi24 as an os its basied on buster im feeding flightaware ads-b exchange and flight24 atm

thanks

One more (dongle + antenna) for ACARS.
You cannot use (one dongle + one antenna) for both ADSB 1090 MHz and ACARS.

(1) You will need to serialize two dongles so that respective softwares (dump1090-mutability & AcarsDeco2) pick the right dongle which has the respective antenna connected to it.

(2) Install AcarsDeco2

As you are using Pi24 image, follow these steps:

1- Serialize dongles:

1.1 - Put label ASDB and Acars on respective dongles
1.2 - Give command sudo apt install rtl-sdr
1.3 - Unplug both dongles
1.4 - Plug only the dongle which you want to use for ADSB
1.5 - Give command rtl_eeprom -s 00001090
1.6 - Unplug ADSB dongle and plug Acars dongle.
1.7 - Give command rtl_eeprom -s 00000133
1.8 - Unplug and replug both dongles

2 - Configure Pi24 to make its dump1090-mutability to use dongle 00001090

2.1 - Give command sudo nano /etc/fr24feed.ini
2.2 - In file opened look for a line proargs="--net --gain -10". If the line is there add device-index to it to make it as follows
procargs="--net --gain -10 --device-index 00001090 "

If line starting with procargs= is not there add this line below the last line
procargs="--net --gain -10 --device-index 00001090 "

2.3 - Save file
2.4 - Restart fr24feed sudo systemctl restart fr24feed

3 - Install AcarsDeco by bash script below:

sudo bash -c "$(wget -O - https://raw.githubusercontent.com/abcd567a/ad2/master/install-ad2.sh)" 

4 - Configure AcarsDeco2 to use Acars dongle 00000133

4.1 - Give command sudo nano /usr/share/ad2/ad2.conf
The file opened will be as below:

--freq 131550000
--freq 131725000
--http-port 8686

4.2 - Below the last line add this line
--device-serial 00000133

4.3 - Save file
4.4 - Restart AcarsDeco2 sudo systemctl restart ad2
4.5 - Open browser and go to IP-of-Pi:8686 to see Acars map & data.

1 Like

thank you for the info that was very helpful

but just one question …
my ini file for fr24 looks like this
bs=“no”
raw=“no”
mlat=“yes”
mlat-without-gps=“yes”
logmode=“2”
receiver=“beast-tcp”
procargs="–gain -10"
fr24key=xxxxxxxxxxxxxxxxxx
host=“127.0.0.1:30005”
receiver=“beast-tcp”

as i run flightawre and ads-b exchange are the changes you say ok with that set up and also do i need to change the ini/configs for flightaware and ads-b exchange? as all3 share the same dongle

i have ordered a second dongle :slight_smile: :grinning:

@ahellary

The dongle is used by dump1090-mutability only. The feeders simply pick & use the data which dump1090-mutability makes available at port 30005

In Pi24 image by FR24, the dump1090-mutability’s settings are controlled by fr24feed by passing to it parameters contained in the line progargs=".....".

Dont worry about settings of other feeders. Leave them as they are. Feeders like piaware, adsbexchange, etc settings are only for themselves, and have nothing to do with settings of dump1090-mutability or fr24feed.

thanks as soon as the second dongle arrives i will tinker

@ahellary

As you are using FR24’s PI24 image, one peculier thing I would like to point out is that all the parameters in the file /etc/fr24feed.ini control the fr24feeder, except the parameters in the line procargs="....", which are exclusively for dump1090-mutability.

The integral dump1090-mutability of FR24 image has it’s file /etc/default/dump1090-mutabilty disabled, hence any parameters added there by user are not implemented. Even the auto start of dump1090-mutability at boot by init.d or service or systemd is blocked, and it is started by fr24feed when fr24feed starts.

You can confirm that the line procargs="..." is for dump1090-mutability by following method:

In file etc/fr24feed.ini, add your latitude and longitude to the existing line procargs="--gain -10" so it becomes procargs="--gain -10 --lat xx.xxxx --lon yy.yyyy" (use actual values in place of xx.xxxx & yy.yyyy). Save file, restart fr24feed. Now open your web browser and go to address IP-of-PI/dump1090/. Reload the browser, and the map will start showing your station marker and 3 circles of radius 100, 150, and 200nm centered at your station location. :slightly_smiling_face: