FlightAware Discussions

DUMPVDL2 and ACARSDECO2 on the same PI3

I have a extra Pi3B and I want to run two dongles at the same time. one running DUMPVDL2 and the other one ACARSDECO2. I have tried but I get a error 6 with the opening of the dongle resources.
Please help!
Raspian Stretch with RTL-SDR Blog V3 dongles.

1 Like

Please specify how you start both programs / which command lines you use.

./dumpvdl2 --rtlsdr 1

This should make dumpvdl2 use the second dongle.
If you have different antennas connected you might need to physically swap the dongles.
(remove the power before swapping the dongles)

As far as i can find for acarsdeco2 you can’t specify the dongle so you’ll have to use the first dongle (index 0) with it.

1 Like

For dumpvdl2 I open up a command window and run this line on the Pi Stretch;
dumpvdl2 --rtlsdr 0 --gain 40 --correction 0 --output-acars-pp

for ACARSDECO2 I opened up a command windows and ran this;
./acarsdeco2 --device-index 1 --gain 49.6 --freq 131550000 131725000 131875000 131125000 --http-port 8686 –outConnectUdp pp:

Hold on I re read you last comment. Let me go back and fix the device

It may well be that acarsdeco2 only supports the device-index on the Windows version.

Anyway if you have a usb claim error maybe something else is using the dongle?
Did you install any dump1090?

Dump 1090 not installed and as for the ACARSDECO2 I used the command to install it on my pirtl%20failure


As neither of them is working maybe you need to blacklist the kernel driver?

As root open the file /etc/modprobe.d/rtl.conf and past this:

blacklist dvb_usb_rtl28xxu
blacklist rtl2832
blacklist rtl8xxxu
blacklist rtl8192cu

Save and reboot and check again.

You might also need udev rules so you don’t need root to access the receivers.

sudo wget -O /etc/udev/rules.d/rtl-sdr.rules "https://raw.githubusercontent.com/osmocom/rtl-sdr/master/rtl-sdr.rules" 
sudo reboot

If rtl_test works for you it’s probably just the blacklist thing.
rtl_test can detach the kernel driver while some other programs seem to be unable to do that for whatever reason.

Edit: A small note on putty:
you can just mark text and it will be copied. then Ctrl-V it here into the text input.
To format it use the 6th icon above the text input.

1 Like

I am a noob to Linux how would I do the black list as per command?

sudo nano /etc/modprobe.d/rtl.conf

paste the blacklist stuff from above
Ctrl-X to exit, yes and enter to save.

That’s pretty much the process for editing any file with nano.
There are other editors but they are mostly regarded as more complicated.
(If you are ever bored start the program vimtutor :slight_smile: )

1 Like

So far ACARSDECO2 is working. Now to make both programs to run on boot would be great.

Just create systemd services for both:

The command you are using right now goes after ExecStart=

If you can’t get it to work i’ll take a look tomorrow.

1 Like

I appreciate the help and will let you know.

here is how I get acarsdeco2 ro run on boot; (I coppied this from FA forums from previous)

STEP-6 : Automated start at boot / reboot
6.1 - Create a blank file ad2.sh, make it executable, and open it for editing

pi@raspberrypi:~ cd acars pi@raspberrypi:~/acars sudo touch ad2.sh
pi@raspberrypi:~/acars sudo chmod +x ad2.sh pi@raspberrypi:~/acars sudo nano ad2.sh
6.2 - Copy-paste following code in new blank file ad2.sh

–device-index 1
–gain 49.6
–freq 131550000 131725000
–http-port 8686
6.3 - Save (Ctrl+o) and Close (Ctrl+x)

6.4 - Open file rc.local for editing

sudo nano /etc/rc.local
6.5 - Copy-paste following line in file rc.local just above last line (i.e. just above exit 0)

/home/pi/acars/ad2.sh &
6.6 - Save (Ctrl+o) and Close (Ctrl+x)
Now is this possible for DUMPVDL2?

Try and do it with service files, it’s much more useful.
It’s not any more complicated than what you posted.

Also those instructions you posted are out of date and won’t work as rc.local is not active anymore by default when using Raspbian Stretch.

1 Like

This is where I get into trouble. LOL!
I dont know where to start. What I got above was copied from a post.

To make rc.local active:

sudo chmod +x /etc/rc.local

# Restart rc-local
sudo systemctl start rc-local

# OR reboot to restart rc-local
sudo reboot
1 Like

You start by creating a service file /etc/systemd/system/foo-daemon.service

In your case you should create two, /etc/systemd/system/acars.service and /etc/systemd/system/dumpvdl.service

Then you put this minimal unit file stuff into it.




If something is named foo it means you should replace it with something appropriate.
The description doesn’t matter.
And i already wrote what the ExecStart= should be, the command line to start the program
with full path in front of it and all the options, for example

ExecStart=/home/pi/acars/acarsdeco2 --device-index 0 --gain 49.6 --freq 131550000 131725000 131875000 131125000 --http-port 8686 –outConnectUdp pp:

The link i posted then tells you how to restart the service and enable automatic starting on bootup. You don’t need to understand all of the page…

With the rc.local you can’t look at errors and if the program crashes it’s not restarted.

That’s a service file like you could use it:


ExecStart=/home/pi/acars/acarsdeco2 --device-index 0 --gain 49.6 --freq 131550000 131725000 131875000 131125000 --http-port 8686 –outConnectUdp pp:


Just use

sudo nano /etc/systemd/system/acarsdeco.service

and paste the above.

Then enable it so it starts on boot:

systemctl enable acarsdeco

(the name is acarsdeco because you used that as the name of the .service file)


I did read the link but you have to remember I am novice at Linux and probably decent at Windows and best at aircraft composites and structure repairs.
I am going to follow your instructions to a T. I do appreciate the help and the instructions.


Sorry, my tone wasn’t called for!
I’ll have to just make a guide aimed at novices for the future!
I have to agree the link does have quite some stuff in it which is confusing and not helpful for the task at hand.

1 Like