FlightAware Discussions

How-to Get VRS-Like Coverage Map on RPi


#123

Here’s how you do it:
See posts 123 & 124 in this thread.


#124

I tried method in the web page linked by you, but could not succeed. It says “Invalid Credentials”

Can you please post a full wget or curl command to download following latest file directly to Pi?
modesmixer2_rpi2-3_deb9_20180616.tgz

Thanks in Advance.


#125

@xlr99
Never mind, found it after lot of Googling :slightly_smiling_face:

GENERAL FORMAT TO DOWNLOAD PUBLICALLY SHARED FILES FROM GOOGLE CLOUD STORAGE

sudo wget -O path/to/folder/[NAME OF FILE TO BE DOWNLOADED] "https://drive.google.com/uc?export=download&id=[FILE ID]"

EXAMPLE CASE

[NAME OF FILE TO BE DOWNLOADED]:
modesmixer2_rpi2-3_deb9_20180616.tgz

Google Cloud Page for downloading "modesmixer2_rpi2-3_deb9_20180616.tgz":
https://drive.google.com/file/d/1lV_tUMVIj_CvM3kxdkk8PX2pLLAJskw_/view

[FILE ID] (extracted from above link):
1lV_tUMVIj_CvM3kxdkk8PX2pLLAJskw_

Full assembled wget command:
sudo wget -O ~/mm2/modesmixer2_rpi2-3_deb9_20180616.tgz "https://drive.google.com/uc?export=download&id=1lV_tUMVIj_CvM3kxdkk8PX2pLLAJskw_"


#126

Here ya go:

wget ‘https://docs.google.com/uc?export=download&id=1lV_tUMVIj_CvM3kxdkk8PX2pLLAJskw_’ -O mm2

Be sure to include the quote marks and the -O mm2 (mm2 = downloaded filename)

Tried it on a Debian Stretch box (9.4) and it worked like a champ.


#127

Yep. Essentially the same thing. thumbsup
I was just about ready to make my post, when you posted yours. :wink:
Hopefully, it’ll save a few folks some time.


#128

From me the one who has very little knowledge of of Linux. How do I simply putty the latest version om MM2? Of course without screwing up my installation I have right now?

Thanks,
Glenn


#129

Are you comfortable using SSH to access your Pi?


#130

very. as long I get the correct lines to input.


#131

I am still learning but people like abcd567,evangelyul, dxista and a few others I had followed what they had posted and I followed with good success.


#132

OK, that’s half the battle, so-to-speak.

abcd gave an example in post 123:

sudo wget -O ~/mm2/modesmixer2_rpi2-3_deb9_20180616.tgz "https://drive.google.com/ \ uc?export=download&id=1lV_tUMVIj_CvM3kxdkk8PX2pLLAJskw_"

The \ character at the end of the fist “line” signals bash the text on the next line is part of the command. i.e. as it were written all on one line. So be sure you include it if you don’t type the command all on the same line. (abcd typed his example all on the same “line” but the line got wrapped making it look like two lines)

If you do type the entire command on the same line, you don’t need the \ character.
Note: in this instance, one line, or the same line means typing all of the text, disregarding any line wrapping that may occur, then hitting Enter

That’ll do the download. If the directory you have the app in is the same as the one in the download command, it’d be a good idea to make a copy of the current version before you do the download.

Otherwise, download the file untar it and reboot.


#133

Rebooted and ready to move on


#134

You missed last step

cd ~/mm2

sudo tar xvzf modesmixer2_rpi2-3_deb9_20180616.tgz 

sudo reboot


#135

Yep, sure did! Thanks for catching that.


#136

got it and works like a charm. You both I want to say I appreciate your help.


#137

Good to hear it.
YVW, S!


#138

@xlr99
Thanks for raising the issue to directly wget from Google Cloud Storage.

By the way, did you try adding this feature?

How-to Read / Set Gain from SkyView and Gmap

.
@glennblum
Glad to know it worked for you.


#139

I have not gone after the gain part as of yet.


#140

I’m in a rural area (small town, pop 900) and the nearest RFI is 25+ miles away. The high power sources are a bit more than twice that. When I first set it up, I experimented with various gain settings for a couple of weeks. Turned out that the setting that works best is AGC. So, something of a set it and forget it affair.


#141

Just changed to PIAWARE stretch and reloaded modesmixer and it seems to be running fine.

so far :slight_smile:


#142

The latest version for “Pi2/Pi3+Stretch” is
modesmixer2_rpi2-3_deb9_20180616.tgz.

Did you download the above noted latest version, or older version below:
modesmixer2_rpi2-3_deb9_20170924.tgz