FlightAware Discussions

How-to Get VRS-Like Coverage Map on RPi


#103

Just updated to piaware 3.6.2, and on the RPI2b I had MM2 running before the update, but after for some reason the location string in mm2.sh doesn’t appear to be seen. the map works but no location tie-point appears and range contours of course won’t work. Here’s the file I have:

#!/bin/sh
cd /home/pi/mm2/
./modesmixer2 --inConnectId 127.0.0.1:30005:ADSB --inConnectId 127.0.0.1:30105
:MLAT --web 8787 --location 49.xxxx:97.xxxx

x = decimal degrees Am I missing something obvious?


#104

@ve4gls

ModeSMixer2 does NOT share the map and settings with dump1090-fa. Something going wrong with ModeSmixer2 map after upgrade of dump1090-fa/piaware seems purely coincidental.

  1. Try after Clear Cache (Ctrl+Shift+Delete) and Reload (Ctrl+F5) the Browser.

  2. If above does not solve the problem, delete all contents of file mm2.sh, then either type or copy-paste the code again, Save (Ctrl+o), Close (Ctrl+x), then Reboot PI.


#105

@abcd567
Made new file mm2.sh c/p text as directed. Now not working at all after reboot. Get this msg when attempting to run manually:
pi@piaware:~/mm2 ./mm2.sh & disown [1] 791 pi@piaware:~/mm2 ./mm2.sh: 3: ./mm2.sh: ./modesmixer2_rpi1: not found

I suspect a typo or extra space somewhere. I’ll look through the files again and if I can’t find anything I will remove MM2 and re-install it from scratch. Not a huge deal, the main piaware seems to be working just fine.
Nice day here… I need to go outside… :slight_smile:


#106

Above code is for Pi B+.
It seems you used it for Pi 2 / Pi3 by mistake.

For RPi 2/3, please COPY-PASTE following text to blank file mm2.sh

EITHER THIS:

/home/pi/mm2/modesmixer2 \
 --inConnectId 127.0.0.1:30005:ADSB \
 --inConnectId 127.0.0.1:30105:MLAT \
 --web 8787 \
 --location xx.xxxx:yy.yyyy \

.
OR THIS

#!/bin/sh
cd /home/pi/mm2/
./modesmixer2 --inConnectId 127.0.0.1:30005:ADSB --inConnectId 127.0.0.1:30105:MLAT --web 8787 --location xx.xxxx:yy.yyyy

In above code, replace xx.xxxx by your latitude, and yy.yyyy by your longitude


#107

Ok… it’s working now. Only issue is that I seem to be located in northern Mongolia. I’ll put a minus (-) sign in front of the longitude and see how that works… and what do you know… It does!
Thank you for your patience @abcd567!
I suspect that might have been my original problem, missing that minus sign. Don’t think I zoomed out when I first noted the problem. Oh well…


#108

On your longitude if you are in the US, use a - in front of the first number. my long is -97.7273


#109

my first Pi 3
i set up exclusively for Pi aware and feeding Flightaware fully and no other feeding programs. My second Pi 3 I have ADSB-Reciever project DUMP1090 mutability feeding FR24 and Plane Finder. The
piAware shows green MLAT aircraft on modesmixer2, the second Pi 3 with Dump1090 mutability I dont see MLAT aircraft on its copy of modesmixer, just white aircraft icons. Is my set up wrong or that is what I get?

Glenn


#110

The second Pi is not receiving MLAT data, it’s sent by FA, you are not connected to FA with it. It should only show as mode S.

FR24 will calculate MLAT for its own use, but not feed back. Planefinder, I don’t know, I don’t remember about MLAT when I fed to it.


#111

Did you enable MLAT in your My ADS-B page?

Go to https://flightaware.com/adsb/stats/user/, select the Pi which does not show mlat, click gear icon, and on configuration pop-up enable mlat.


#112

I thought he said the second Pi is not feeding FA, only the first.


#113

Oops… I missed this point. bugs%20bunny%20doing%20a%20facepalm


#114

indirect work-around…

  1. on the pi WITH FA connection.
    copy / run modesmixer with following:
    --inConnect 127.0.0.1:30105 --outServer beastmlat:30205

  2. on the second pi WITHOUT FA
    add following to modesmixer
    --inConnect [IP of FA rpi]:30205

now MLAT from FA RPi will be displayed.
(ADSBexchange also returns MLAT, tried it in Canada with very good results.)

HTH
evangel


#115

It depends where in Canada. It was a no go in YOW last I tried. It’s ok in YYZ.


#116

I was in YUL - Cote Vertu - St Laurent

image


#117

I have ADSB Exchange installed but I have no clue if it is running. Actually I guess it isnt running because MM2 is not showing MLAT green.


#118

below near you appear on-line, so probably your feeder is off.
you can try from command line sudo service mlat-client restart or even reboot
to see if any change.

from http://www.adsbexchange.com/coverage-2/

image

evangel


#119

I bet that I dont have the client set up properly. Maybe it has something to do with the user name.Temple is about 20 miles to my east.


#120

sorry just noticed you are feeding ONLY through VRS.
I do too, but this is considered a ‘custom feed’ that wont appear on their feeder stats site.
so please disregard my earlier note. try as they advise in
https://adsbexchange.com/how-to-feed/custom-feed-how-to/

ED1: followed their instruction and got this

image

so guess will have to wait couple of days… will adv

evangel


#121

Late to the party with this, but thought I’d offer the suggestion for future reference.

Any file that can be downloaded via a web browser can be fetched via wget or curl
i.e. you can retreive them even if you don’t have a web browser installed.

Both wget and curl packages are available for Raspbian.

Here’s a How-To example:

wget http://www.example.org/files/archive.zip

will retreive the file archive.zip from the URL www.example.com/files
(note: the line above is only an example)

curl -O http://www.example.com/files/latest.tar.gz
does the same thing using curl
(again, the line above is an example)

Here’s another page with examples of how to use both wget and curl:
https://www.thegeekstuff.com/2012/07/wget-curl


#122

Thanks for the suggestion.

I had earlier tried wget, but it failed as the modesmixer2 files are hosted at Google cloud, which did not allow download by wget. You can try and see.

I however found a workaround for this situation: I uploaded modesmixer2 files to my dropbox, which allowed download by wget. I posted this method on Feb 2018. Please see the first post, item EDIT Feb 08, 2018