How-to Get VRS-Like Coverage Map on RPi


#143

Just checked, its the 80616


#144

Couple Questions, I have been trying to find in the forum for modesmixer but is there a way to turn on bandwidth and also a way to change date format to US version 8/11 vs 11/8


#145

My Modesmixer site is refusing connection

anyone else getting this today. My standard dump1090 works fine

This site can’t be reached

192.168.0.12 refused to connect.

ERR_CONNECTION_REFUSED


#146

Connection refused means that the server is not listening on that particular port.
I see it all of the time with firewalled connections where the service hasn’t been started but the connectivity is allowed.


#147

Yes a reboot fixed it. I wonder what caused it to crash ??? the Flightaware dump1090 didnt


#148

had same issue after a recent norton security update on my pc. not only blocked modesmixer but also ssh to rpi…:weary:


#149

Here is the ModeSMixer2 installation script I have prepared for myself. I would now like to share it to make things easy for others as well. However following points should be noted:

  1. The version of ModeSMixer2 which the script downloads from Google Drive is current version for Pi 2 / 3 Raspbian Stretch (modesmixer2_rpi2-3_deb9_20180616.tgz). When new version is released, the script will require updating.

  2. It is based on user pi (i.e. pi@raspberrypi or pi@piaware). The installation path is hard coded to /home/pi/mm2

STEP 1 of 4

Create a new file install-mm2.sh, make it executable, and open it for editing

sudo touch /home/pi/install-mm2.sh 
sudo chmod +x /home/pi/install-mm2.sh
sudo nano /home/pi/install-mm2.sh

.

STEP 2 of 4

In the new blank file install-mm2.sh, copy-paste code given below. Save file (Ctrl+o) and close file (Ctrl+x)
.

Following is the code to be copy-pasted in file install-mm2.sh

#!/bin/bash

echo "creating folder mm2"
sudo mkdir /home/pi/mm2

echo "downloading modeSMixer2 file from Google Drive"
sudo wget -O /home/pi/mm2/modesmixer2_rpi2-3_deb9_20180616.tgz "https://drive.google.com/uc?export=download&id=1lV_tUMVIj_CvM3kxdkk8PX2pLLAJskw_"

echo "entering into folder mm2"
cd /home/pi/mm2

echo "unzipping downloaded file"
sudo tar xvzf modesmixer2_rpi2-3_deb9_20180616.tgz

echo "creating starting script"
sudo touch /home/pi/mm2/mm2.sh

echo "writing code to file mm2.sh"
FILE="/home/pi/mm2/mm2.sh"

sudo chmod 777 $FILE

/bin/cat <<EOM >$FILE
#!/bin/sh
/home/pi/mm2/modesmixer2 \\
 --inConnectId 127.0.0.1:30005:ADSB \\
 --inConnectId 127.0.0.1:30105:MLAT \\
 --web 8787 \\
 --location xx.xxxx:yy.yyyy \\
EOM

sudo chmod +x $FILE


echo "writing start-up to file /etc/rc.local"
sudo sed -i '/fi/a \
\
/home/pi/mm2/mm2.sh & \
' /etc/rc.local

echo " "
echo " "
echo "INSTALLATION COMPLETE .....PLEASE DO FOLLOWING:"
echo "(1) Edit file /home/pi/mm2/mm2.sh and in the following line and"
echo "    rereplace xx.xxxx and yy.yyyy by your actual latitude and longitude"
echo " "
echo "    --location xx.xxxx:yy.yyyy \ "
echo " "
echo "(2) Reboot Pi"
echo " "

exit 0

.

STEP 3 of 4

Run the file

cd /home/pi
sudo ./install-mm2.sh

.

STEP 4 of 4

When script completes installation:
It will announce completion, and will also ask you to:

  • Edit file /home/pi/mm2/mm2.sh and replace xx.xxxx : yy.yyyy by yor actual latitude and longitude
  • Reboot Pi
    .
    .

Announcing PiAware 3! (Latest version: 3.6.3)
#150

Made it easier for RPI 2/3 running Stretch

Requires that you are user pi, i.e. like pi@piaware or pi@raspberrypi or pi@your_name etc.

(1) Download and run installation script

sudo apt-get install git

cd ~/  
git clone https://github.com/abcd567a/mm2.git 
cd mm2  
./install-mm2.sh  

.
(2) After installation is completed, give following command to open file mm2.sh for editing

sudo nano ~/mm2/mm2.sh  

In above file, replace xx.xxxx:yy.yyyy by your actual latitude and longitude.

Save (Ctrl+o) and Close (Ctrl+x)
.

(3) Reboot PI
sudo reboot
.

(4) Open your browser and type:
IP-OF-PI:8787

.


#151

Nice, thanks.
PS: What, abcd567 was taken on Github?


#152

YES, someone else has already taken abcd567, that is why I had to add an extra "a" after abcd567


#153

Rotten people :slight_smile:


#154

Identity theft.:sweat_smile:

I would check to make sure the girlfriend’s phone numbers you keep on the RPi are safe.:rofl:


#155

I just did a clone of the flight aware stretch and was going to add mode s mixer but it says unknown command GIT


#156

Hmm, my system already had Git. you can: sudo apt-get install git


#157

This happenes if git is not already installed. I have now added command to install git.


#158

Worked like a champ, Bought a new Micro SD card so I can have clean everything. Now its back up and running just fine.

Thanks for your hard work. Its the best.

Now if I could figure out how to get bandwidth going.


#159

Glad to know that you could install modeSMixer2 using the script.

The bandwidth meter measures bandwidth of output data . As your modeSMixer2 is not feeding anything like VRS or Basestation etc, the bandwidth meter will show zero.


#160

Hi all

I have managed to get modeSmixer2 working with no problems thanks to all the info everyone has posted :slight_smile:

I can now get stats similar to VRS when away from home

however is there a way to use leaflet maps instead of Google maps? im not keen on signing up for an API

on VRS I use leaflet maps and it works very well,

hopefully someone knows a way to use leaflet with modeSmixer2

cheers Mark


#161

In Radarspotting forum, there is a thread “ModeSDeco2 and ModeSMixer2 - console programs for RTLSDR and transcoding”, where sergsero (the author of modeSDeco2/modeSMixer2) often shows up and answers questions.

Incidently, I have posted this question there 3 days ago (CLICK HERE) , and am waiting for reply. Please keep checking there, and if sergsero gives an answer, please post it here for benefit of other members.
Thanks.


#162

Thanks adcd567 for info…and for allot of the useful info on this site.

I will keep an eye on radarspotting for related posts regarding this…I like you don’t want to sign up for a google code.

It’s a pity google decided to do this.

Cheers mark