FlightAware Discussions

Headless Want to add GUI

Hello All;
New user here, only been receiving ADS-B for about a week. My range was limited to 38 miles. I built a 16 section coaxial collinear, now my range is out to 125 miles which is all I want. Any further and I will get loaded with KBOS and KJFK traffic.

I am running a RPi 3B+. I aIm not a programmer nor a person who knows much of the RPi. I took a new 32GB SD card and flashed it with the programs Flight Aware says to download and use. All works fine. I don’t no how much RPi code is contained in that Flight aware down load. I have one monitor that displays the Flight Aware ALT 10 terminal display. But I have to use my Mac with Firefox and go to IP address 192.168.1.16 to display My Stats Page and my 1090
Skyward map. I can not tie up my Mac all night watching the 1090 Skyware Map Display.

In doing a lot of reading, I believe that I can get the RPi 3B+ to load software for a GUI. Presently I am running headless. If I can get a GUI going then I have a large screen monitor for 1090 Skyware
Map display or switch to terminal mode if wanted. I have read about many different ways to add code and bring up a GUI Screen/Session. Not being a programmer or really understanding Linux programming, I can NOT chance Hosing up this working system I now have. I can’t handle a big Ooops.

Is there any one reading this that has done what I want to do and not had any problems that can share with me the needed code to add in terminal session to bring about the wanted GIU.

Thank You
KS2K

First one in the search

1 Like

Install the GUI:
sudo apt-get install -y raspberrypi-ui-mods rpi-chromium-mods
sudo apt-get install lightdm chromium-browser xinit

from “sudo raspi-config” Configure boot option for GUI, boot with autologin

Clarence; Thanks so much. The install went with out issue.
I now have GUI, Chromium etc on boot.
I do have one issue I need help with. When I used my Mac to look at skyaware, I entered Pi@192.168.1.16 and I had skyaware up on the Mac. Now on the RPi GUI, I try to enter the above IP and the @ displays as a * and it will not allow me to put a . between the numbers in the IP address. What must I put on the RPi Command line to get it to go to Skyaware? Thanks so much
KS2K

try
chromium http://127.0.0.1:8080 &
from the CLI.

Check you have the correct keyboard type set. RPI may default to the UK keyboard, which is a little different to the US keyboard.

You could also set http://127.0.0.1:8080 as the home page in Chromium.

2 Likes

I feel a little silly. All is working BEAUTIFUL now. The Keyboard was bad. I got it at a yard sale, guess I now know why it was in the yard sale.

Please bear with me on one last question. I held this to last as getting the GUI running was priority. The colors on the screen are wrong. On boot the RED Raspberry is BLUE. On the home desktop wall paper of the cliff its a mic of blues and oranges. All very sharp just off color.
Yes, I know the display is good, It was running as a display for Ham Radio Software.

Thanks for the wonderful help
KS2K

On my pi, it’s chromium-browser, not chromium.

I not quite sure what you were doing on the Mac. If you were entering that in a Safari URL, the pi@ part wouldn’t be necessary. That launches a home window on my Pi, not directly into SkyAware.

If you have the GUI up on the pi, I would expect you to click on the Globe on the top bar to launch chromium-browser. Or click on the raspberry, then the globe, then Chromium.
In the URL bar, you could put localhost and click on SkyAware at the bottom, or localhost/dump1090-fa or localhost:8080

(you could put 192.168.1.16, the pi@ part isn’t needed)

From the black text terminal bash prompt, you could enter
chromium-browser localhost/dump1090-fa &
which would launch the browser

In the file /boot/config.txt
hdmi_force_hotplug=1
Remove the # from hdmi_force_hotplug if there is one, and reboot.

lots of useful hints for generic Raspberry Pi can be found by starting a google search with
raspberry pi …
or visit raspberrypi.org and search there.

1 Like