Follow up: PiAware under new IP address

So my unit is up and running, thanks for the help.

If I move it from my house to the garage, the router in the garage will assign it a new IP address (Xfinity in the house is on 10.0.X.X and have a single ethernet run to the garage with a NetGear (NG) Router that is on 192.168.X.X). I tried cleaning this up last weekend, but it doesn’t want to work if I turn the NG’s DCHP off even though the NG is technically hanging off of the Xfinity.

I assume that even with the change from 10.0.X.X to 192.168.X.X, FlightAware will still keep the PiAware PI assigned to my account since the MAC address and everything else will be the same?

Your local IP has nothing to do with your FA account. Your account is part of the feeder configuration.

2 Likes

Your LAN IP doesn’t matter. However, a cleaner setup would be to put your Netgear in Bridge Mode, not just turn off DHCP. Then everything would be on 10.0.x.x.

Try Advanced>Advanced Setup>Bridge Mode> Select Bridge Mode.

1 Like

I’ll try that (again?). I’m pretty sure I tried that also, but I upgraded the bios and reset it anout 5 times in that session. So maybe not. Thanks.

Your IP address (such as 206.253.81.28) or Local IP address (such as 192.168.0.15 OR 10.0.0.18) or Pi’s MAC address, has nothing to do in assigning Pi to your account.

It is the feeder-id stored in your Pi’s cache which determines the account to which the Piaware belongs to. You can display the feeder-id by following command:

cat /var/cache/piaware/feeder_id

The output of above command (feeder-id) will be in this format:
xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

 

 

Turning off DHCP and using Bridge Mode are two different things. It shouldn’t matter for what you’re doing though. As posted, FA doesn’t care about your LAN IP addresses.