Wrong Static IP Reported by FA for my Rasp Pi


#1

FA reports my PiAware is associated with my account and I should expect to see statistics after 30 min or so. But when nothing showed up even as FR24 was getting my feed I discovered a mismatch between my MAC address and IP address.

FA links the wired MAC address with the wireless IP I have assigned. I need to change it to the wired IP. (Don’t want to change the IP assignment in the router which FR24 is using OK).

I need to get into PiAware and edit the IP address but how do I reconfigure that? I have puTTy and can get into my RPi remotely. I think I need the sudo command that gets me to the setup.


#2

FA uses the eth0 MAC address as a unique identifier.
It does not care about the internal IP address. It should be listed later when the registration is completed.

Try a quick reboot. It can take 3 hours for the stats to show.
Does the internal webserver show aircraft?

Check the logs on the RPI. It can help with diagnosing the problem.

/var/log/dump1090.log
/var/log/messages
/tmp/piaware.out (soon to be /var/log/piaware.log )


#3

Thanks but I’m afraid I’m lost on most of it.

FA’s message is this:

Great news! Your account is associated with the following PiAware receivers and you can view your statistics here:
1**.b8:27:eb:xx:xx:b7**: PiAware (Debian Package Add-on) 2.1 added Wednesday, July 20, 2016 (205.XXX.58.204 / 192.168.1.63)

There will be no communication with FA unless 192.168.1.63 is changed to 192.168.1.62.

Either, I get FA to delete the reported setup and let it rediscover my hardware or I need the command to manually change the IP within PiAware.


#4

On which address you are able to get into RPi using PuTTY, 192.168.1.63 OR 192.168.1.62 ?


#5

I log in with puTTy and Windows Remote Desktop with 192.168.1.62. My RPi, computer and internet modem are all wired. (Wireless access is also possible and that might be why FA grabbed the wireless IP.) FR24 works fine.


#6

Why not disable wireless access if you have a wired access? This will force FA to grab your wired local IP address. Once FA grabs your Pi’s wired IP, you may again turn on wireless, and watch what happens.


#7

FA does not use 192.168.1.62 or 192.168.1.63. Those links are for your internal use only. If you know one will work but the other won’t, just set yourself a bookmark to the one that works. You won’t be able to click on the other one, but you will be able to get the same result by accessing the bookmark (or typing in the IP directly). Perhaps inconvenient to you, but that shouldn’t affect your feed to FA. FA only uses your external IP, which is the 205… one.


#8

I thought about that and research it. Seems tricky.

The problem is that FA’s server has the device with MAC b8:27:eb:xx:xx:b7 and IP 192.168.1.63 in it’s data base. It links it to me as account user Robbwell because we share the same internet IP. By email I’ll try to get FA to delete that.


#9

The internal IP is only used for reporting. It’s not used to link new receivers (the externally visible IP is used; this is unreliable as you discovered) and it’s not used when making outgoing connection (piaware just establishes a tcp connection and lets the os pick the source address)