Flightaware Piaware github issue?


#1

Hi,
This afternoon working with Joe’s adsb scripts, I and others have noted an error with installing Flightaware PIaware files via github. Now I am not sure if the problem is with Joe’s setup of whether his install goes elsewhere to install the Flightaware Piaware files on his setup.


#2

.

Joe’s script use “piaware_builder” source-code which contains file “sensible-build.sh
.
.


#3

That link apparently is where the problem is.


#4

Did you run sensible-build.sh ?


#5

I have never used that script:

Joes instructions:\

sudo apt-get update
sudo apt-get install git
git clone https://github.com/jprochazka/adsb-receiver.git ~/adsb-receiver
cd ~/adsb-receiver
chmod +x install.sh
./install.sh

There’s got to be something more wrong with Flightaware feed, during the install process, you are only offered the 1090 mutability feed, the 1090 flightaware feed option is missing.


#6

When I used Joe’s script I noticed that it didn’t offer to install any 1090 feed. I had the FA 1090 installed previously (at that time), and it continued to work after running the script.


#7

Run the script again, most likely this time it will offer the feeders which are not yet installed. It wont offer feeders which are already installed.

cd adsb-receiver
./install.sh

#8

Ahh no. There is only 1 1090 been offered by Joe’s scripts and that it 1090 mutability, 1090 Flightaware is not showing as an option and given what happened yesterday, it will be the same result when you go to install Piaware Flightaware, it will fail. I have a micro half installed and again, it balked at the Piaware Flightaware. Something is majorly wrong with flightaware github for their mutability not been offered as a choice to start with and if you go with 1090 mutability, you will fail with associating that with Flightaware. We sit and wait again, no advice from the Joe side of things and the issue has also not received response from another who has raised the issue on the FA github.


#9

Update 2 days later, no update, same error occuring :frowning: