FlightAware Discussions

"Flash failed"

Maybe someone can give me some help here … I’m trying to set up my 5th feeder. When using Balena Etcher 1.5.120 and formatting a new Samsung 32gB “Pro Endurance” MicroSD card the result is always “flash failed.” This occurs immediately at the end of the verification process. I’m using Windoze 10 Pro. This is repeatable over and over.

I never had this issue previously. Any thoughts?

Did you try a different imaging program ? for example Win32 disk imager ?

Maybe that will solve the issue ?
I use it alongside balenaEtcher and I never had an issue with both of them.

Hi. Thanks. No. I guess that’s certainly worth a try. I was just following FA’s instructions – for now. ;<)
I appreciate the thought!

other option could be that you have a corrupted download. so maybe redownload the image if it fails on Win32 disk imager as well :nerd_face:

Not familiar with Windoz 10 but there must be some disk checking software available.

Maybe faint possibility dodgy SD card.

Geoff

I’ve seen the same failures with Balena Etcher. I suggest using Raspberry Pi Imager

I am flashing all my Raspberry images since years with Balena Etcher. Beginning with Windows 10, now running it on Linux.

I think i flashed my devices more than 30 times and never had issues with Balena Etcher.

For me the most likely reason is a corrupt SD card

I would erase the partition completely with diskpart (Windows 10), create a regular filesystem on that card with built-in functionality and then use Balena to write the image.
the Raspberry imager doesn’t do anything different, the only benefit is that you’re able to set the parameters for a headless setup

1 Like

All helpful information, guyz. The industrial MSD card was brand new so I was not primed to expect a failure. I was able to get it imaged using another computer running WIndoze 10. I dunno. It “worked” but I sure don’t know why. (You know the old saying … if you “fixed” something and don’t know what you did to do so – you probably didn’t. ;<) )

There could have been a failure in the sd-card reader or even in the storage where you downloaded the image to.
It’s somewhat unlikely but not impossible.

If it worked on another computer, then you might know the answer…

Having an “industrial card” also does not mean it is free of errors 100% of the time. It s only more unlikely but not impossible