Feeding data to FR24 using dump1090-fa


#1

I have been feeding data to FA using the standard install dump1090-fa on a Pi, and also feeding FR24 from dump1090-fa. However, a few weeks ago on one of my Pis, the FR24 feeder stopped whilst my two other Pis are fine. I’ve read various things on other forums about problems with a new FR24 feeder and dump1090 mutability but nothing about dump1090-fa

Could anyone simply suggest how I might resolve this problem? The Pi is running Raspbian Stretch.

Many thanks


#2

One of my Pi had dump1090-fa, and other dump1090-mutability ver 1.15~dev.

The dump1090-fa one is working ok even after upgrades of fr24feed.

The dump1090-mutability one failed as the fr24feed upgrade changed permissions and ownerships of dump1090-mutability files and folders. I had to format microSD card and make a fresh install, first dump1090-mutability ver 1.15 ~dev, then the latest version of FR24 feeder by bash script given on their site.


#3

Thanks. I’m using dump1090-fa on two Pis, one is still feeding FR24 the other failed. I was going to install the FR24 feeder software again but was worried I would create problsm after reading about dump1090-mutability


#4

First check which version is installed, and which is available:
apt-cache policy fr24feed

Purge, clean and reinstall:

sudo apt-get purge fr24feed
sudo apt-get clean
sudo apt-get update
sudo apt-get install fr24feed

Edit file fr24feed.ini
sudo nano /etc/fr24feed.ini

If following lines are not there, add these
receiver=“avr-tcp”

fr24key=“xxxxxxxxxx”
(replace xxxxxxxx by your actual key)

host=“127.0.0.1:30002”

Delete this line if there
receiver=“dvbt”

Save (Crrl+o) and close (Ctrl+x)

Reboot
sudo reboot


#5

Thanks, but still no joy


#6
  1. Check if dirmngr is installed.
    apt-cache policy dirmngr

    If it is not installed, first install it:
    sudo apt-get install dirmngr

  2. Check if fr24feed got installed.
    apt-cache policy fr24feed

    If it is not installed, install it:
    sudo apt-get install fr24feed


#7

Still no joy

Setting on both Pis are identical - both running the same version of FR24 feeder. The only difference is that the one that isn’t working is using Rasbian Stretch

Many thanks


#8
  1. What are settings in /etc/fr24feed.ini ?
    if
    receiver="dvbt"
    change it to
    receiver="avr-tcp"
    host="127.0.0.21:30002"
    Make sure to use 127.0.0.1, and not localhost

  2. If above does not help, first try:

    sudo apt-get install -f
  1. If above does not fix problem, try this:
    sudo apt-get purge fr24feed
    sudo apt-get clean
    sudo apt-get update


    sudo apt-get install -o Dpkg::Options::="--force-confdef" -o Dpkg::Options::="--force-confold" fr24feed


#9

Hi

I’ve tried all these but now I get an error message ‘unable to connect’ when I try to check the status


#10

Please post output of following 3 commands.
(when posting, for privacy reasons, remove value of fr24key from output of 1st command)

cat /etc/fr24feed.ini

sudo apt-cache policy fr24feed

fr24feed-status


#11

Hi
Please find attached a screenshot of the output

Thank you


#12

All your settings and versions are OK. The “Receiver : down …” is caused if dump1090-fa is not working. Are you sure dump1090-fa is working? Please check.

I checked mine on STRETCH, and got output as follows

pi@raspberrypi:~ $ sudo systemctl status dump1090-fa -l

● dump1090-fa.service - dump1090 ADS-B receiver (FlightAware customization)
   Loaded: loaded (/lib/systemd/system/dump1090-fa.service; enabled; vendor preset: enabled)
   Active: active (running) since Sat 2018-02-03 15:21:54 EST; 1h 35min ago
     Docs: https://flightaware.com/adsb/piaware/
 Main PID: 453 (dump1090-fa)
   CGroup: /system.slice/dump1090-fa.service
           └─453 /usr/bin/dump1090-fa --device-index 0 --gain -10 --ppm 0 --net-bo-port 30005 --max-range 360 --net --net-heartbeat

Feb 03 15:21:54 raspberrypi systemd[1]: Started dump1090 ADS-B receiver (FlightAware customization).
Feb 03 15:21:54 raspberrypi dump1090-fa[453]: Sat Feb  3 15:21:54 2018 EST  dump1090-fa 3.5.3 starting up.
Feb 03 15:21:54 raspberrypi dump1090-fa[453]: rtlsdr: using device #0: Generic RTL2832U (Realtek, RTL2832U, SN 00001003)
Feb 03 15:21:54 raspberrypi dump1090-fa[453]: Detached kernel driver
Feb 03 15:21:55 raspberrypi dump1090-fa[453]: Found Rafael Micro R820T tuner
Feb 03 15:21:55 raspberrypi dump1090-fa[453]: rtlsdr: enabling tuner AGC

.
.

pi@raspberrypi:~ $ sudo systemctl status piaware -l

● piaware.service - FlightAware ADS-B uploader
   Loaded: loaded (/lib/systemd/system/piaware.service; enabled; vendor preset: enabled)
   Active: active (running) since Sat 2018-02-03 16:02:10 EST; 54min ago
     Docs: https://flightaware.com/adsb/piaware/
 Main PID: 29021 (piaware)
   CGroup: /system.slice/piaware.service
           ├─29021 /usr/bin/piaware -p /run/piaware/piaware.pid -plainlog -statusfile /run/piaware/status.json
           ├─29073 /usr/lib/piaware/helpers/faup1090 --net-bo-ipaddr localhost --net-bo-port 30005 --stdout --lat 43.5  --lon -79.6
           └─29082 /usr/lib/piaware/helpers/fa-mlat-client --input-connect localhost:30005 --input-type dump1090 --results beast,con

Feb 03 16:37:46 raspberrypi piaware[29021]: 4531 msgs recv'd from dump1090-fa (579 in last 5m); 4531 msgs sent to FlightAware
Feb 03 16:42:46 raspberrypi piaware[29021]: 5186 msgs recv'd from dump1090-fa (655 in last 5m); 5186 msgs sent to FlightAware
Feb 03 16:47:16 raspberrypi piaware[29021]: mlat-client(29082): Receiver status: connected
Feb 03 16:47:16 raspberrypi piaware[29021]: mlat-client(29082): Server status:   synchronized with 107 nearby receivers
Feb 03 16:47:16 raspberrypi piaware[29021]: mlat-client(29082): Receiver:  110.6 msg/s received       36.9 msg/s processed (33%)
Feb 03 16:47:16 raspberrypi piaware[29021]: mlat-client(29082): Server:      0.2 kB/s from server    0.0kB/s TCP to server     0.5kB
Feb 03 16:47:16 raspberrypi piaware[29021]: mlat-client(29082): Results:  104.4 positions/minute
Feb 03 16:47:16 raspberrypi piaware[29021]: mlat-client(29082): Aircraft: 12 of 36 Mode S, 12 of 12 ADS-B used
Feb 03 16:47:46 raspberrypi piaware[29021]: 5846 msgs recv'd from dump1090-fa (660 in last 5m); 5846 msgs sent to FlightAware
Feb 03 16:52:46 raspberrypi piaware[29021]: 6477 msgs recv'd from dump1090-fa (631 in last 5m); 6477 msgs sent to FlightAware


#13

@NigelRichardson
I found the bug (I think!)
.

I am using this setting
receiver="beast-tcp"
host="127.0.0.21:30005"
All is ok

.

When I changed it to
receiver="avr-tcp"
host="127.0.0.21:30002"
FR24 failed just like you.
.
.

This is my setting which works OK

pi@raspberrypi:~ $ sudo nano /etc/fr24feed.ini

receiver="beast-tcp"
fr24key="xxxxxxxxxxxxxxxxxxx"
host="127.0.0.1:30005"
bs="no"
raw="no"
logmode="0"
windowmode="0"
mpx="no"
mlat="yes"
mlat-without-gps="yes"

#14

Yes working for me too

Thank you so much for all your help and patience, much appreciated

Nigel


#15

Raspbian STRETCH + dump1090-fa OR dump1090-mutability v1.15~dev + fr24feed ver 1.0.19-13

Setting-1: OK
receiver="beast-tcp"
host=“127.0.0.1:30005”

Setting-2: FAILS
receiver="avr-tcp"
host=“127.0.0.1:30002”

Setting-3: FAILS
receiver="beast-tcp"
host=“localhost:30005”

Setting-4: Creates a mess.
If by mistake setting is changed to receiver=“dvbt”, and fr24feed restarted or Pi rebooted, it creates a mess.

  • If you have dump1090-mutability v 1.15~dev, it gets replaced by ver 1.14
  • If you have dump1090-fa, it stays, but dump1090-mutability ver 1.14 also gets installed.

After cleaning this mess, I safeguarded against future disasters by following method :smile:

cd /usr/lib/fr24/

sudo mv install_dump1090.sh  install_dump1090.sh.getlost
sudo mv dump1090  dump1090.getlost


#16

Have dump1090-fa on Jessie. The following two settings work fine on it.

Setting-2: FAILS
receiver="avr-tcp"
host=“127.0.0.1:30002”

Setting-3: FAILS
receiver="beast-tcp"
host=“localhost:30005”


#17

@flightfinderr

Your OS is Jessie, mine is Stretch, that is one difference.

My fr24feed version is 1.0.19-13. What is the version of your fr24feed?

(Find out by command apt-cache policy fr24feed)


#18

@abcd567

I just wanted to mention that it works fine on Jessie for me. Version is 1.0.19-13.

Let me ask help on another matter. Installed dump1090-muta 1.15 dev on another Pi (Stretch), it doesn’t seem to get any data. Connected the same dvb-t dongle that currently feeds FA, FR24 etc but still no enjoy. Any tips on what I need to check? Possibly incorrect installation as IP/dump1090/gmap.html doesn’t load map either? Log shows it sees the dongle

Tue Feb  6 09:22:44 2018 UTC  dump1090-mutability v1.15~dev starting up.
Using sample converter: UC8, integer/table path
Found 1 device(s):
0: Generic, RTL2832U, SN: 7xxxxxxxxxxxxxx (currently selected)
Detached kernel driver
Found Rafael Micro R820T tuner
Max available gain is: 49.60 dB
Setting gain to: 49.60 dB
Gain reported by device: 49.60 dB

#19

@flightfinderr

The Stretch has many pains in neck. One of these is that dump1090-mutability fails to work on it unless a workaround is done.

Please see this post for the workaround:

https://discussions.flightaware.com/t/when-is-stretch-coming-to-piaware-sd-card-image-version/25990/9


#20

to make the fr24 feeder producing data for other feeders your have to go to localhost:8754 and settings and put: –net --net-http-port 8080 in the process arguments and save and restart.
This works for me, before that piaware complains about that dump1090 is not producing data on localhost:3005.