Latest installation of fr24feed will screw-up dump1090


#1

Here’s a heads-up after I found my RPi unresponsive this morning to anything dump1090-mutability related, e.g. PiAware Skyview showing “AJAX call failed (error: Not Found)”.

The thread above at the FR24-forum will provide you with the issue and possible solutions / workarounds.

Basically it means the fr24feed-installer will alter the owner on /run/dump1090-mutability to nobody:nogroup where the owner should be dump1090 in my case (and probably in yours too).
Quick fix: chown -R dump1090:nogroup /run/dump1090-mutability.

Besides that, with this new version lots of fr24feed-logging went into daemon.log and syslog, even with logmode="0". To prevent exhaustive writing to the disk, I’ve cut this short with an extra file /etc/rsyslog.d/fr24feed.conf reading

if $programname == 'fr24feed' then /dev/null
& stop

and restarted rsyslog (service rsyslog restart).


#2

FIX FOR PIAWARE SD CARD IMAGE

Above post is applicable if your install had dump1090-mutability.
For my Piaware SD Card image with dump1090-fa, I noted following after auto upgrade to fr24feed ver 1.0.19-2 and version 1.0.19-5:

  1. There was no problem of "Ajax call failed. The Skyview map displayed OK.
  2. The page ip-of-pi:8754 and ip-of-pi:8754/settings.html will not load sayaing “Problem loading page. Unable to connect”.
  3. status of fr24feed is failed:
    pi@piaware:~$ fr24feed-status
    [FAIL] FR24 Feeder/Decoder Process ... failed!
    pi@piaware:~$ sudo systemctl status fr24feed
    ● fr24feed.service - Flightradar24 Decoder & Feeder
       Loaded: loaded (/etc/systemd/system/fr24feed.service; disabled)
       Active: inactive (dead)

Fix 1 of 2

  1. Open file /etc/rc.local for editing

    pi@piaware:~$ sudo nano /etc/rc.local

  2. Add line sudo systemctl restart fr24feed above last single-worded line (i.e. above exit0)
    The file will become like this:

  #!/bin/sh -e
  .......
  .......
  # By default this script does nothing.
  sudo systemctl restart fr24feed
  exit 0
  1. Save file (Ctrl+o) and close file (Ctrl+x)

  2. Reboot

  sudo reboot
  1. After reboot, check status
  pi@piaware:~$ fr24feed-status
  [ ok ] FR24 Feeder/Decoder Process: running.
  [ ok ] FR24 Stats Timestamp: 2018-01-20 20:04:36.
  [ ok ] FR24 Link: connected [TCP].
  [ ok ] FR24 Radar: T-CYYZ9.
  [ ok ] FR24 Tracked AC: 43.
  [ ok ] Receiver: connected (52092 MSGS/0 SYNC).
  [ ok ] FR24 MLAT: ok [UDP].
  [ ok ] FR24 MLAT AC seen: 41.

Fix 2 of 2

The page ip-of-pi:8754 and ip-of-pi:8754/settings.html will start displaying after Fix 1, but from settings page, the “Save” and “Restart” buttons are missing, and instead there is a remark “Config file is open in read-only mode and cannot be modified from within the application.”

Give following command, then reboot.

sudo chmod a+rw /etc/fr24feed.ini
sudo reboot

After reboot load page ip-of-pi:8754/settings.html and you will see the “Save” and “Restart” buttons.
If these buttons still dont appear, clear browser cache (Ctrl+Shift+Delete) and Reload Browser (Ctrl+F5).


#3

Thanks!
However, there is absolutely no need to reboot after a file change and / or restarting a service! It’s a Linux-system, not Windows…


#4

I several times tried “clear cache & reload browser”, but the changes did not get implemented till I rebooted the Pi.