Epiphany won't load Web-Based Dump1090 view now??

I don’t know much about Linux. I’m running PiAware and it auto-updated to 1.20 recently. I used to use the monitor on my Pi to connect to itself and show the web based display (on port 8080).

Now, when I try and go to (the web address of my Pi) it starts to load and then the blue bar gets stuck and I repeatedly se 'Loading “192.168/1/10”… in the lower left of the screen. (overwrites itself about 2 times per second).

I’ve tried rebooting, etc, but not luck.

I can connect from any other computer on my network to this address and get the graphical display from Dump1090.

Any thoughts? Thanks.

Update: I even tried using the new SD image for 1.20-1 and I still have the problem with Epiphany not loading the Dump1090 page on the Pi from the Pi. This used to work fine on prior versions.

Does it show a page when loading instead?

Nope, same problem. Starts to load and then has 'Loading “”… in lower left of screen, repeatedly.

You could uninstall epiphany and then reinstall it. That might help and it might not.

sudo apt-get autoremove epiphany-browser

sudo apt-get install epiphany-browser

Good suggestion but uninstalling and reinstalling Epiphany didn’t fix the problem. Frustrating … Thanks again.

FWIW - I’ve had this same problem. It looks like the browser is stuck in a loop, as the progress bar keeps resetting, and the destination IP keeps refreshing. I have my Pi in the attic, so no problem, but I could see this would be annoying if you wanted to run a local display.

Just a follow-up. The latest version of Epiphany (or its support packages) does have a problem with certain web sites (include the web portal from Dump1090). There are others complaining about other web sites that don’t work now.

If you do want to use your Raspberry Pi to monitor the web portal on Dump1090, you can use other web browsers (I’ve used Chromium with good results).

It looks as if the problem is related to the current WEBKIT.

To use Epiphany with Dump1090, simply start the X server with the following:

export WEBKIT_DISABLE_TBS=1; startx

Started this way, Epiphany will load the web based Dump1090 interface without locking up in an infinite loop.