dump1090 a/c ground position error


#1

Good morning to all,
Recently i decided to run 24/7 my RTL2832-R820T2 usb dongle , instead of my old SBS-1 MKI.
My setup is dump1090 --> modesmixer2 --> Basestation --> VRS
The .bat files i used are :
dump1090.exe --interactive --net --modeac --net-beast --net-http-port 8088 --net-ro-size 500 --net-ro-rate 5 --net-buffer 5 --aggressive --mlat --ppm 53
pause

modesmixer2 --inConnect 127.0.0.1:30005 --outServer sbs10001:10001 --web 8888 --db C:\modesmixer2\BaseStation.sqb --location 40.64:22.93
PAUSE
exit

And in VRS , Format : BaseStation and Port :30003

The cause of the error i observed is starting from dump1090.
I’m sending three snapshots(see below URL).

  1. was a landing a/c , on the ground , see the strange constant -50ft altitude then after when speed is 0kts dissapeared.
    2)another a/c at parking stand , see the faulty longtitude.
  2. the same aircraft that the time became airborn so the coordinates as you can see fixed.

What it could be?
Have you seen the same <>?

https://photos.google.com/share/AF1QipP07EzPEDQ_jFf-ETXzkkum-grNEW_9NQwoG0cDgec04x5s1Zr5vzMAr1Fsqm4SCg?key=VHFTX2lWTjdmclpGUzlNWmZUUGdOSVNZTzVPdzRR


#2

add the dump1090 --lat and --lon options with high quality values of your home position.


#3

What dump1090 precisely are you using?

I assume since it is windows it is most probably a version from MalcolmRobb’s fork. That fork has a number of position decoding bugs and unfortunately appears to be unmaintained now.

dump1090-mutability has bugfixes but also doesn’t run on windows.

Also, --aggressive is usually a bad idea, even more so with older dump1090, it produces garbage data.


#4

As remember I’m using the windows version Ver : 1.10.3010.14 that i found here https://github.com/MalcolmRobb/dump1090.
And for the advice : “add the dump1090 --lat and --lon options with high quality values of your home position.” , do you mean something like that : --lat 40.62593 ----lon 22.93777 inside dump1090 .bat?
For the time being i didn’t use these parameters in dump .bat , i’ll try it and tell you , maybe that was the cause of bug…
Thank you very much


#5

Another thing you can try is to feed VRS using port 30005, Beast binary format. Then VRS can do its own decoding of the raw messages and dump1090’s position decoding code is not used.

(port 30005 forwards the raw uninterpreted messages; port 30003 forwards decoded messages with positions interpreted etc)


#6

ok as you adviced me i edited dump1090 .bat file and insert the parameters --lat and --lon with accurate numbers of my antenna position.
That it was ! now all wotking well!
Thanks a lot :smiley:


#7

Great! Worked for me too. But I wasn’t getting anything before I put the values in.


#8

Amazing!! Do you mean that you had not ever seen aircrafts on ground before? and now you can see?
I think you didn’t saw aircrafts on ground cause they transfered thousand miles far away , and you just didn’t searched for them like me i did on the google map.
Now i observed another bug…when the aircraft taxing on the runway at vertical speed showing a constant wrong number…see below the snapshot instead of 0 ft/m
https://www.flickr.com/photos/141989366@N07/shares/RkT7p2


#9

After a better look , i found that after the aircraft touching down the program doesn’t reset to zero 0 ft/m the vertical speed , but keep the last one recieved before the touching down.


#10

I think my problem, is that the airport is in a gully (lower than me) and I only get a few hits. Probably too weak to get two hits, but with a lat/lon it can produce positions with just one hit. I didn’t see any targets farther away :slight_smile:

You might try the suggestion of switching ports and letting VRS resolve the bits. I suspect it might do a better job than the older dump1090 you have.

I don’t remember if Vertical Velocity is transmitted on the ground. I was under the impression it was an Airborne Velocity Message. So I suspect maybe some goofy programming going on there. Maybe the Port 30003 is sending it, even though the “on-ground” bit is set.


#11

Hi again,
Before i noticed the vertical speed bug ,i did what you said so i set on VRS menu as receiver format “AVR or beast Raw Feed” and port “30005”.


#12

Also I’ve checked that on modesmixer2 screen vspeed after touching down is right(0 fmp).
See here https://photos.google.com/photo/AF1QipO0qLVM9kwk4hPJ_ClO25so0ki3hmJXOBWsCw6T