FlightAware Discussions

dump1090 3D Viewer


#145

Dear everyone,

What I am trying to do is run the whole in Opera. Do not want to believe it, but this works. BingMap always starts up well after closing and speed of building up is miz good. What happens…with VPN oke, withoud no BingMap. Something with security??.


#146

Hallo Bram,

Can you explain how to filter out de highest altitude lines.
The planes that fly over is not that important for me.

Thanks for answer and greetings Ger


#147

Thank you for this. Very nicely done. I am still not getting planes and tracks on the map. But I will keep trying. At least the map shows up :slight_smile:


#148

There are two line that need to be changed

From

if (this.hex && this.lat && this.lon && this.alt_baro  ) {

to

if (this.hex && this.lat && this.lon && this.alt_baro < 30000 ) {					

//
// this.alt_baro < 30000 only plane below 30000 feet
//


#149

Klasse Brem,
Thanks, now it looks more quiet.

Good weekend, Ger


#150

Not so… mine is not picking up planes. I get the map and coords correctly and view is proper for my setup but no planes :frowning:


#151

Please post some picture, Do you use Opera web browser…?


#152

I did post… I use Chrome.

I have tried the mod "this.altitude" to "this.alt_baro" and did not work.
Noticed that

…/data/airplanes.json

is NOT available… 404 error.


#153

I’m Working on a new version that works with Cesium 1.50 ion…and Safari Chrome Mozilla

Work in Progress :slight_smile:


#154

Bram, you are terrific. THANK YOU for all the help you have provided here to everyone. Community is great because of folks like you.

So, here is my set up.

-DEFAULT install of 3.6.3 from FlightAware. Clean Fresh Install. Works perfect
-Downloaded the 3d script from Shogoodae and it only got to display Map. No planes.
-…/data/airplanes.json is NOT reachable at all. Not locally not remotely.
-I do all my testing inside my own network

PiAware = 10.0.1.22
Local Net = 10.0.1.0/24
Viewing from 10.0.1.16

-Tried changing original 3D script to this.alt_baro and broke the map. Never loads fully and then frozen, no FPS
-Dete all 3D folder. Start fresh
-Download the 3d script from Brams, changed IP to http://10.0.1.22 and entered my Lat Lon
-Black map loads.

Here are the open ports on my Pi:

pi@piaware:/usr/share/dump1090-fa/html/3d$ netstat --listen
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State      
tcp        0      0 0.0.0.0:http-alt        0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:http            0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:30002           0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:30003           0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:30004           0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:30005           0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:ssh             0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:30104           0.0.0.0:*               LISTEN     
tcp6       0      0 [::]:http               [::]:*                  LISTEN     
tcp6       0      0 [::]:30002              [::]:*                  LISTEN     
tcp6       0      0 [::]:30003              [::]:*                  LISTEN     
tcp6       0      0 [::]:30004              [::]:*                  LISTEN     
tcp6       0      0 [::]:30005              [::]:*                  LISTEN     
tcp6       0      0 [::]:ssh                [::]:*                  LISTEN     
tcp6       0      0 [::]:30104              [::]:*                  LISTEN     
tcp6       0      0 [::]:30105              [::]:*                  LISTEN     
tcp6       0      0 [::]:30106              [::]:*                  LISTEN     
udp        0      0 0.0.0.0:45029           0.0.0.0:*                          
udp        0      0 0.0.0.0:bootpc          0.0.0.0:*                          
udp        0      0 0.0.0.0:mdns            0.0.0.0:*                          
udp        0      0 0.0.0.0:46416           0.0.0.0:*                          
udp6       0      0 [::]:39928              [::]:*                             
udp6       0      0 [::]:mdns               [::]:*                             

-I do not see port 30053 open.

Thanks for the help so far. I will get it working. :slight_smile:


#155

I installed PlenFinder Feeder software as I noticed that was referenced in index.html file. Still not good.

Also, defining default port for dump190-fa is not necessary as it is already on that port by default. :80 just redirects the URL.

Still not working. FLightaware and Planefinder both working perfectly and feeding properly. Still no 3D maps :frowning:

Bram, are you using a DEFAULT fresh install of PiAware 3.6.3?

I do NOT want to access my PiAware from outside my network. I do not need to forward ports or anythign else.

Thanks for your help

EDIT 1:

Now getting JSON Data… yay… finally

3d3

Still no map data :frowning:

UPDATE: We have tracks!!!

The trick was to reduce the alt_baro to less than 13000 feet… Trying higher now but 30000 definitely kills the system

UPDATE

It seems it does not matter what the < then is set to. I have it set to < 50000 and still working but the entry MUST BE there. Without a “< xxxxx” there will nto be planes displayed. Not sure why.

Mine is now set to:

LINE 60:

if (this.hex && this.lat && this.lon && this.alt_baro < 50000 )

Questions for the more expert
1-How to get colors and gradients on tracks?
2-How do I get more information on each plane?

Thank you


#156

Almost fixed …:slight_smile:


#157

New version , have fun and post some screenshots :slight_smile:

Download - https://www.bramjacobse.nl/show/3d.zip

Please edit setting in index.html
// ALL MANDATORY VARIABLES HERE... //
// Provide a Bing Maps API key here to enable the Bing imagery layer.
// You can obtain a free key (with usage limits) at
// https://www.bingmapsportal.com/ (you need a "basic key")

var BingMapsAPIKey = 'xxxxxxxxxxxxxxx';

// Location radar LAT / LON
var myLat = 51.00;
var myLon = 4.22;

// Default camera position (play and space key press)
var camLat = 51.6959:
var camLon = 3.8256;

var camDist = 138434;
var camPan = -0.027;
var camTilt = 1.055;

 // ip adress dump1090 and pfclient
 //  change to external IP and forward the correct ports in Router

var hostIp = 'http://192.168.1.20'; // example 'http://192.168.1.200'
var dumpPort = 80; // dump1090 port number
var pfPort = 30053; // planefinder port number


#158

Hallo Bram,
The 3d newone looks great, thanks, your a wizard.
One question, why is Schiphol the old map and when i zoom in it going to be new.
See the attachement. Is it possible to change that?

Greetings Ger


#159

I can’t fix that , it’s just the way how the maps is presented on different zoom levels…
Maybe the map-provider will update it in the future.


#160

bramjacobse - - could you make your 3D.zip available again …
thx


#161

https://www.bramjacobse.nl/show/3d.zip


#162

… many thanks …


#163

Beste Bramjacobse, after a few weeks silence (vacation) and good funtioning of the software a smal question. Is there a possibility to change the webserver port number of the 3d module. I tried something but no result.
Thanks for a answer.
greetings Ger


#164

Hoi Ger,

Check this link, it think it will answer your question…:slight_smile:

https://blog.niklasottosson.com/misc/put-sites-on-different-ports-with-lighttpd-web-server/