FlightAware Discussions

Connect to Raspberry Pi to configure

I received the message concerning expanding the SD space on the raspberry pi and I am trying to figure out how to connect to the raspberry pi. I know on regular raspberry pi’s (I have 1 running PiHole and two others) I can connect and HDMI cable to one of our TV’s and a keyboard and see the Raspberry Pi startup alone with a username prompt when I hit return.
With the raspberry pi running PiAware, I am not seeing any output when it boots, and after I know it is working and I hit return I still see no output. Of course I would not believe SSH Server is running so I could at least do the default pi username and raspberrypi for the password.
Of course I would like to change the default password on the Raspberry pi and extend the SD card.

Any help receive I will greatly appreciate.

It should show something on the monitor like other pis.
Can’t explain why it wouldn’t be doing that and in that regard could only say:

  • use a fresh image
  • or try if you have your hdmi cabling correct

Anyhow, here is the (different) default password for the piaware sd card:
https://flightaware.com/adsb/piaware/build/optional#wifi

If you have no clue but want to try SSH, check this thread:
For Beginners - How-to SSH to RPi - Setup Putty in Windows

As above, you should have HDMI signal before any image starts to load.

Are you running the flightaware image? If so, SSH is not enabled by default

Where did you receive the “SD space” message from?

Welcome to FA!

I finally did get the PiAware up and running, got the SSH Server enabled and am now able to log into the PiAware Raspberry Pi.

Still getting no display using an HDMI cable connected to the RaspberryPi, which is connected to the HDMI port on the TV. Not needed as much now, but I am curious as to why it is not working. I ended not using the SD card that came with the kit. Downloaded the image from the PiAware site, and was able to get it up and going still without the display.

Thank you for your assistants.

I am using the FlightAware image, but did not use the one that was included with the kit.
Have not seen the “SD space” message again, but was able to expand the SDCard space, change the name.

Who needs a display when you have ssh.
Maybe the TV doesn’t like the resolution used or something.

Funny thing was, though I have not tried it since, when I tried the same SD card on a different Raspberry Pi I had, same results. I have not tried it since I got it up and running.