What's the username and password for ssh access?


#1

Hi
I’ve just burned a new SD card with version 3 on it and booted my Pi 3. I run this headless and it needs to connect to my WiFI network so I need to login via ssh to set up the WiFi (I’ve connected a cable temporarily).

However, I can’t login to the Pi using the normal user pi password raspberry. What’s the default password for the pi account?

Gareth


#2

Try : flightaware


#3

With a PiAware 3 sdcard image, you can configure the wireless details in /boot/piaware-config.txt which should be easily editable on another system e.g. a PC as it’s on a FAT partition.

If you do configure it by logging in, you’ll need to either edit /boot/piaware-config.txt or equivalently use the piaware-config utility; changes to /etc/network/interfaces et al will get clobbered on reboot.


#4

Thanks, both. flightaware worked.


#5

/… I figured rather than start a new thread…

Am i missing something here? I’ve tried pi / flightaware and it denies me…


#6

pi / flightaware is correct if you are using a piaware sdcard image. Are you using a piaware sdcard image?


#7

I’m pretty sure I grabbed it from the link posted on here…


#8

What link?


#9

flightaware.com/adsb/piaware/install


#10

Then that is indeed the piaware image and the username and password are pi and flightaware respectively, unless you have changed them after installing.


#11

During the install, I don’t recal changing anything is the issue…


#12

If this happens with me, I will take a headache free route: I will download the Piaware image again, format microSD card, and write the newly downloaded image.


#13

I know, but such a pain in the crack When I should be able to log in.


#14

As a follow up on this, for anyone else looking for the round-about fix.

This flavor of Linux will auto boot to the GUI. Plug your mouse/keyboard into the PI before you boot and your favorite HDMI monitor

When it boots to the GUI, click the ‘start’ button on the top left then PREFERENCES then RASPBERRY PI CONFIGURATION

You then select SYSTEM tab and click CHANGE PASSWORD

This will change the " PI " password.

I changed it to something other than flightaware and I can now putty into the PI computer and do shut down commands and reboot commands vs yanking the power cord.


#15

My SSH don’t open. No supported authentication methods available (server sent public key) What is it? I tried with my IP and port 22 nothing don’t work.


#16

Do what I posted above, and it wont matter. There must be a port error.


#17

You have a FlightFeeder. This is hardware loaned to you by FlightAware and we need to maintain control over the software it runs so that we can remotely manage and upgrade it. There is no ssh access available to end users.


#18

Oh Thats why.

I didnt notice he or she was using flight-aware loaner gear.

Yeah bro, leave it alone