FlightAware Discussions

Combining multiple receivers into one map - Combine1090

[Update - my bad, didn’t realize there was another service combine1090-dump that needed to be restarted, found that in another thread on googling some more…]

I just installed combine1090 as I have one main Raspberry Pi with piaware running dump1090-fa feeding FlightAware. One issue is that local airport flights are “too loud” and overload the dongle and cannot be tracked properly. So I have a second Raspberry Pi that I have configured with very low sensitivity, and I put combine1090 on the main receiver so I can get its map with the combined feed and can now see both near and far flights.

However, it appears the JSON_OPTIONS="–json-location-accuracy 2" is not being handled properly by combine1090. It’s behaving as if it is set to 1 as my location is not correct on the map. I have the same setting in both dump1090-fa config files and also the combine1090 config but it is still wrong. I’ve tried adding the lat/lon to combine1090 with no effect either.

Can you please check the logic for handling this value?

Thanks,
Erik

MLAT won’t work if you feed combined data.
So it’s preferrable to install piaware on both devices and only use the combined data for display purposes.

The location has been solved if i understand correctly.

I’m not trying to feed the combined stream, the intent was only for viewing (at /combine1090). The secondary device is not intended to feed as I just use it for experimentation and in this case I wanted to try combining it at low sensitivity to get the local planes better as well as distant targets on the same map as the local airport flights often come very near and I would get a lot of dashed lines before the signal was not overloading any more. I ran the default combine1090 installer on my feeder device and added the secondary in SOURCES.

As for MLAT maybe it’s not working properly; I thought combine1090 would just give me a separate display and not affect the feed, can that be accomplished?

Yes, it was just restarting the other service after changing 1->2 that was the issue.

Thanks for the app, it’s been something I’ve wanted to look into for some time, will have to look more into how it’s actually doing this and what the various ports are, perhaps to see if we have any 978 UAT traffic around to mix in.

1 Like