FlightAware Discussions

Can't view map on localhost:8080

Hi, I am trying to install dump1090-fa only and using --net (Enable networking with default ports unless overridden). I don’t see the map at localhost:8080. I don’t see any program listening on that port. I only have lighttpd listening on port 80. When I used other foks, I had port 8080 listening. Any suggestions?

I am on a Ubuntu 18.04 laptop.

Thanks.

Install the debian package.
It includes a service to auto-start dump1090-fa, populate /run/dump1090-fa and the lighttpd configuration to show data on :8080

If you’re having trouble creating the debian package, there is some install script by abcd somewhere, not sure where.
Or you can use readsb, it wouldn’t be on :8080 but rather on :8504.
Automatic installation for readsb · wiedehopf/adsb-scripts Wiki · GitHub

1 Like

individual scripts to installs dump1090-fa, dump978-fa, and piaware data feeder

(1) FA forum: Install Piaware 5.0 On x86_64 Machines and RPi armv7l & aarch64

(2) Github: https://github.com/abcd567a/piaware-ubuntu20-amd64

 

Hi, Can you elaborate the debian package (link).

I could install tar1090 and it is impressive. I still would like to figure out my original issue (no service at 8080)

Also, in tar1090, how do you set the home location? I see the instructions below, but it is not clear.

## Home / receiver location:

This is set in the decoder, so readsb or dump1090-fa, if you used one of my scripts to install their readme will have further instructions on how to set the location.
dpkg-buildpackage -b

instead of make, will produce .deb files in parent folder

You need to set it in readsb. (/etc/default/readsb)
If you used the script, see Automatic installation for readsb · wiedehopf/adsb-scripts Wiki · GitHub

Thanks for your quick response. One more question. How do I stop the service so that the device is no longer used (I want to test it with other applications)

google doesn’t answer that?
as root: systemctl stop readsb
there is also enable disable to affect behaviour on system startup.

Thanks. I wasn’t sure how this code works, so I was stopping tar1090. Figured out myself. Thanks for your help.