FlightAware Discussions

Lighttpd listenting on port 80

Hi there!

I have installed dump1090-fa on my server to make some tests before feeding. I have noticed that dump1090-fa is running Lighttpd as a map server on port 8080, but I also noticed that the webserver is listening in port 80.
Is there any problem if I change it from listening on port 80 to listen on port 8080? I need to do that because I want to be able to run another service on port 80, but Lighttpd is already listening on that port.

Cheers!

Marcio

Should cause no problems.

lighttpd is actually just serving files from the filesystem, nothing complex, so you could also configure your other webserver to serve the map data if you prefer.

I face same problem on Kali Linux.

  • At localhost:8080, I see SkyAware Map

  • At localhost I see Apache2 placeholder page.

  • Apache2 is pre-installed with the Kali OS image, but by default is disabled in systemd. If I enable it, I loose SkyAware served by lighttpd page.

I want to serve the dump1090-fa map through Apache2, just as an experiment, but dont know how to do that.

 

Here’s my apache config for dump1090, skyaware978, tar1090 and graphs1090. On RedHat systems, this just gets dropped into /etc/httpd/conf.d. Not sure where it goes in Debian based systems.

Header set Access-Control-Allow-Origin "*"

Alias           /skyaware978/data        /run/skyaware978
Alias           /skyaware978         /usr/share/skyaware978/html

<Directory /usr/share/skyaware978/html>
	AllowOverride All
	Options FollowSymLinks ExecCGI
	DirectoryIndex index.html
	RewriteEngine On
	RewriteBase "/"
	Satisfy any
</Directory>

<Directory /run/skyaware978>
	AllowOverride All
	Options FollowSymLinks ExecCGI
	DirectoryIndex index.html
	RewriteEngine On
	RewriteBase "/"
	Satisfy any
</Directory>

Alias           /dump1090-fa/data         /run/dump1090-fa
Alias           /dump1090-fa         /usr/share/dump1090-fa/html

<Directory /usr/share/dump1090-fa/html>
	AllowOverride All
	Options FollowSymLinks ExecCGI
	DirectoryIndex index.html
	RewriteEngine On
	RewriteBase "/"
	Satisfy any
</Directory>

<Directory /run/dump1090-fa>
	AllowOverride All
	Options FollowSymLinks ExecCGI
	DirectoryIndex index.html
	RewriteEngine On
	RewriteBase "/"
	Satisfy any
</Directory>

Alias           /tar1090/data        /run/dump1090-fa-a
Alias           /tar1090/chunks        /run/tar1090-a
Alias           /tar1090/globe_history        /var/globe_history
Alias           /tar1090          /usr/local/share/tar1090/html

<Directory /usr/local/share/tar1090/html>
	AllowOverride All
	Options FollowSymLinks ExecCGI
	DirectoryIndex index.html
	RewriteEngine On
	RewriteBase "/"
	Satisfy any
</Directory>

<Directory /run/tar1090>
	AllowOverride All
	Options FollowSymLinks ExecCGI
	DirectoryIndex index.html
	RewriteEngine On
	RewriteBase "/"
	Satisfy any
	AddEncoding x-gzip .gz
</Directory>

Alias	/graphs1090/graphs /run/graphs1090
Alias	/graphs1090 /usr/share/graphs1090/html

<Directory /usr/share/graphs1090/html>
	AllowOverride All
	Options FollowSymLinks ExecCGI
	DirectoryIndex index.html
	RewriteEngine On
	RewriteBase "/"
	Satisfy any
</Directory>

<Directory /run/graphs1090>
	AllowOverride All
	Options FollowSymLinks ExecCGI
	DirectoryIndex index.html
	RewriteEngine On
	RewriteBase "/"
	Satisfy any
	AddEncoding x-gzip .gz
</Directory>

1 Like

That is just the default top level page that the Apache Debian packages installs into /var/www (IIRC), it’s probably actually being served by lighttpd. dump1090-fa doesn’t install a top-level page; try under /dump1090-fa/

1 Like

You are right.
In Kali, the SkyView is available at both localhost:8080 and localhost/dump1090-fa/. Therefore it does not matter what placeholder page is served at localhost.

My problem started when I issued following commands:


sudo systemctl enable apache2   

sudo systemctl start apache2   

After issuing above commands, I cannot see SkyView map on any address.

 

 

Thanks @gtj0 for detailed config of apache2. I will give it a try today or tommorrow.