FlightAware Discussions

Where do I find my dump1090-fa map? Looked everywhere but can't find it!

I have a newly-installed dump1090-fa and PiAware, but I can’t seem to find the map despite the many forums I seem to have gone to. Where should I look, and does it change based off of whether I’m on the computer running dump1090 or not?

For context, dump1090 and PiAware are running on Linux Mint 20 MATE - so not a Pi.

I’ve tried localhost:8080/, FlightAware’s automatically given one of, and also,,,,, localhost:dump1090-fa/gmap.html, and more. Many come up with 404’s, and some don’t even load.

I do notice that and similar ones do work for seeing raw data, but I’m guessing those are the ports for PiAware.

Am I stupidly missing something here? Please help me out!

You have apache installed in addition to lighttpd?

Also check lighttpd logs:

sudo journalctl --no-pager -u lighttpd

I usually use /dump1090-fa instead of :8080

Address indicstes that possibly you are running Linux Mint on VM on Window. If this is the case, try changing VM network setting to “Bridged Network”, and IP will change from format 10.0.0.xx to something like 192.168.0.xx. Then in browser try IP/dump1090-fa to see the map.

on which device are you running dump1090-fa and what’s your router?
The IP seem to be strange for a local network as long as you didn’t configure it manually

None of these URL are working for me (changed the IP do my local network). Where did you get these from?

And localhost only works while launched from the same device, but not via network

The 10.0.0.xx is default format of IP if Linux is run in VM on Windows. Please see my above post.

I’ve seen it, but wanted to get it confirmed by TO :wink:

1 Like

@wiedehopf, I don’t think apache’s installed, I’m installing apache2 now - but I’m getting these errors:

Created symlink /etc/systemd/system/multi-user.target.wants/apache-htcacheclean.service → /lib/systemd/system/apache-htcacheclean.service.

Job for apache2.service failed because the control process exited with error code.

See “systemctl status apache2.service” and “journalctl -xe” for details.

invoke-rc.d: initscript apache2, action “start” failed.

● apache2.service - The Apache HTTP Server

 Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)

 Active: failed (Result: exit-code) since Mon 2020-07-27 16:53:31 PDT; 21ms ago

   Docs: https://httpd.apache.org/docs/2.4/

Process: 28127 ExecStart=/usr/sbin/apachectl start (code=exited, status=1/FAILURE)

Jul 27 16:53:31 nick-vanni-linux-mint apachectl[28150]: AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using Set the ‘ServerName’ directive globally to suppress this message

Jul 27 16:53:31 nick-vanni-linux-mint apachectl[28150]: (98)Address already in use: AH00072: make_sock: could not bind to address [::]:80

Jul 27 16:53:31 nick-vanni-linux-mint apachectl[28150]: (98)Address already in use: AH00072: make_sock: could not bind to address

Jul 27 16:53:31 nick-vanni-linux-mint apachectl[28150]: no listening sockets available, shutting down

Jul 27 16:53:31 nick-vanni-linux-mint apachectl[28150]: AH00015: Unable to open logs

Jul 27 16:53:31 nick-vanni-linux-mint apachectl[28127]: Action ‘start’ failed.

Jul 27 16:53:31 nick-vanni-linux-mint apachectl[28127]: The Apache error log may have more information.

Jul 27 16:53:31 nick-vanni-linux-mint systemd[1]: apache2.service: Control process exited, code=exited, status=1/FAILURE

Jul 27 16:53:31 nick-vanni-linux-mint systemd[1]: apache2.service: Failed with result ‘exit-code’.

Jul 27 16:53:31 nick-vanni-linux-mint systemd[1]: Failed to start The Apache HTTP Server.

All lighttpd logs look good afaik, it’s all a lot of starting, started, stopping, and succeeded logs.

/dump1090-fa doesn’t seem to work either. :confused:

@abcd567 I had Windows 10 running on this (now prehistoric) Sony VAIO laptop a week or two ago until I decided to use it for PiAware and ADSB since it could likely run Linux Mint.

It’s not in any VM, but Linux Mint has been installed on a hard drive that used to be Windows (Linux Mint wiped the disk). Not sure if that makes a difference.

Could I change my IP in Mint? I do also have a Belkin dongle I have to use, as the WiFi card seems to be out.

Instead of Linux Mint, better install “Raspberry Pi Desktop for PC” on your Hard Drive.

It suites better for dump1090-fa & piaware


Alternatively you can install Debian 10.


What’s so bad about Linux Mint? Everything else seems to be working well with it

There is nothing bad in Linux Mint, but distros having some differences from Debian, side issues like yours may arise. The source code is optimum for Debian with least issues. Ubuntu also sometimes has minor issues.

Dont install the Raspberry Pi Desktop to Hard Drive in the start. Instead run it from DVD or USB stick as live CD (in persistant mode) for trial. If all goes well you may do a permanent install on HD, replacing mint.

A possible source of your issue may be your WiFi Belkin dongle. If you have another dongle,try it. Try also wired connection to router.

Having apache installed could be an issue.
Never said you should install it -.-

Lighttpd log would be more useful to post.
And remove that apache again … it will try to use the same ports as lighttpd and cause issues.

Let’s see:

ls /etc/lighttpd/conf-enabled

Also let’s check this:

ls /run/dump1090-fa

and this

wget http://localhost/dump1090-fa/data/receiver.json

Apache is not required and can cause a conflict with the lighttpd bundled by dump1090-fa installation.

The above list does not contain following two. Try these also in browser of Linux Mint:


on the device where dump1090-fa is running

(Just to complete that)

1 Like