~Bug/Error~ Airport Info Page problem..


#1

I have encountered a bug/error on the ‘Airport Info’ pages… When you go to add a new business, FBO, restaurant, etc. under the ‘Airport Services, Businesses, and Facilities’ section on ANY Airport Info page, it just redirects you back to/refreshes the same airport info page that you were at…

Wonder if its just something wrong on my end?..so try it out for yourself guys and let me know:

Try it:

1.) Go to, or click on, the “Airport Info” link for ANY airport, to get to the Airport Information page for that Airport.

2.) Scroll down to the ‘Airport Services, Businesses, and Facilities’ section, (or at the top of the page, on the left hand side, click on ‘FBOs and Airport Businesses’)…either one takes you to the same part of the page…

3.) Click on (under ANY category), click on “Add a new one now” or if there are no entries ALREADY IN that category, it will say, and you will click on, “Add the first (x_airport name_x) Aircraft Rental or Flight School.”., (or instead of ‘Aircraft Rental or Flight School’, it may also say whatever category it is that you are adding the first entry for, i.e: Add the first: “Hotel or restaurant”, “Maintenance or Aircraft Services”, etc…

4.) When you click on one of those, INSTEAD of going to the page where you ENTER the information for a new airport FBO, Business, Hotel, Flight School, etc., it instead just redirects you to, therefore refreshing, the airport information page you were at… :frowning:

>I've tried this on THREE different browsers thinking maybe it was something to do with the first browser I was using, but i got the same redirect in each of the 3 browsers I tried it in.. :frowning:
..So, just thought I would give the F/A team a heads up on this error so they can figure out what is going wrong there and do what they do best, keeping this wonderful site up and running for all of us tracking addicts :slight_smile:            
  Thanks for all your work Guys, its much appreciated! :slight_smile:   -Chris L.

#2

I have no difficulty adding or updating info. Are you logged into the FA pages or the Discussions page? They’re different entities requiring different logins and many of the functions readily available from the FA pages are buggy when attempting to access them from the Discussions page.


#3

What do you mean “did I log in to the FA pages or the discussions pages?”…once you log-in at the very top of the page, you’re then logged in for EVERYTHING; forums, pictures, flight planning, and Flight Aware in general… This is weird though cause I have already recieved 2 messages from 2 other users saying that they too are getting the same redirect error…so, I dunno… I guess we’ll just have to wait till it gets fixed…hopefully it will be back working again soon :slight_smile:


#4

I mean start here: http://flightaware.com/ when you login and then try updating or adding FBO info on an airport info page.

Apparently if you start here: http://discussions.flightaware.com/ and attempt to update an airport page you’ll get the error you’re seeing. I believe we were told that it’s because there are different servers involved? Could be wrong.


#5

The links are broken for most airports; we’re aware of it.

If you really want to add a business, copy the link and change the airport code from the IATA code/FAA LOC ID to the ICAO code. So flightaware.com/resources/airpor … dation/new

The forums and the main site use the same username/password, but do require you to login to them separately.