auto update doesn't seem to be working


#1

I have three piaware’s, none of the three auto-updated from 1.18 into the 1.19 version. When I do a piaware-config -show, it DOES show that autoupdate is enabled. Any suggestions or am I reporting a bug?


#2

I’ve noticed the same things. Both my web page and my autoUpdate (1) and manualUpdate (1) look to be properly set but I’ve had to go from 1.17 to 1.18 to 1.19 manually. Am I missing something or just being too impatient.

I do get the message that I’m a version behind at times.

Jon Hupp


#3

Same thing goes for me, I had to manually update it.


#4

.


#5

Mine has not auto-updated either, nor after I used the web page to command it to do so. Waiting a day or two to see if it eventually updates before doing the manual update.


#6

It’s not working for me either.

Is there a way to manually trigger an update from the command line? I don’t want to re-image my SD card as I’ve made a lot of mods and tweaks to my current setup.


#7

Sure, you can manually update the software by following the instuctions here: flightaware.com/adsb/piaware/upgrade


#8

Thanks. I looked all over and missed that. :neutral_face:


#9

We’ve made auto-update available for 1.19, so most devices should have it now or over the weekend if eligible and operating.


#10

I guess if 1.20 shows up, we know it worked?


#11

I’ve been thinking that since 1.17. I’l wait and see. Next time, if I don’t get an autoupdate in 48 hours or so I’ll ask them to look at my site before I update manually. I’ve sent some manual update commands from the webpage and some work (like halt and reboot), but some of the update things don’t seem to work (or work in the background and I can’t see that they have worked). I’m not very competent with Linux so I may be missing something.


#12

The upgrade page says, “If you installed PiAware with FlightAware’s SD card image, you can upgrade your receiver by simply repeating that process by following steps 2 and 3 on the build page to re-write your SD card with the latest version. Versions 1.16 and above automatically update so you will not have to do this more than once,” emphasis added. Maybe that portion should be removed from the page, since it doesn’t seem to be autoupdating for anybody.


#13

We enable auto-update a few days after releasing the manual update. Hundreds of sites were updated as a result, so it does seem to be working.

If you’re not running 1.19 but installed the SD card image or think you have auto-update enabled, please post some specifics on your situation.


#14

I have not done a manual update because I was expecting an automatic one a few days after the release was announced. I’ve still not updated because I haven’t allocated the time. Here is the message I get:

Anomaly report for piaware feeder with a mac address of b8:27:eb:1a:5a:10:
This system is running piaware version 1.18. Piaware version 1.19 is current. Please upgrade to the latest version by visiting flightaware.com/adsb/piaware/upgrade.

My equipment is a Raspberry PI with WIFI dongle with 1.18 installed via the SD card method. First installation was via network cable, but I switched to WIFI after a dongle arrived some days later. Only other departure from the recommended equipment is a ground plane antenna that has been connected for about 3 days now. I’ll refrain from doing a manual update in case you want to use me for testing of some sort.

I did get a new local IP number when switching to WIFI, but I wouldn’t think that would matter. I believe my external IP number has remained the same.

P.S. I did not tweak anything to enable auto-update, nor did I tweak anything to disable it. I thought 1.18 had it enabled by default, but I haven’t confirmed with the build I’m using.