FlightAware Discussions

Anyone know why I cannot file transfer suddenly

Ive been using Bitvise for a long time and never had this issue. I was trying to upload markers.js and I keep getting SFTP permission denied error. Im able to transfer down from the raspberry but not up.

Dont know what changed.

You can upload to folder /home/pi only. This folder has write permission for uploads. To upload to any other folder, first upload to /home/pi then move it to desired folder by issuing following command:
sudo mv [filename] /path/to/destination/folder/

Ill try that, but Ive always been able to copy it down, modify and upload before.

Maybe SCP is required. I am using WinSCP and am able to upload wherever i want.

If you use root credentials and enable root ssh login then you can use SCP to put files wherever.

The OP is using Bitvise, and I also use it. Through Bitwise, you cannot upload to any folder other than /home/pi/

The upload/download is through Graphical interface

(This is not my Pi or desktop, downloaded image from web)

That’s exactly how WinSCP works.

image

May be WinSCO has somehow solved permission issue, but in Bitvise, it is definitely there. I am using Bitvise for about 2 years now and am sure of the permission issue.

Well you are not using root credentials, are you? …

To be clear: WinSCP also needs the access via root, using the regular name will not give this permission, because sudo cannot work as well.

Well the upload/download are graphical i.e. right click on the file in RPi and select download., or right click on file in Windows and select upload. I always logged in as pi user, never tried to login as root. What is root password for Raspbian? It is raspberry for user pi.

Google it, i’m sure there are guides out there how to use root on the RPi.
(ssh configuration also needs to be changed)

1 Like

Root login is is disabled by default in Raspbian. To enable root login one must edit /etc/passwd.

Edit line root:x:0:0:root:/root:/bin/bash so that it reads root::0:0:root:/root:/bin/bash
Reboot
Root now has an empty password
Change the root password

1 Like

Editing passwd manually is really required?
Seems strange.

Can’t you just sudo passwd root ?

If you want to log in remotely as root via ssh, you have to change the ssh server config. By default, ssh root log in is disabled:

If you want to log in directly with the username root you need to do the following:

Set a password for the root account:

sudo passwd

Then you need to edit the ssh server config:

sudo nano /etc/ssh/sshd_config

Replace:
#PermitRootLogin prohibit-password

with
PermitRootLogin yes

and then restart the ssh server (this will probably log you out if you are doing it remotely):

sudo systemctl restart ssh

No it doesn’t, doesn’t change existing sessions, clever design :slight_smile:

1 Like

Ok, all good information. Only one question

Why could I do it before, and now I cannot? What changed recently.

This question can be answered usually only by the user :wink: