FlightAware Discussions

Need help accessing Pi

Good evening,

I need help form you gurus.

I am usnfg a MacBook ro access my Pi.
Did is what I do:
Finder-> Go-> Connect to server.
ssh://pi@192.168.xxx.xx
It seems there is a connection, but all I see is a blanc window.

I think I did something stupid, but is there someone who can help me. My Pi is not feeding for some hours.

Thanks,
Bert

Have you been able to SSH into it before?

Whatever happened to your Pi could affect your SSH access. Try rebooting first.

Hello Eric1tran,
thanks for the reply. I tried everything.
I gave up and installed all feeders agin. Some are working some are not.
For FlightAware, my settings are wrong. Need to change to IP address for the piaware, but I don’t know where . Guess the config file, but tried that as well
pi@raspberrypi : ~ $ edit /etc/piaware.conf

Error: no write permission for file “/etc/piaware.conf”

Any ideas?

sudo vi /etc/piaware.conf (old CLI editor. not user friendly)
sudo nano /etc/piaware.conf (more user friendly editor).

You can also change the settings using
sudo piaware-config

Is your original SSH issue fixed?

And can you elaborate on what is not working/what settings are wrong?

You can configure piaware settings using the piaware-config command.

To see a list of all the settings:

sudo piaware-config -showall

To configure a setting:

sudo piaware-config <setting> <value>

Dear Eric

I can access my raspberry. After installing everything I could use the Pi.

I experience an “new” stage thing. I seem to be connected, at least two of the three icons are green in MYADS
But no planes are seen??

But is is getting weirder. When I us the option view live data, I see the error, cannot connect to server.
The IP address is correct. So I am more and more confused.

Check on your radio now. Enter lsusb to make sure it recognizes it.

nou sure what you want me to do, sorry
pi@raspberrypi : ~ $ lsusb

Bus 001 Device 004: ID 0bda:2838 Realtek Semiconductor Corp. RTL2838 DVB-T

Bus 001 Device 005: ID 0424:7800 Standard Microsystems Corp.

Bus 001 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub

Bus 001 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I’m just looking at your stats/logs and see you are not receiving aircraft message. Your logs are showing

[2020-09-17 16:22 CEST] can't start dump1090, no services that look like dump1090 found

Did you install dump1090-fa when you re-installed everything?

sudo apt-get install dump1090-fa

Dear Eric,

sorry for troubling you the way I do. Installed dump 1090 again. This is the last part
Enabling dump1090-fa: ok

Run “service lighttpd force-reload” to enable changes

Restarting lighttpd…

Job for lighttpd.service failed because the control process exited with error code.

See “systemctl status lighttpd.service” and “journalctl -xe” for details.

invoke-rc.d: initscript lighttpd, action “restart” failed.

● lighttpd.service - Lighttpd Daemon

Loaded: loaded (/lib/systemd/system/lighttpd.service; enabled; vendor preset: enabled)

Active: activating (auto-restart) (Result: exit-code) since Thu 2020-09-17 19:16:44 BST; 32ms ago

Process: 18720 ExecStartPre=/usr/sbin/lighttpd -tt -f /etc/lighttpd/lighttpd.conf (code=exited, status=255/EXCEPTION)

Created symlink /etc/systemd/system/default.target.wants/dump1090-fa.service → /lib/systemd/system/dump1090-fa.service.

Processing triggers for libc-bin (2.28-10+rpi1) …

You seem to be not using an image and not quite have down what you need to install, so this may be useful:
https://github.com/wiedehopf/adsb-wiki/wiki/Raspbian-Lite:-ADS-B-receiver

For your lighttpd issue, that’s likely related to dump1090-mutability being installed by fr24feed because you didn’t install dump1090-fa …
https://github.com/wiedehopf/adsb-scripts/wiki/Automatic-installation-for-dump1090-fa
The above script fixes the most common problems with that.
Just to inform you what the issue is, likely an extra file in /etc/lighttpd/conf-enabled that’s conflicting, with dump1090 or dump1090-mutability in the name.
If you don’t want to run the script check that directory and remove the extra file.

If you want to debug that yourself, check the log: https://github.com/wiedehopf/adsb-wiki/wiki/Debug-commands#lighttpd
You’ll also need to restart the service.

2 Likes

As always Wiedehopf your second suggestion did the trick. I am feeding again, hurray!

Have to fix my next problem. Using a Fritzbox as router when I try to access the raspberry on 19.168.xxx.xx it says 403 forbidden.
Any ideas what I did wrong this time?

Doesn’t have anything to do with the router if you’re just on the local network.

Does http://192.168.xx.xx/dump1090-fa work?

Just / isn’t even available by default but it usually gives a default page not a 403.
Really i don’t know what you screwed up with your lighttpd config.

yes it is working :slightly_smiling_face: