planeObject.js transfer from Linux laptop to Raspberry


#1

Hokay, I used an edit program to do the color airplane mod to planeObject.js but when I try to upload it via filezilla I recieve a transfer error. I even enabled super user with sudo su … but still it fails with

Error: /usr/share/dump1090-mutability/html/planeObject.js: open for write: permission denied
Error: File transfer failed

I tried using sudo nano to just insert the required lines but that ended in failure as I cannot seem to insert the text.

Any Help for a linux newb.


#2

hey

maybe your folder and this file as Root ?

and you want write as PI oder other user.

pi user sudo vi or nano

than i make here
chmod 666 planeObject.js
and you can
chown -R pi:pi html

try this and say , work or dont work

i test here , same problem,

the user right , or you connect with FTP as Root ?

user right in this folder


#3

try this:

cd /usr/share/dump1090-mutability/html
sudo wget raw.githubusercontent.com/mutab … eObject.js


#4

Worked like a champ, RMed the old MV the new to the old and Bingo. Works peach.

Thanks