FlightAware Discussions

Raspberrypi update Skyaware html no longer getting aircraft.json data

I have had my Raspberry Pi working as and feeding FlightAware for several months now. I have recently carried out a sudo apt-get update & apt-get upgrade (15 Jul 20). Since then I have the follwoind senario,

  • I can see the aircraft.json file is updating,

  • I can see that the local aircraft to my receiver are being up loaded to other adsb sites,

  • The local FlightAware html /dump1090-fa/index.html is not plotting the planes

  • The other json files are being loaded - the distance rings, the intheair.json, and the js scripts for the buttons etc.

  • The aircraft.json can still be accessed /dump1090-fa/data/aircraft.json.

  • The lighttpd/conf-enabled/89-dump1090-fa.conf still has the correct alias’ for the ‘data/’ = ‘/run/dump1090-fa/’ location.

I have tried restarting the lighttpd service. I have tried rebooting the pi. I have checked the policy for piaware and dump1090-fa and both match giving 3.8.1 version table 500.

Any suggestions?

I have this issue on two separate remote machines accessing the pi. One is running mint linux mozilla firefox and the other is windows 10 chrome. Thus, the reason to suspect the pi. The console inspection on the W10 chrome web page refers to
'An uncaught ReferenceError: PlaneObject is not defined
at processReceiverUpdate (script.js?V=3.81:85)
at end_load_history (script.js?V=3.81:435)
at Object. (script.js?3.8.1:406)
at i (jquery-3.0.0.min.js:formatted:1325)
at Object.firewith [as resolveWith] (jquery-3.0.0.min.js:formatted:1379)
at A (jquery-3.0.0.min.js:formatted:3373)
at XMLHttpRequest. (jquery-3.0.0.min.js:formatted:3889)

Solved - where I had been investigating the html file I had managed to type in a couple of “//” around the icao filter without realising. Issue with two keyboards and one brain.

2 Likes