All working but no aircraft!

Hi All,

I recently tried moving my Piaware system to the top of a water tower, where I expected reception should be great. It all seems to work, the system checks in to the server, I’m shown as online, but it shows no aircraft! piaware-status says:

PiAware master process (piaware) is running with pid 14120.
PiAware ADS-B client (faup1090) is running with pid 30830.
PiAware ADS-B UAT client (faup978) is not running (disabled by configuration settings)
PiAware mlat client (fa-mlat-client) is running with pid 14201.
Local ADS-B receiver (dump1090-fa) is running with pid 30607.
dump1090-fa (pid 30607) is listening for ES connections on port 30005.
faup1090 is connected to the ADS-B receiver.
piaware is connected to FlightAware.
dump1090 is NOT producing data on localhost:30005.

Exactly the same hardware in a different location (my house) with a far less optimal antenna location gives reasonable performance and shows aircraft.

After many rounds of trouble shooting, I am left with the possibility that there is something poisonous about the location on the water tower. There are other electronics up there, including a VHF repeater. There’s a long ethernet run to get connectivity up there. Is it possible that very local RFI is blocking the signal? Any ideas how I could test/fix that ?

I would look at this thread.

Read this thread with exactly the same topic:

dump1090 is NOT producing data on localhost:30005 - FlightAware / ADS-B Flight Tracking - FlightAware Discussions

Thanks, I did go through that thread at the start of the trouble-shooting process. I also switched power supplies and removed USB extension cables. I finally reached the conclusion that the only variable that caused the problem was location!

This means the SDR is not working, location doesn’t matter in that case.

The dump1090-fa log will show that it can’t find the SDR.
If you’ve tried the other stuff, you’ve got a dead SDR on your hands.

Interference dump1090-fa would be running fine, just no data.

Thanks, that’s strange, location does seem to be a factor. When it’s at the house and ‘working’, I seem to get that error message when there are no aircraft detected, but it disappears when an a/c is on my screen. Of course that could be cause not effect! But on the water tower, exactly the same setup, I never see a/c and always get the “NOT producing data” error. Anyway, I’ve ordered a Pro Stick Plus, I’ll see what effect that has.

Nvm i misremembered that status output, dump1090-fa seems to be running.

cat /run/dump1090-fa/stats.json

put it on and link it here.

And yeah with a repeater on there you’ll need filters.
The FA Pro+ won’t cut it as it has an LNA before the filter and the LNA can be overloaded as well somewhat easily.

FA Pro+ won’t cut it

What will ?

put it on and link it here.


You said your order the FA pro+ stick.
Anyhow doesn’t look like interference from the stats.json, more like the antenna not being connected or blocked.

Put a band pass filter at the antenna.

Are you using the same gain settings when the set-up is on the water tower as when it’s at your house? Maybe it’s getting overloaded when it’s way up there because signals are stronger.

Yes, I tried varying the gain

USB extension cables are very ‘hit and miss’. Unless you have verified it’s performance, consider it a suspect.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.