Advanced Config Hostname


#1

Folks,

Of late I’ve been having network failure on my device. I’ve switched devices and still occurs.

My Pi is dedicated to PiAware, it is fixed IP via the interfaces file and wpa_supplicant is set for roaming. When the network failure occurs I am still able to access the device via serial connection so all terminal commands work. Strangely issuing ifconfig shows all network settings have been lost. Restarting the network service does not resolve the issue.

Without going in to everything it seems to occur when I change the hostname file but appears stable when I leave it at the default raspberrypi name (can’t reproduce it to order - times seem to be randon). If I alter the hostname file I do also alter the name in the hosts file.

I see there is a receiver-host setting in advanced configuration so am wondering what is the default setting for this.

I am a fairly experienced Linux user and am used to adjusting settings but this is driving me mad so any suggestions appreciated.

Geffers


#2

receiver-host doesn’t have to do with the WIFI network settings.

The documentation on piaware config is here
https://flightaware.com/adsb/piaware/advanced_configuration

The receiver-host is for the radio receiver host name. The prostick or RTL dongle is your radio receiver.

Without going in to everything it seems to occur when I change the hostname file but appears stable when I leave it at the default raspberrypi name (can’t reproduce it to order - times seem to be randon). If I alter the hostname file I do also alter the name in the hosts file.

Network problems are hard to diagnose.
Log files are definitely the best place to start

cat /var/log/syslog

and

dmesg

You can check your current piaware-config settings by typing

piaware-config -showall

If you set a piaware-config setting to blank it will use the default values
You can set piaware-config settings by using

piaware-config receiver-host value


#3

Thank you for useful information.

There is no dmesg file on my /var/log folder.

First indication of a problem shows in piaware.log

Jan 22 00:29:18 PiAware25 piaware[424]: mlat-client(690): Out-of-order timestamps: 1

15 minutes later

Jan 22 00:44:18 PiAware25 piaware[424]: mlat-client(690): Server status: not synchronized with any nearby receivers

Minutes later

Jan 22 00:44:25 PiAware25 piaware[424]: 36173 msgs recv’d from dump1090-fa (41 in last 5m); 36173 msgs sent to FlightAware
Jan 22 00:46:04 PiAware25 piaware[424]: timed out waiting for alive message from FlightAware, reconnecting…
Jan 22 00:46:04 PiAware25 piaware[424]: multilateration data no longer required, disabling mlat client
Jan 22 00:46:05 PiAware25 piaware[424]: fa-mlat-client exited normally

Then in syslog file I get the following coinciding with piaware log of saying no sync with nearby receivers.

Jan 22 00:45:34 PiAware25 avahi-daemon[402]: Withdrawing address record for 10.19.44.25 on wlan0.
Jan 22 00:45:34 PiAware25 avahi-daemon[402]: Leaving mDNS multicast group on interface wlan0.IPv4 with address 10.19.44.25.
Jan 22 00:45:37 PiAware25 avahi-daemon[402]: Interface wlan0.IPv4 no longer relevant for mDNS.

This only seems to happen when I change the machine name away from the default and with default it is currently 26 hours uptime.

Geffers


#4

dmesg is a command to show driver loading and unloading logs. You just run the command to view the logs.
It looks like the wifi drivers are loading correctly or you wouldn’t have networking at all.

There might be some odd problem with your router + raspberry pi setting Or you have some weak wifi signal Or there is a hardware problem going on.