FlightAware Discussions

ADS-B Receiver Project Setup Scripts


I don’t have a flight feeder account and i don’t have any of the 4 it asks for. All I have is the Flightaware Pro Stick and the ADSB Receiver Project installed. This day is getting worse.


Ok, first step done.
What about second step, ModeS Multilatration (MLAT) radio button Mlat enabled checked?


I editted my reply. I dont have any flight feeder attached to my account here.


You dont need a Flightfeeder to get an account and mlat. You need a computer running dump1090 and Piaware and a Flightaware Pro Stick (or dvb-t), which you already have.

It seems you have not claimed your piaware.

While loggedin to your account, go to claim page and follow steps shown there.



hey cool thanks ill reply shortly


I dont have mlat turned on in dump1090-mutability I forgot where the list of command line arguments are. I seen it online but forgot to bookmark it. I don’t see it in the command line in Task Manager just all the ports gain and other things.


It’s done in the website only.
You may need to restart your device for it to take effect.


i reran dpkg again and aded --mlat to the additional arguments part then restarted lighttpd and restarted dump1090-mutability mlat doesn’t appear in taskmanager when viewing the command line of the process.

Claim Piaware page isnt seeing it after a few attempts.

Let me open router ports. that finally entered my head.


This is NOT going to enable MLAT. You have to enable it from your flightaware stats page as I have shown in my post above. I am reposting the screenshot in case you missed it.


PiAware - Claim and Link a Brand New PiAware Ground Station

Unfortunately, FlightAware hasn’t found a new, unclaimed PiAware feeder to claim.

FlightAware searches for PiAware connections on the same global IP (xxx.xx.xx.82) as your connection. If you are on the same LAN as the PiAware device, then we should be able to find the receiver and claim it for you. You should wait a few minutes after plugging in your PiAware device before expecting it to be connected to FlightAware. Try checking cable connections, waiting a few moments, and trying again.

If you are unable to use the automatic claim feature, please contact ADS-B Support.

Apparently not. I have to tell dump1090-mutability to do MLAT.


While claiming, the computer from which you are claiming, and the computer which has Pro Stick +Piaware, both should be on the same Local Network

Otherwise you will see this:



I see that what I see in the image you posted. The whole thing is on computer. My router ports are opened udp range 30000-40000.


Is your Piaware working? Check it with this command, and post the output

sudo systemctl status piaware -l  

If it is working ok, then last few lines will show that it is receiving messages from dump1090 and sending to Flightaware


sudo systemctl status piaware -l
Unit piaware.service could not be found.

Im confused now. I was told all it needs is FA Dongle and dump1090. I have ADSB Receiver Project which is the OP here


Adsb receiver project has many components, all optional. Seems you did not choose Flightaware Piaware in the Feeders choice list

1. Decoders

  • dump1090-mutability
  • dump1090-fa

2. Feeders

  • Flightaware (Piaware)
  • Planefinder
  • Flightradar24
  • Adsbexchange

3. Databases

4. Web Portal (graphs)

  • dump1090-mutability
  • Flightaware (Piaware)

Where selected. I don’t understand :thinking:


Select when these options are presented after the Adsb Project Sript starts running, when you give these commands

sudo apt install git  
cd ~/  
git clone http://github.com/jprochazka/adsb-receiver.git  
cd ~/adsb-receiver




I take it as I am to be feeding to flightradar24. It didnt install anything new related to the selection Flightradar24 client


Flightradar24 choice shown in the screenshot is only an example to show which screen has feeders. You have to unselect Flightradar24, and select Flightaware Piaware.

To select/unselect, move the cursor by arrow key to Flightaware Piaware, and press Spacebar on your keyboard. A star [*] will appear on left side of “Flightaware Piaware”. After choosing, press Enter key.


It’s looking for a PIAWARE client besides what’s already there. It’s a 64 bit program. I found that out when I tried to add the Piaware repository. It says it doesn’t support i386 architecture. My computer is 32bit.

Totally unpleasant feeling when people want to dictate what your hardware should be. Just because more 64bit hardware is sold doesn’t mean there aren’t any 32bit computers being used. Don’t single people out. Penguins (Tux, Linux ‘freedom’) like ALL. Stubborn bullheadedness of society when the majority literally pushes away other things that are still good.

Elitist attitude like that is yesterday this is 2018.