FlightAware Discussions

Adding feeders

hi

i have a R Pi 3b + with a FightAwareProStickPlus dongle
at present i feed Flightradar24 using their NOOBS image

i want to setup feeds to other services would appreciate noobie proof instructions

i would like to avoid disurpting the FR24feed

i want to setup feeds to other services

  1. flightaware - already have a station code - not sure how install with the ‘old’ code
    new shares to install
  2. plane finder
  3. radar box
  4. adsb exchange

Your expert assistance would be appreciated - bit overwhelmed with all the content and do not want to upset the present FR24 feed setup

thank you
jg

All feeders you have listed are having a script to be used. Simply follow their instructions, you only have to be careful not trying to use the image they also provide.

And for getting a new station with an already existing feeder-id, simply follow this thread:

1 Like

This might help.

1 Like

 

This is a bit confusing for a new user with PI24 image. Better not use it.

Here are straightforward simple steps for Flightradar24’s Pi24 image:

(1) If you want to use multiple site, the very first step you have to do is to open your web browser, go to address ip=of-pi:8754/settings.html and add config parameter --net in “Process Arguments” field. Please see blue circle in settings below:
Click Save and Restart buttons located at bottom-right of settings page.

(2) To make sure your changes in step (1) are saved and applied, open browser and go to address ip-of-pi:30005 . Wait for a while, and if your settings are OK and saved, you will see this:

image

(3) If you see as in step (2) above, you are set to add other feeders. Proceed to step (4). If you cant see above, then your settings are not saved due to a bug in Pi24 image. SSH to Pi and issue following command:

sudo nano /etc/fr24feed.ini

Scroll down to find this line
procargs="--gain -10"
add --net to it so it becomes
procargs="--net --gain -10"

Note: if line starting with procargs= does not exist, scroll down and below last line add following new line:
procargs="--net --gain -10"

Save (Ctrl+O) and close (Ctrl+X)

Restart fr24feed
sudo systemctl restart fr24feed

Now repeat test in step (2) above.
 

(4) Add PIAWARE

wget https://flightaware.com/adsb/piaware/files/packages/pool/piaware/p/piaware-support/piaware-repository_3.8.1_all.deb

sudo dpkg -i piaware-repository_3.8.1_all.deb 

sudo apt-get update

sudo apt-get install piaware

 

(5) Add PLANEFINDER

wget http://client.planefinder.net/pfclient_4.1.1_armhf.deb

sudo dpkg -i pfclient_4.1.1_armhf.deb 

 

(6) Above instructions are sufficient. However for details and further reading, you may see these posts:

(a) installing other feeders on Pi24 image
https://forum.flightradar24.com/forum/radar-forums/flightradar24-feeding-data-to-flightradar24/12435-2019-pi24-image-quickstart-guide?p=156015#post156015

(b) 2019 - PI24 (Image) QuickStart Guide
https://forum.flightradar24.com/forum/radar-forums/flightradar24-feeding-data-to-flightradar24/12435-2019-pi24-image-quickstart-guide

(c) Raspberry Pi:How To Install Raspian OS + Dump1090 + FR24 Data Feeder
https://forum.flightradar24.com/forum/radar-forums/flightradar24-feeding-data-to-flightradar24/8804-raspberry-pi-how-to-install-raspian-os-dump1090-fr24-data-feeder

2 Likes

many thanks
appreciate the detail

jg

Thanks @abcd567, for the procedures you spend time in detailing for the uneducated
I may have missed it, but not sure how to add other feeders if you have just Flightaware/Dump109-fa running. ie adding FR24 to flightaware.

To add FR24 feeder to Piaware sd card image:

(1) Copy-paste following bash script in SSH window and press Enter key:

Scroll right to see the command in full

sudo bash -c "$(wget -O - https://repo-feed.flightradar24.com/install_fr24_rpi.sh)"  

(2) When the feeder is installed, it will start signup process by asking email, feeder key, latitude longitude etc.

(3) When you reach to Step 4.1, do NOT choose Receiver “1 -DVBT Stick (USB)”. Choose “4 - ModeSBeast (USB/Network)”. Please see below:

 

(4) When you reach Step 4.2, choose:

  • Connection type "1 - Network connection "
  • Receiver’s IP address 127.0.0.1
  • Receiver’s data port 30005

Please see below:

 

(5) After signup process is completed, restart fr24feed

sudo systemctl restart fr24feed   

(6) Check status

fr24feed-status

(7) Open browser and type following address
IP-of-Pi:8754

 

To Add Planefinder feeder to Piaware SD card image

wget http://client.planefinder.net/pfclient_4.1.1_armhf.deb

sudo dpkg -i pfclient_4.1.1_armhf.deb 

After installation is completed, in browser go to address
IP-of-Pi:30053
Enter email or sharekey if you have, then use
Network address: 127.0.0.1
Port: 30005

 

1 Like

Thanks @abcd567 the install worked just find. But!

Running with an airspy and installed with @wiedehopf auto install script, and my Flightaware is running fine and reporting positions/aircraft but FR24 is reporting 0 for tracked aircraft but Receiver is displaying : beast-tcp, Connected

airspy_adsb config is at default settings, NET= -l 47787:beast -c localhost:30005:beast

please help again!

I think that you may need to point PF to port 47787.
30005 is where airspy is sending the traffic(so it is a receive traffic port).
47787 is the port that is listening to send the traffic.

1 Like

So I need to set FR24 to listen to port 47787 insted of 30005?

No, FR24 needs to connect to 47787 to receive data from the airspy.
(I didn’t read the details and see that FR24 had the issue not PF).

Here is the help for airspy_adsb (-c is connect, -l is listen)
airspy_adsb -h
airspy_adsb v1.85
Options:
-s <serial_number> Device serial number
-t Aircraft timeout in seconds
-g <rf_gain> RF gain: 0…21
-f Forward Error Correction (FEC) bits
-e <preamble_filter> Preamble filter (decimal): 0…20
-w <whitelist_threshold> Whitelist threshold: 1…20
-c :[:format] Add a Push Client
-l [:format] Add a Listener
-m <mlat_freq> MLAT frequency in MHz: 12, 20 or 24 (Airspy R2 only)
-n Enable Verbatim mode
-x Enable DX mode
-r Reduce the IF bandwidth to 4 MHz
-b Enable Bias-Tee
-p Enable Bit Packing
-v Verbose mode
-h Display this help screen
Available output formats:

  • AVR - Raw AVR format
  • AVR-STRICT - Raw AVR format with only CRC valid frames
  • ASAVR - Raw Airspy AVR format
  • Beast - Raw Beast Binary format
1 Like

Thanks all now working :+1: :+1: :+1:

3 Likes

OK so a big thank you to all that replied and assisted

To recap I had an FR24 image that was feeding successfully using an FA ProStickPlus

I have now added FA Piaware and its also feeding

There is some conflict (with the dump1090s ?) though on the local lan i am denied access via a browers to :30005 and :8080 - would appreciate some assistance here (and some newbie instructions)

Also my antenna is (dont laugh) woeful didnt know a thing when i purchased it - can it be saved is it customisable? The distance from the screw fitment to the first coil is much less than 67mm. Pictures below of the FR24 settings, access denied and my hahantenna

THANK YOU again
image

Yes, it can be optimized. The length of the tip is not correct. You need to either cut it or remove the tip (should be screwed) and replace it with a piece of cable in the appropriate length.

Check this thread: