FlightAware Discussions

A few questions piaware related

Stupid idea maybe,
I’m trying to disable dump1090-fa and install de dump1090 version (trying something) just to compare those 2 but I don’t want to cripple my feed (piaware image).
Later if necessary I want to remove one of them… errrr how?

A little bit of help would be great, thank you

Emil

(1) STATUS

pi@orangepipc:~$ systemctl status dump1090-fa
● dump1090-fa.service - dump1090 ADS-B receiver (FlightAware customization)
   Loaded: loaded (/lib/systemd/system/dump1090-fa.service; enabled; vendor pres
   Active: active (running) since Tue 2018-12-04 09:23:21 EST; 3h 4min ago
     Docs: https://flightaware.com/adsb/piaware/
 Main PID: 903 (dump1090-fa)
    Tasks: 3 (limit: 4915)
   CGroup: /system.slice/dump1090-fa.service
           └─903 /usr/bin/dump1090-fa --device-index 0 --gain 32.8 --ppm 0 --net

Dec 04 09:23:21 orangepipc systemd[1]: Started dump1090 ADS-B receiver (FlightAw
Dec 04 09:23:21 orangepipc dump1090-fa[903]: Tue Dec  4 09:23:21 2018 EST  dump1
Dec 04 09:23:21 orangepipc dump1090-fa[903]: rtlsdr: using device #0: Generic RT
Dec 04 09:23:21 orangepipc dump1090-fa[903]: Detached kernel driver
Dec 04 09:23:21 orangepipc dump1090-fa[903]: Found Rafael Micro R820T tuner
Dec 04 09:23:22 orangepipc dump1090-fa[903]: rtlsdr: tuner gain set to 32.8 dB

.
.
(2) DISABLE DUMP1090-FA

pi@orangepipc:~$ sudo systemctl disable dump1090-fa
[sudo] password for pi:
Removed /etc/systemd/system/default.target.wants/dump1090-fa.service.

pi@orangepipc:~$ sudo reboot

.
.
(3) ENABLE DUMP1090-FA

pi@orangepipc:~$ sudo systemctl enable dump1090-fa
Created symlink /etc/systemd/system/default.target.wants/dump1090-fa.service → /lib/systemd/system/dump1090-fa.service.

pi@orangepipc:~$ sudo reboot

@ abcd567
thanks mate, meanwhile I found what I was looking for but now I have a totally different problem.
After removing of 1090 mutability I have constantly after a few seconds the message “problem fetching data from dump1090”.
I guess that something went wrong by the removal of 1090 muta…
Any idea what it can be?
The map works but is annoying.

1 Like

@EmilK

  1. How you deleted it, by following command

    sudo dpkg --remove dump1090-mutability

    OR

    sudo dpkg --purge dump1090-mutability

    The --purge is better than --remove.

  2. The folder html (which contains map files), is often left over after uninstall. Try this command to remove it, alongwith it’s parent folder dump1090-mutability:

    sudo rm -rf /user/share/dump1090-mutability

Clear browser cache Ctrl+Shift+Delete, then reload browser Ctrl+F5

.

@ abcd567

1
I used the purge version (Ive seen a post from you saying so)

  1. Nope, same, I guess has to do with the network configuration that dump-muta is setting up…
    Also AJAX, SyntanError and unexpected end of JSON input are displayed…

Don’t stress yourself, is not that bad, the function is there, its only a cosmetical error

ls /etc/lighttpd/conf-enabled

what does this say?

if it has a dump1090-mutability file you can sudo rm that.
you can also check your dump1090-fa config file.

not sure how that problem would happen with installing and reinstall other dump1090.
maybe you install dump1090 as well without anything behind it and now the two are “fighting”

also check the dump1090-fa log:

sudo journalctl -u dump1090-fa -e --no-pager -n100

pi@piaware:~$ ls /etc/lighttpd/conf-enabled
10-fastcgi.conf 15-fastcgi-php.conf 50-piaware.conf 89-adsb-portal.conf

dump-fa log shows nothing, I mean nothing except some entries about dump1090 fa…

Thank you @ all

So I managed to get a screenshot when the error is displayed.
It looks like the errors are also in the lines 144, 170, 171, 174, 175, 176, 294 … I think I have not cached all errors, the displayed time is really short.
So, how can I fix this one?

I think i encountered the exact same problem.
Trying to remember what the problem was.

Ah yes the stat caching.

sudo lighty-enable-mod dump1090-fa-statcache
sudo systemctl restart lighttpd

Yeah i was just trying to see if dump1090-fa was constantly restarting or something. Just trying to get as much log information as possible. Luckily the json syntax error made me remember some error :wink:

I’m not sure why this config file isn’t enabled by default. Maybe it is and adsbreceiver switches it off or never on? I don’t know to be honest.

@ wiederhopf
THANK YOU, Dankeschön
Yeap that did the trick, or magic, call it how you want :slight_smile:

Emil

Has anyone managed to start piaware (the sd image) from a SSD? I have one catching dust (a 32 GB Sandisk older model).

The RPi 3 models can boot from a usb drive, that is probably the only way to connect it (enclosure or adapter), although there may exist sata HATs.

Power consumption may be an issue, if it uses the RPi to power itself

I run PiAware from an SSD, along with a collection of data logging and graphics utils. The raspberrypi.org forums were very helpful, especially this thread: https://www.raspberrypi.org/forums/viewtopic.php?p=376609

The Pi doesn’t provide enough USB power to run the SSD and the RTL reliably, so used a powered USB hub. The Pi doesn’t take any advantage of a USB 3.0 hub, and they are more likely to cause interference with the RTL and with Pi WiFi, so a USB 2.0 hub is actually better for this usage.

Quick question for the Group;

I would like to set up a separate RPi that can easily feed VRS unfiltered, nothing being blocked. Simply to be used for my own use.

I was going to use PiAware with Dump 1090 but I was not particularly wanting to feed FA or anyone else for that matter, just my own VRS as I already have two feeds to FA that I did not want to alter as they are running fine, feeding fine.

Any suggestions as to a software version running Dump 1090 that would suffice?

If they are on the same local network you can use one or both of those to feed VRS without any modification.

I use the Flightaware piaware image on my Pi.

I run VRS on Windows and have each Pi set up in the receivers section of VRS

Format is set to AVR or Beast Mode
Address is the IP address of the Pi on your local area network
Port is 30005

You also need to set a Receiver Location for each Pi

That will give you ADSB. MLAT is similar but uses Basestation format and port 30106.

Will that solve your problem?

S.

Thanks SweetPea11, no, that’s not the actual issue at hand, sorry I should have given better detail.

I already have several receivers (FR24/FA/PF and the like being both Original boxes and RPi’s) feeding the VRS at the moment, but I wanted a dedicated “Un-Filtered” one that was going to show all being received.

The local output on 30005 is not filtered no matter which site you feed.

So it is showing already showing all that is received.
You can also show the FA MLAT results in VRS as you probably already do but they will always be filtered.

Thanks wiedehopf,

I looked into that too, the original FA box will only feed data on port 30002, the RPi is on 30003.

With Port Scanning, the attached is the result (FA use RPi internally as everyone probably knows).

I attempted to use the other mentioned ports with little to no data being fed.

So I’m now guessing, the known aircraft seen visually, may simply not have ads-b fitted or active and I’m showing in VRS what there is to be seen - well, until mandate anyway… Allowing or should I say removing the tick from “Ignore aircraft with no position” does naturally create a greater number of aircraft being displayed as you said. I just feel there must be more not being displayed.

I will try one last experiment, will acquire the latest PiAware file and add Dump 1090, load it on yet another RPi, and simply try that with the ports you mentioned, if for some reason these ports you mention are in fact software blocked like the others is yet to be seen, failing that FA gain yet another receiver feeding them.

Thank you to all that have had input into this trial, greatly appreciated.

RPi FA%20Box

.

Output is available on following Ports of dump1090 (mut / fa):

  • 30002 (format: RAW/AVR)
  • 30003 (format SBS)
  • 30005 (format Beast)
  • 30106 (MLAT feed-back from FlightAware)
pi@raspberrypi:~ $ cat /etc/default/dump1090-mutability

.... .... ....
.... .... ....
# Networking options
#

# Port to listen on for raw (AVR-format) input connections. 0 disables.
RAW_INPUT_PORT="30001"

# Port to listen on for raw (AVR-format) output connections. 0 disables.
RAW_OUTPUT_PORT="30002"

# Port to listen on for SBS-format output connections. 0 disables.
SBS_OUTPUT_PORT="30003"

# Port to listen on for Beast-format input connections. 0 disables.
BEAST_INPUT_PORT="30004,30104"

# Port to listen on for Beast-format output connections. 0 disables.
BEAST_OUTPUT_PORT="30005"


Thank you abcd567, will give it a shot :slight_smile: