FlightAware Discussions

Need help with PiAware


#1

Hello, I have setup my PiAware image today on a raspberry pi 3B. I am using a generic USB DVB-T dongle (Blue) which meets thw dongle requirements. I am using a proper power supply, 5V 3A 24AWG power supply which works fine. My SD card is completely fine. It is a new sandisk ultra 32GB.

My issue is that I have only recieved aircraft during the first 2 minutes of boot, then nothing else shows up. My tracker currently has an uptime of 3 hours.

On my piaware information website, my radio (yellow) says “Connected to receiver but no recent data seen”. The piaware and flight aware are both green. My MLAT (Yellow) says “No clock synchronization with nearby receivers”. On my Piaware configuration page, if I try to set a nearby airport, it continously says “searching…”

How do I get my receiver up and working?


#2

For Beginners - How-to Set Receiver Location


#3

Sounds like a failure of the antenna connector/cable.


#4

Done. I am still not getting any aircraft though.


#5

Hmm… I dont know.

pi@RaspberryPi:~ $ rtl_test -t
Found 1 device(s):
  0:  Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM
Detached kernel driver
Found Rafael Micro R820T tuner
Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6 
[R82XX] PLL not locked!
Sampling at 2048000 S/s.
No E4000 tuner found, aborting.
Reattached kernel driver

Rtl_adsb:

pi@RaspberryPi:~ $ rtl_adsb 
Found 1 device(s):
  0:  Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM
Detached kernel driver
Found Rafael Micro R820T tuner
Tuner gain set to automatic.
Tuned to 1090000000 Hz.
Exact sample rate is: 2000000.052982 Hz
Sampling at 2000000 S/s.
*d132de82848ffdb35d84de7f43b8;
*843262e29b3d98be2efc83ebbd0e;
*b17eb31211ab0efd4e2925f93e55;
*e24221aaec46032489bcae73c1fa;
*d6bf4bd15166ff3685949403616b;
*a0406598c5be7d5b3a34fae40d75;
*a001451c2015b671d8a5e00d5202;
*ad44093999543b1f202685d5e800;
*8d450931ec2c2d00013804682473;
*ca792b4f0a16d9d7c50dcb40020a;
*a8201519a22da712bf6d69d22ac4;
*8d6074af5829b61fd20a32368c90;
*d05c7b923f26bc0d5a50da9b7bbc;
*a36964c511a594495b4234176114;
*cfee46e9a94a5cd5c7315de0aa5b;
^CSignal caught, exiting!

#6

I still think the problem is that your dongle DVB-T driver is not blacklisted.
No kernel driver should be loaded that only leads to problems.

Please show the output of

sudo lsmod | grep rtl

Also the -t with rtl_test makes it not do what you want it to do.
Use

rtl_test -s 24000000

#7
pi@piaware:~ $ sudo lsmod | grep rtl
rtl2832                20480  0
i2c_mux                16384  1 rtl2832
dvb_usb_rtl28xxu       32768  0
dvb_usb_v2             24576  1 dvb_usb_rtl28xxu
dvb_core              110592  2 dvb_usb_v2,rtl2832
pi@piaware:~ $ 

rtl_test:

pi@RaspberryPi:~ $ rtl_test -s 24000000
Found 1 device(s):
  0:  Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM
Detached kernel driver
Found Rafael Micro R820T tuner
Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6 
Invalid sample rate: 24000000 Hz
WARNING: Failed to set sample rate.

Info: This tool will continuously read from the device, and report if
samples get lost. If you observe no further output, everything is fine.

Reading samples in async mode...
^CSignal caught, exiting!

User cancel, exiting...
Samples per million lost (minimum): 0
Reattached kernel driver

#8

This all looks good please try the blacklisting i proposed earlier again and then check the lsmod command again.

sudo nano /etc/modprobe.d/blacklist.conf

add the following two lines

blacklist rtl2832
blacklist dvb_usb_rtl28xxu

then CTRL-O to save and CTRL-X to exit

show the output of

sudo cat /etc/modprobe.d/blacklist.conf

then

sudo reboot

then

sudo lsmod | grep rtl

#9
pi@piaware:~ $ sudo cat /etc/modprobe.d/blacklist.conf
blacklist rtl2832
blacklist dvb_usb_rtl28xxu
pi@piaware:~ $ sudo lsmod | grep rtl
pi@piaware:~ $

#10

Any chance it’s working now?

If not post the output of

sudo journalctl -u dump1090-fa -n50 --no-pager

#11

Nope still not working.

pi@piaware:~ $ sudo journalctl -u dump1090-fa -n50 --no-pager
-- Logs begin at Thu 2016-11-03 17:16:42 UTC, end at Thu 2018-11-22 21:14:39 UTC. --
Nov 22 21:03:36 piaware systemd[1]: Started dump1090 ADS-B receiver (FlightAware customization).
Nov 22 21:03:36 piaware dump1090-fa[490]: Thu Nov 22 21:03:36 2018 UTC  dump1090-fa 3.6.3 starting up.
Nov 22 21:03:36 piaware dump1090-fa[490]: rtlsdr: using device #0: Generic RTL2832U OEM (Realtek, RTL2838UHIDIR, SN 00000001)
Nov 22 21:03:36 piaware dump1090-fa[490]: Found Rafael Micro R820T tuner
Nov 22 21:03:37 piaware dump1090-fa[490]: rtlsdr: enabling tuner AGC
Nov 22 21:03:58 piaware dump1090-fa[490]: Thu Nov 22 21:03:58 2018 UTC  No data received from the SDR for a long time, it may have wedged
Nov 22 21:05:06 piaware dump1090-fa[490]: Thu Nov 22 21:05:06 2018 UTC  No data received from the SDR for a long time, it may have wedged
Nov 22 21:06:06 piaware dump1090-fa[490]: Thu Nov 22 21:06:06 2018 UTC  No data received from the SDR for a long time, it may have wedged
Nov 22 21:07:06 piaware dump1090-fa[490]: Thu Nov 22 21:07:06 2018 UTC  No data received from the SDR for a long time, it may have wedged
Nov 22 21:08:07 piaware dump1090-fa[490]: Thu Nov 22 21:08:07 2018 UTC  No data received from the SDR for a long time, it may have wedged
Nov 22 21:09:07 piaware dump1090-fa[490]: Thu Nov 22 21:09:07 2018 UTC  No data received from the SDR for a long time, it may have wedged
Nov 22 21:10:07 piaware dump1090-fa[490]: Thu Nov 22 21:10:07 2018 UTC  No data received from the SDR for a long time, it may have wedged
Nov 22 21:11:07 piaware dump1090-fa[490]: Thu Nov 22 21:11:07 2018 UTC  No data received from the SDR for a long time, it may have wedged
Nov 22 21:12:07 piaware dump1090-fa[490]: Thu Nov 22 21:12:07 2018 UTC  No data received from the SDR for a long time, it may have wedged
Nov 22 21:13:08 piaware dump1090-fa[490]: Thu Nov 22 21:13:08 2018 UTC  No data received from the SDR for a long time, it may have wedged
Nov 22 21:14:08 piaware dump1090-fa[490]: Thu Nov 22 21:14:08 2018 UTC  No data received from the SDR for a long time, it may have wedged

#12
sudo pkill -9 dump1090-fa
sudo systemctl restart dump1090-fa
sudo journalctl -u dump1090-fa -n50 --no-pager

#13
pi@piaware:~ $ sudo journalctl -u dump1090-fa -n50 --no-pager
-- Logs begin at Thu 2016-11-03 17:16:42 UTC, end at Thu 2018-11-22 21:18:11 UTC. --
Nov 22 21:17:42 piaware dump1090-fa[1079]: rtlsdr: enabling tuner AGC
Nov 22 21:17:42 piaware dump1090-fa[1079]: rtlsdr_demod_write_reg failed with -4
Nov 22 21:17:42 piaware dump1090-fa[1079]: rtlsdr_demod_read_reg failed with -4
Nov 22 21:17:42 piaware dump1090-fa[1079]: rtlsdr_demod_write_reg failed with -4
Nov 22 21:17:42 piaware dump1090-fa[1079]: rtlsdr_demod_read_reg failed with -4
Nov 22 21:17:42 piaware dump1090-fa[1079]: rtlsdr_demod_write_reg failed with -4
Nov 22 21:17:42 piaware dump1090-fa[1079]: rtlsdr_demod_read_reg failed with -4
Nov 22 21:17:42 piaware dump1090-fa[1079]: rtlsdr_demod_write_reg failed with -4
Nov 22 21:17:42 piaware dump1090-fa[1079]: rtlsdr_demod_read_reg failed with -4
Nov 22 21:17:42 piaware dump1090-fa[1079]: rtlsdr_demod_write_reg failed with -4
Nov 22 21:17:42 piaware dump1090-fa[1079]: rtlsdr_demod_read_reg failed with -4
Nov 22 21:17:42 piaware dump1090-fa[1079]: rtlsdr_demod_write_reg failed with -4
Nov 22 21:17:42 piaware dump1090-fa[1079]: rtlsdr_demod_read_reg failed with -4
Nov 22 21:17:42 piaware dump1090-fa[1079]: rtlsdr_demod_write_reg failed with -4
Nov 22 21:17:42 piaware dump1090-fa[1079]: rtlsdr_demod_read_reg failed with -4
Nov 22 21:17:42 piaware dump1090-fa[1079]: rtlsdr_demod_write_reg failed with -4
Nov 22 21:17:42 piaware dump1090-fa[1079]: rtlsdr_demod_read_reg failed with -4
Nov 22 21:17:42 piaware dump1090-fa[1079]: rtlsdr_demod_write_reg failed with -4
Nov 22 21:17:42 piaware dump1090-fa[1079]: rtlsdr_demod_read_reg failed with -4
Nov 22 21:17:42 piaware dump1090-fa[1079]: rtlsdr_write_reg failed with -4
Nov 22 21:17:42 piaware dump1090-fa[1079]: Failed to submit transfer 0!
Nov 22 21:17:43 piaware dump1090-fa[1079]: Failed to submit transfer 0!
Nov 22 21:17:43 piaware dump1090-fa[1079]: Thu Nov 22 21:17:43 2018 UTC  No data received from the SDR for a long time, it may have wedged
Nov 22 21:17:44 piaware dump1090-fa[1079]: Failed to submit transfer 0!
Nov 22 21:17:45 piaware dump1090-fa[1079]: Failed to submit transfer 0!
Nov 22 21:17:46 piaware dump1090-fa[1079]: Failed to submit transfer 0!
Nov 22 21:17:47 piaware dump1090-fa[1079]: Failed to submit transfer 0!
Nov 22 21:17:48 piaware dump1090-fa[1079]: Failed to submit transfer 0!
Nov 22 21:17:49 piaware dump1090-fa[1079]: Failed to submit transfer 0!
Nov 22 21:17:50 piaware dump1090-fa[1079]: Failed to submit transfer 0!

#14

Quite curious. rtl_test works but dump1090 does not.

Just out of curiosity, does

sudo sytemctl stop dump1090-fa
rtl_test -s 24000000

still work?


#15
pi@piaware:~ $ rtl_test -s 24000000
    No supported devices found.


replugging the dongle back in:

    pi@piaware:~ $ rtl_test -s 24000000
    Found 1 device(s):
  0:  Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
No supported tuner found
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
Enabled direct sampling mode, input 1
rtlsdr_demod_read_reg failed with -1
Supported gain values (1): 0.0 
Invalid sample rate: 24000000 Hz
WARNING: Failed to set sample rate.
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_write_reg failed with -1
rtlsdr_write_reg failed with -1

Info: This tool will continuously read from the device, and report if
samples get lost. If you observe no further output, everything is fine.

Reading samples in async mode...
^CSignal caught, exiting!

User cancel, exiting...
Floating point exception

BTW, earlier I had done the RTL test on the other raspberry pi since I did not know what to stop.


#16

interestingly enough the device seems to work worse when the kernel driver is blacklisted.

sudo rm /etc/modprobe.d/blacklist.conf
sudo reboot
sudo journalctl -u dump1090-fa -n50 --no-pager

My best guess is: device does not work without kernel drive for DVB-T for whatever stupid reason.
But dump1090 won’t work properly because the kernel driver somehow gets the device back.

Do you have a picture of the dongle maybe others can avoid it?


#17

The dongle looks the same as any other DVB-T+FM+DAB (blue) generic dongle.

pi@piaware:~ $ sudo journalctl -u dump1090-fa -n50 --no-pager
-- Logs begin at Thu 2016-11-03 17:16:42 UTC, end at Thu 2018-11-22 21:33:13 UTC. --
Nov 22 21:33:01 piaware dump1090-fa[481]: weirdness: rtlsdr gave us a block with an unusual size (got 0 bytes, expected 262144 bytes)
Nov 22 21:33:01 piaware dump1090-fa[481]: weirdness: rtlsdr gave us a block with an unusual size (got 0 bytes, expected 262144 bytes)
Nov 22 21:33:01 piaware dump1090-fa[481]: weirdness: rtlsdr gave us a block with an unusual size (got 0 bytes, expected 262144 bytes)
Nov 22 21:33:01 piaware dump1090-fa[481]: weirdness: rtlsdr gave us a block with an unusual size (got 0 bytes, expected 262144 bytes)
Nov 22 21:33:01 piaware dump1090-fa[481]: weirdness: rtlsdr gave us a block with an unusual size (got 0 bytes, expected 262144 bytes)
Nov 22 21:33:01 piaware dump1090-fa[481]: weirdness: rtlsdr gave us a block with an unusual size (got 0 bytes, expected 262144 bytes)
Nov 22 21:33:01 piaware dump1090-fa[481]: weirdness: rtlsdr gave us a block with an unusual size (got 0 bytes, expected 262144 bytes)

#18

But this dongle works on the 3B+?

Then somehow this dongle and this pi 3b just don’t work together using dump1090 at least.


#19

I dont know if it works with the 3B+, I had plugged the dongle into the RPi3B+ and ran the RTL test and it gave the result showed as “pi@raspberrypi”


#20

i’m confuse do you have one raspberry pi or do you have two?

if you have two just change over the sdcard so you definitely know it’s the dongle.
also maybe you could use the newer pi for dump1090 and your problem would be solved (doubting that it will work on the other pi either though)

(already pretty sure it’s just the dongle not liking dump1090 but it’s worth a try)