Need help with flightaware receiver issue


#1

I recently setup my Raspberry pi to act as a ADS-B intended for the FlightAware usb receiver. I have everything loaded, along with the WIFI working fine. At the startup screen that says welcome to PiAware 3.5.3 everything appears to be normal with the exception of the receiver with reads (Error: Not connected to receiver) I’ve tried different USB ports but I get the same error. I browsed looking for answers but no one seems to be experiencing the same issue. I’m worried my Flighaware USB data receiver is bad. Has anyone seen this issue? If so what’s the fix. Thanks in advance.


#2

I’m not using the flightaware dongle, just the generic, but the piaware mounted the receiver as soon as it booted with no issues. Maybe there is a problem with your receiver. Did all the ports work when running raspian?
Do you have an antenna connected? Maybe it spews out an error if it doesn’t see data coming in?


#3

@matt7125: Test your FA Dongle by following method:

#STEP-1: Install the test tools package rtl-sdr
pi@raspberrypi:~ $ sudo apt-get update
pi@raspberrypi:~ $ sudo apt-get install rtl-sdr

#STEP-2: Stop dump1090-fa to free your Dongle for test
pi@raspberrypi:~ $ sudo systemctl stop dump1090-fa

#STEP-3: Now run the test command
pi@raspberrypi:~ $ rtl_test -t

#STEP-4: 
#If your Dongle is OK, 
#AND 
#properly connected,
#you will see this output
Found 1 device(s):
  0:  Realtek, RTL2832UFA, SN: 00001001

Using device 0: Generic RTL2832U
Found Rafael Micro R820T tuner
Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6 
Sampling at 2048000 S/s.
No E4000 tuner found, aborting.