A few questions piaware related


#1

Hello there
you can shoot me; I have seen this somewhere but I cant find it anymore.

  1. Command to change the receiver type, I want to move the receiver from Pi3 on Tinkerboard

  2. Just to be sure, feeder id transfer command ( I have saved it somewhere)

  3. I have a spare HDD, how can I move the OS to it? If the OS movement is not possible how can I define the HDD as swap unit/ temp data system?

Thank you
Emil


#2

“Receiver Type” pertains to weather you are using DVB-T (Pro Stick) or network feed. It has nothing to with type of Computer Board.

.

.
Please see this thread I have created few minutes ago

.
For Begginers - How to Get Back Existing Station Number in A Fresh Install

.


#3

On the tinkerboard I had the airspy and I want to move to the lightaware stick, sorry forgot to mention. piaware-config receiver type … I need the exact command.


#4

@EmilK

The Flightaware Pro Stick is a RTL-SDR Device.
Piaware by default is set to receiver-type rtlsdr.
If you have changed it, you can reset it by following command:

sudo piaware-config receiver-type rtlsdr

.

Setting name Possible values Default value Description
receiver-type rtlsdr, beast, radarcape, relay, other rtlsdr configures how PiAware attempts to talk to the ADS-B receiver

Set “receiver-type” to “rtlsdr”. This is the traditional setup with a RTL-SDR dongle directly connected to the Pi. PiAware will connect to localhost:30005 for ADS-B data.

#5

Thank you, exactly what I was looking for.


#6

Im trying to update the system:

sudo apt-get update
E: The method driver /usr/lib/apt/methods/https could not be found.
N: Is the package apt-transport-https installed?
E: The method driver /usr/lib/apt/methods/https could not be found.
N: Is the package apt-transport-https installed?

I’ve tried to to remove any https URLs within /etc/apt/sources.list and /etc/apt/sources.list.d/* in order to perform an apt-get update but it seems that I don’t have enough permissions…

Any help greatly apreciated


#7

@EmilK

sudo apt-get install apt-transport-https

sudo apt-get update

#8

pi@piaware:~$ sudo apt-get install apt-transport-https
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package apt-transport-https

Just seen
Sending commands to your device is not available because the feature is disabled locally on your device.

Without my intervention, no idea why


#9

It is a good idea to run “sudo apt-get update” to grab the package index. You can then try to install the package again and see if it was just missing the index. However, you might have the problem that the apt repo you are using doesn’t have the package.

This is set in piaware-config and you can see the current settings with the command:

piaware-config -showall

Here is a list of the different options. You want to have allow-auto-updates and allow-manual-updates set to yes.
https://flightaware.com/adsb/piaware/advanced_configuration


#10

pi@piaware:~$ sudo apt-get update
Hit http://flightaware.com jessie InRelease
Get:1 http://archive.raspberrypi.org jessie InRelease [22.9 kB]
E: The method driver /usr/lib/apt/methods/https could not be found.
N: Is the package apt-transport-https installed?

pi@piaware:~$ piaware-config -showall
#adept-serverhostspiaware.flightaware.com piaware.flightaware.com {70.42.6.197 70.42.6.198 70.42.6.191 70.42.6.225 70.42.6.224 70.42.6.156}” # usi ng default value
#adept-serverport 1200 # using default value
#allow-auto-updates no # using default value
#allow-dhcp-duid yes # using default value
#allow-manual-updates no # using default value
#allow-mlat yes # using default value
#allow-modeac yes # using default value
#beast-baudrate # no value set and no default value
#feeder-id # no value set and no default value
#flightaware-password # no value set and no default value
#flightaware-user # no value set and no default value
#force-macaddress # no value set and no default value
#http-proxy-host # no value set and no default value
#http-proxy-password # no value set and no default value
#http-proxy-port # no value set and no default value
#http-proxy-user # no value set and no default value
image-type piaware # value set at /us r/share/piaware-support/piaware-image-config.txt:5
manage-config yes # value set at /us r/share/piaware-support/piaware-image-config.txt:4
#mlat-results yes # using default va lue
#mlat-results-anon yes # using default va lue
#mlat-results-format “beast,connect,localhost:30104 beast,listen,30105 ext_basestation,listen,30106” # using default value
#priority # no value set and no default value
#radarcape-host # no value set and no default value
#receiver-host # no value set and no default value
#receiver-port 30005 # using default va lue
#receiver-type rtlsdr # using default va lue
#rfkill no # using default va lue
#rtlsdr-device-index 0 # using default va lue
rtlsdr-gain 28.0 # value set at /bo ot/piaware-config.txt:1
#rtlsdr-ppm 0 # using default va lue
#wired-address # no value set and no default value
#wired-broadcast # no value set and no default value
#wired-gateway # no value set and no default value
#wired-nameservers “8.8.8.8 8.8.4.4” # using default va lue
#wired-netmask # no value set and no default value
#wired-network yes # using default va lue
#wired-type dhcp # using default va lue
#wireless-address # no value set and no default value
#wireless-broadcast # no value set and no default value
#wireless-gateway # no value set and no default value
#wireless-nameservers “8.8.8.8 8.8.4.4” # using default va lue
#wireless-netmask # no value set and no default value
#wireless-network no # using default va lue
#wireless-password # no value set and no default value
#wireless-ssid # no value set and no default value
#wireless-type dhcp # using default va lue


#11
sudo piaware-config allow-auto-updates yes
sudo piaware-config allow-manual-updates yes
sudo systemctl restart piaware

#12

Thanks @abcd567 like usual right to the point
still no full joy…

[2018-02-27 08:00 CET] manual update (user-initiated via their flightaware control page) requested by adept server
[2018-02-27 08:00 CET] performing manual update, action: piaware
[2018-02-27 08:00 CET] *** running command ‘/usr/lib/piaware/helpers/run-apt-get update’ and logging output
[2018-02-27 08:00 CET] run-apt-get(21124): Get:1 http://archive.raspberrypi.org jessie InRelease [22.9 kB]
[2018-02-27 08:00 CET] run-apt-get(21124): Get:2 http://archive.raspberrypi.org jessie/main armhf Packages [171 kB]
[2018-02-27 08:00 CET] run-apt-get(21124): E: The method driver /usr/lib/apt/methods/https could not be found.
[2018-02-27 08:00 CET] child process 21124 exited with status EXIT 100
[2018-02-27 08:00 CET] skipping action piaware
[2018-02-27 08:00 CET] update request complete


#13

Switch from pi to root, then try

pi@piaware:~$ sudo -i
root@piaware:~#

#14

pi@piaware:~$ sudo -i
root@piaware:~# sudo apt-get install apt-transport-https
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package apt-transport-https
root@piaware:~# sudo apt-get update
Hit http://archive.raspberrypi.org jessie InRelease
Hit http://flightaware.com jessie InRelease
E: The method driver /usr/lib/apt/methods/https could not be found.
N: Is the package apt-transport-https installed?
root@piaware:~#


#15

few steps you can try…

in /etc/apt/conf.list commend everything with # except the line
deb http://mirrordirector.raspbian.org/raspbian/ jessie main contrib non-free rpi

reboot the device

try
sudo aptitude update see if it works.

if nothing happens

     sudo find /usr/share/doc/apt-* ```

this is where apt-transport-https is. it could be missing in which case you have to re-install
package apt (not so difficult to download and install from web, provided you have the full and
not the lite jessie version, if not, it gets more complicated, need to download the package on PC
use filezilla to transfer it to pi, extract and install using tar and dpkg. )

have a look at

 [https://packages.debian.org/jessie/apt-transport-https](https://packages.debian.org/jessie/apt-transport-https)

and

[https://community.c9.io/t/installing-apt-transport-https-issue/10994](https://community.c9.io/t/installing-apt-transport-https-issue/10994)

HTH

#16

@evangelyul
No config.list there

only
apt.conf.d
preferences.d
sources.list.d
trusted.gpg.d
sources.list
trusted.gpg


#17

You have mentioned that:
“I’ve tried to to remove any https URLs within /etc/apt/sources.list and /etc/apt/sources.list.d/* in order to perform an apt-get update but it seems that I don’t have enough permissions…”

I suggested switching to root to resolve the permission problem.
After switching to root, did you try to remove references to https in /etc/apt/sources.list, and /etc/apt/sources.list.d/*?

pi@piaware:~$ sudo -i
root@piaware:~# sudo nano /etc/apt/sources.list

root@piaware:~# sudo nano /etc/apt/sources.list.d/raspberrypi.org.list

#18

@EmilK

A workaround below, if
sudo apt-get install apt-transport-https
is not letting you install apt-transport-https

.

#Do not use apt-get
#Download apt-transport-https .deb package directly from Debian repositories
pi@piaware:~$ sudo wget http://ftp.at.debian.org/debian/pool/main/a/apt/apt-transport-https_1.0.9.8.4_armhf.deb     

--2018-02-27 13:24:42--  http://ftp.at.debian.org/debian/pool/main/a/apt/apt-transport-https_1.0.9.8.4_armhf.deb     
Resolving ftp.at.debian.org (ftp.at.debian.org)... 2001:858:2:1::10, 213.129.232.18
-----------
2018-02-27 13:24:43 (171 KB/s) - ‘apt-transport-https_1.0.9.8.4_armhf.deb’ saved [135040/135040]

#Check if the file downloaded successfully
pi@piaware:~$ ls
apt-transport-https_1.0.9.8.4_armhf.deb


#Install the downloaded .deb package
pi@piaware:~$ sudo dpkg -i  apt-transport-https_1.0.9.8.4_armhf.deb

(Reading database ... 32611 files and directories currently installed.)
Preparing to unpack apt-transport-https_1.0.9.8.4_armhf.deb ...
Unpacking apt-transport-https (1.0.9.8.4) over (1.0.9.8.4) ...
Setting up apt-transport-https (1.0.9.8.4) ...


#19

that did the magic
THANK YOU


#20

Happy to know your problem is solved. :+1: :smile:

Actually the magic was combined effect of two commands.

sudo wget http://ftp.at.debian.org/debian/pool/main/a/apt/apt-transport-https_1.0.9.8.4_armhf.deb   

sudo dpkg -i apt-transport-https_1.0.9.8.4_armhf.deb