FlightAware Discussions

Exchange 978 MHz UAT Receiver Dongles

I want to change 978 UAT receivers from an orange FA Pro Stick to the RTL-SDR v3 receiver. I set the RTL-SDR v3 serial number using rtl_eeprom -s 00000978 and that seemed to stick A-OK. I shutdown the RPi, unplugged the orange FA receiver, plugged in the RTL-SDR v3 receiver and powered everything back up.

But I get nothing on the 978 side (1090 works A-OK). No airplanes, no position reports. So I am guessing I need to change a receiver type or something in the config files.

My box is setup as Buster (Sep 2019) with the PiAware added (not the SD image) on an RPi2B.

pi@PiAware:~ $ sudo piaware-config
allow-auto-updates             yes                            # value set at /etc/piaware.conf:7
allow-manual-updates           yes                            # value set at /etc/piaware.conf:8
feeder-id                      my-secret-feeder-ID            # value set at /etc/piaware.conf:9
receiver-type                  rtlsdr                         # value set at /etc/piaware.conf:11
uat-receiver-type              sdr                            # value set at /etc/piaware.conf:10
pi@PiAware:~ $ cat /etc/default/dump978-fa
# dump978-fa configuration
# This is sourced by /usr/share/dump978-fa/start-dump978-fa as a
# shellscript fragment.

# If you are using a PiAware sdcard image, this config file is regenerated
# on boot based on the contents of piaware-config.txt; any changes made to this
# file will be lost.

# dump978-fa won't automatically start unless ENABLED=yes
ENABLED=yes

RECEIVER_OPTIONS="--sdr driver=rtlsdr,serial=00000978 --sdr-gain 40.2 --format CS8"
DECODER_OPTIONS=""
NET_OPTIONS="--raw-port 30978 --json-port 30979"

 

Is there something different between the orange FA Pro Stick and the RTL-SDR v3?

sudo journalctl --no-pager -u dump978-fa
sudo rtl_test

That’s actually the wrong place to configure that on a piaware sd-card image.
This is where you put the serials on the piaware image:

sudo piaware-config rtlsdr-device-index 00001090
sudo piaware-config uat-sdr-device driver=rtlsdr,serial=00000978

It’s all described here: Howto : Piaware SD card image 3.8.0 Quickstart Guide

1 Like

I am not using the PiAware image. I am using Buster with PiAware added on.

You had to confuse me with the hostname then :wink:
Anyhow, the output for the commands mentioned is still relevant.

1 Like

Actually depending on the antenna, it could just be that you need the amplification from the orange stick. The rtl-sdr v3 doesn’t have any amplification, so the first thing you would probably need to do is to increase the gain. (not quite sure how you set AGC in dump978-fa).

Also are you sure there just no traffic on 978 MHz atm?
Depending on where you are in the US, the weather isn’t very nice.

1 Like

For the Buster with PiAware added on - help me understand:

  • When do I use piaware-config?
  • And when do I use /etc/default/dump978-fa (or /etc/default/dump1090-fa) to configure PiAware?

To me it should be one place and not two places!

 

Antenna is the FA 978 MHz gain antenna and it is in the attic. I normally see 50-60 aircraft on a good day. And <10 on a bad day.

My UAT gain is set to 40.2 but I can bump it up tomorrow.

I’m near Chicago. It was a nice day today, but no traffic tonight. I’ll try again tomorrow.

Gain Setting of dump978-fa (Package Install)

sudo nano /etc/default/dump978-fa

This was previous version’s syntax:

RECEIVER_OPTIONS="--sdr driver=rtlsdr,serial=00000978 --sdr-gain 49 --format CS8"

Check current version’s syntax:
dump978-fa --help

My RECEIVER_OPTIONS match the above except for the gain.

And I checked the syntax. But I could not locate the possible arg (arguments) for --sdr.

Add
--sdr-gain 20
to
RECEIVER_OPTIONS=" "
then
sudo systemctl restart dump978-fa
sudo systemctl status dump978-fa

Does the status command’s output show gain 20?

The status output with gain NOT set by user contains this line:

SoapySDR: using maximum manual gain 49.6 dB

Never. These files configure the dump1090-fa and dump978-fa packages, which can be installed independently from piaware (you don’t need piaware installed to run them, and piaware doesn’t require that they’re installed to work - so long as you have some other sort of ADS-B data source available).

Part of the confusion here is that “piaware” is used to refer to both the piaware feeder software, and the whole piaware sdcard image that includes the piaware feeder software, dump1090, dump978, etc, and glue to configure them all.

When you’re using a piaware sdcard, you can use piaware-config to configure the network & receiver details of the system, and the glue scripts will automatically create the necessary config files for dump1090-fa etc.

If you are using a package install of the piaware feeder, then piaware-config only configures the piaware feeder (e.g. feeder ID). You should configure whatever data source you’re using (e.g. dump1090-fa) separately.

Why not in next version change the name of piaware data feeder from piaware to fafeeder, on the lines of rbfeeder, fr24feed, and pfclient? Then Piaware will be exclusively for SD card image.

1 Like

See this post:

This controls how to find the device to use. It takes anything accepted by SoapySDR::Device::make(). This is a comma-separated list of key-value pairs; for possible values, run SoapySDRUtil --find, e.g.:

pi@piaware:~ $ SoapySDRUtil --find
######################################################
## Soapy SDR -- the SDR abstraction library
######################################################

Detached kernel driver
Found Rafael Micro R820T tuner
Reattached kernel driver
Found device 0
  available = Yes
  driver = rtlsdr
  label = Generic RTL2832U :: 00001090
  manufacturer = Realtek
  product = RTL2832U
  rtl = 0
  serial = 00001090
  tuner = Rafael Micro R820T

… for that device, you could specify e.g. --sdr driver=rtlsdr,serial=00001090

1 Like

To run
SoapySDRUtil --find
First install soapysde-tools:

sudo apt-get install soapysdr-tools

1 Like

piaware-config only controls the feed to FA in your situation, many of the options don’t do anything unless you use the piaware sd-card.
But your setup looks right for the package install, i was just confused as your hostname was piaware … which suggested the piaware sd-card image.

You didn’t yet provide the output for the commands i asked for:

sudo journalctl --no-pager -u dump978-fa
sudo rtl_test
1 Like

All is A-OK today! There must have been no traffic during the hour plus I checked.

Usually I see 1-5 UAT planes per hour and lots of TIS-B “ghosts”. The TIS-B ghosts appear for a moment, then age, then turn a pastel (lighter) color, then disappear. I was looking for both UAT planes and the constant stream of TIS-B ghosts. Neither appeared for more then an hour and I thought the worst. Bad move on my part! :woozy_face:

I use Buster with the PiAware addon (not the SD card image) and I was referring to “piaware” as the entire system including “piaware feeder software, dump1090, dump978, etc”. My bad! This is somewhat confusing to me but I’ll get there!

So I am assuming (bad to do!) that I have things in piaware-config like receiver-type rtlsdr and uat-receiver-type sdr that don’t belong?

pi@PiAware:~ $ sudo piaware-config
allow-auto-updates             yes                            # value set at /etc/piaware.conf:7
allow-manual-updates           yes                            # value set at /etc/piaware.conf:8
feeder-id                      my-secret-feeder-ID            # value set at /etc/piaware.conf:9
receiver-type                  rtlsdr                         # value set at /etc/piaware.conf:11
uat-receiver-type              sdr                            # value set at /etc/piaware.conf:10

 

EDIT: Here are my TIS-B ghosts…

and a few moments later they are all gone…

.
Both the following commands are pplicable for Piaware SD card image AND Raspbian image with package install:

sudo piaware-config receiver-type rtlsdr  
## the above setting is enabled by default, not necessary to issue it.

sudo piaware-config uat-receiver-type sdr 
## the above setting is disabled by default. 
## It is necessary to issue it if you want to use dump978-fa

.

Please see following thread for configuration & settings of your type of install (i.e. package install).

Although this thread is for Debian & Ubuntu amd64 (on Intel PC), and packages are built from source-code, the settings/configurations given there are equally applicable to package install on Raspbian Buster (on RPi).

Howto Install Piaware ver 3.8.0 on Ubuntu & Debian amd64

.

1 Like

They actually control two things

  1. they tell the piaware feeder software where to connect to for data
  2. they tell the piaware sdcard glue how to configure dump1090/dump978/etc

So it’s normal for them to be there on package installs, too.

TIS-B in theory only gets transmitted if there is a suitable aircraft (advertising UAT-in, UAT-out, but no 1090-in) nearby to receive it, and the refresh rate also doesn’t seem to be all that high, which is why you see them popping in and out seemingly at random. It’s not a reception problem, it’s just how the FAA transmits the data.

3 Likes