FlightAware Discussions

(Windows->RPi) Skyview not accessable and how to MLAT?

Hi

Have previously feed FR24 and FA from a windows PC.
Now i have set up af RPi3B+ with, and in the order:

OS
dump1090 mutability 1.15 dev (web view is working)
ModesMixer2 (just for test, web view was working, service not running now)
FR24 (Feed and webview is working, MLAT enabled)
PiAware (only step 2 in install proc) (feed seems to work according to FA www)

However i can’t get anything displayed on port 8080?

How do i setup MLAT? I can’t find any config file, other than the one created when i enabled manual updates (only this setting in the file).

br Lars

1 Like

That only works with dump1090-fa but you are using dump1090 mutability.

Also looks like your MLAT is working:
https://flightaware.com/adsb/stats/user/larsras

Thanks.
Weird, MLAT has also just changed to green here.
Ok with skyview. So many combinations for installing packages for feeding and i’m complete new on RPi side. But at least i got something working :slight_smile:

You can watch your system log if you want, some MLAT status is printed there by piaware:

journalctl -f -u piaware

or just
journalctl -f

depending on what you want to check.

I would personally replace dump1090-mutability with the newer dump1090-fa but it’s a matter of taste.
Also configuration is a little different.

If you want to check more specifically if MLAT is having hiccups you can use this command:

journalctl -u piaware | grep 'timest\|Server st'

Thanks, will check further tomorrow.
I will also try to figure out how to install the -fa version instead of the mutability then.
I guess that other feeders also work with -fa version?

It’s basically just a newer version of mutability, so yes for the feeders it doesn’t matter which you use.

This should do the trick in regards to switching to dump1090-fa

sudo apt-get remove dump1090-mutability
sudo lighty-disable-mod dump1090
sudo apt-get install dump1090-fa

The :8080 works only with:

  • Piaware SD Card image
  • Pi24 image
  • Flightradar24 windows feeder fr24feed_win32

It wont work with Raspbian image with package install of either dump1090-fa or dump1090-mutability.

As @larsras has Raspbian image, changing from dump1090-mutability to dump1090-fa wont help in this respect.

On Raspbian image with package installs, both dump1090-mutability and dump1090-fa work equally good for feeding ALL sites (Flightaware, Flightradar24, Planefinder, Radarbox24 etc etc). They both are equally good for MLAT.

There is only one difference: The appearance of the map.
Most people prefer dump1090-fa map over dump1090-mutability map, because dump-fa map is more beautiful, otherwise both maps display same information.

DUMP-MUTABILITY MAP

DUMP-FA MAP

1 Like

It works fine with dump1090-fa package install.
It’s the normal Skyview just like with the piaware image.

If you are talking about the status page indicating feeder and MLAT status, that is normally only available on the piaware sd-card but can be installed as a package called piaware-web.

Just now rechecked, yes :8080 works on package install of dump-fa also. It is dump-mutab which displays “Unable to connect”.

However weather or not map is displayed on :8080, it is not a problem. The maps can be viewed on:

dump1090-fa at
ip-of-pi/dump1090-fa/

dump1090-mutability at
ip-of-pi/dump1090/

Changing from dump-mutab to dump-fa just for :8080 is not worth the trouble. However if change is done due to map’s appearance, then it is OK.

1 Like

@larsras

If you like the appearance of dump1090-fa map better than dump1090-mutability map, here is the way to replace dump-mut by dump-fa:

#First purge the dump1090-mutability
sudo dpkg --purge dump1090-mutabilty   

#The above command often does not delete folder "/usr/share/dump1090-mutability" 
# as it is not empty. Delete it manually by following command
sudo rm -rf /usr/share/dump1090-mutability   

#Now install dump1090-fa. 
#As you have already installed piaware repository during installation of Piaware
#you have to give only following command
sudo apt-get install dump1090-fa   

#REBOOT after installation of dump1090-fa is completed
sudo reboot  

Open browser. go to ip-of-pi/dump1090-fa/
If any problem in loading/viewing the new map, clear browser cache (Ctrl+Shift+Delete) and then Reload browser (Ctrl+F5)

ENJOY NEW MAP :slight_smile:

@wiedehopf
@larsras

There is one more important difference which I forgot to mention.

The dump1090-fa map has RSSI column (visible when table is expanded), whereas dump1090-mutability map does not have this column (although it can be added by some workaround, but needs medium-level Linux capability of user).

The RSSI colums is very useful in manually tweaking and optimizing the Gain setting of the dongle.

1 Like

@wiedehopf
@abcd567
Awesome support :slight_smile: Thanks to both of you!

Now running the dump1090-fa instead, and i like the map and espcially the expanded table :slight_smile:

1 Like

The RSSI colums is very useful in manually tweaking and optimizing the Gain setting of the dongle.

In fact, you wrote the nice gain script that changed the gain without adding it to Skyview. It worked for mutability. I tried to change it to work with dump-fa but it reached the limits of my programming capabilities. Did you get try to get it to work for dump-fa ?

@thespeedycab

If you mean changing gain from browser, then there are two options

Please see both the above noted posts.
There are options for dump-mut and dump-fa. You dont have to modify anything. Just use the right script.

.

Independent web page

That’s one I was looking for. Thanks