Wifi on Raspberry Pi

So I’m a newbie when it comes to the whole Raspberry Pi thing, but I couldn’t help but pique my interest when I saw the squawk for building your own ADS-B receiver. I read in the set up instructions on FA’s page, that the USB wifi receiver had to be plugged into the unit via the USB extension cable. I don’t quite understand this. Why can’t I just plug the wifi adapter directly into the unit?

You can if it fits. Some of the dongles & adapters are chunky enough that they don’t both fit. That’s all.

I asked on the forum a similar question for the flightfeeder. Since i got no answer i did not use a dongle but i used an old wifi router instead.

My setup is now: flightfeeder (raspberry pi) network output → UTP cable → router → wifi → router → modem → internet.
the router connected to the flightfeeder is configured as Client Bridge, so it connects wirelessly to a wifi router two floors below to connect to the internet. Problem solved.

The FlightFeeder does not currently support WiFI dongles, sorry about that.

just trying to help dbaker :slight_smile:
It worked for me, maybe for others…

wifi dongles on the Pi can be a PITA to get to work.

The only trouble I had setting up the Edimax adapter we recommend was that it would not connect to my 5GHz network at home. Once I switched to the 2.4GHz SSID it worked like a charm, with no unusual setup needed. I configured mine via ssh rather than go to the trouble of connecting a TV/keyboard, but I’m pretty comfortable on the command line.

Also, I did not get the USB extension cable and did not need it to connect both the Wifi and receiver dongles. Honestly, I’d be more likely to use the extension for the receiver, since it’s pretty bulky.

Some folks have encountered problems with random resets and crashes on older Pi B’s with the on-board fuses - and on all Pi B’s if the power supply current rating is not high enough. Power supplies rated at less than 1amp will run a Pi model B but once other power hungry USB devices are added the voltage may drop and cause unreliable operation.

To be certain I now use 5V power supplies rated at 2Amps. That solves the issue of the supply voltage dropping below 5Volts and causing erratic operation of the Pi - but problems can still arise if the ‘fuse’ operates from excessive USB current and shuts the Pi down. (it will come back when it cools down in an hour or so)

Before I got on to the higher current power supplies I used to use and recommend to others a small 4 port USB powered hub to run the dongles and WiFi. Now I don’t bother unless I need more than two USB Ports - and when I start using the Pi B+'s I probably will never need a hub - even if the user wants a keyboard and mouse as well .

Just thought I’d add my experience to the list. I have an Edimax usb wifi dongle on my PI B+. Setup was easy using the GUI desktop. It connected to my 2.4Ghz network no problems and auto connected after a restart. I didn’t have to use an extension and the device is working great and reporting to flight aware!

Hearing all of this is very reassuring, and I am considering taking the plunge. I do not have any programming experience, but the directions on FA’s set up page seem to be pretty straight forward. Part of me is still hesitant. I just don’t want to blow money on something that I could foul up with zero experience.

Have at it. You will enjoy the aggravations afterward with the sense of accomplishment. This is a sure cure for zero experience, and it will be interesting to see how far it takes you.
Good luck and have fun.

Thinking of diving in on a Raspberry but reading the Wifi part makes me nervous. Because of the system location etc, wifi will be a need. In fact Im hoping to later put it up in my attic near the antenna and have it run on either a power plug I will put up there or Solar set up so wifi is a must.

Should I just get Wifi working reliably first before I install PIAware ??

Also I currently feed with Plane plotter. And the whole idea is to not have my desktop run 24/7. Is there a PP feed from the raspberry without running the desktop 24/7?

Search Planeplotter for PPup1090

I just hooked up the wifi USB to my piaware RP and the only problem with it would be if your wifi setup is locked with a password. I was able to get it to hookup to my routers but I had to installl WICD (a linux network manager) in order to feed it the password. And right now I am trying to assign it a static IP address (on my internal network) so that I can always find it without have to dig into DHCP tables… Still working on it. NOTE: I have yet to hookup either a keyboard or a monitor to the RPi so if you have those two, the password may not be a problem.

Here’s what I have in /etc/network/interfaces for the wifi network, using a static IP. This is for a WPA secured network, which I imagine most home users are set up with now (even my parents finally upgraded from WEP)

# The WIFI network interface
auto wlan0
iface wlan0 inet static
wpa-ssid your_ssid
wpa-psk your_password

Just to reiterate from before, I did all my config from the command line rather than the gui, so the gui experience may be significantly different.

I’m trying to setup a second feed for FlightAware. On my first one, I have a direct LAN connection.

Here I always get the following error: “software failed to determine MAC address of the device. cannot proceed without it.”


  • Rasperry Pi Typ A
  • Edimax WLAN Stick
  • Powered USB Hub
  • Antenna

Is piaware looking for eth0?

Pclifton: thanks for the wlan0 info… Will give it a try but I am pretty sure I’m going to put my RPi out in the barn with a hardwire… But it’s nice to have other methods.

For anyone looking to set up wireless access, the Edimax EW-7811Un is supported out of the box and you can follow guides available online for headless configuration.

Here’s a super-barebones version that assumes you’re using the stock PiAware image file and already have the adapter plugged in:

Modify /etc/wpa_supplicant/wpa_supplicant.conf

sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

Add the network block and substitute your ssid/psk (the first two lines should already be present).

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev


Restart the adapter, either with the following, or by physically power-cycling the RPi:

sudo ifdown wlan0
sudo ifup wlan0

For static IP configuration, modify /etc/network/interfaces:

sudo nano /etc/network/interfaces

Your base configuration will look something like this:

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

Replace ‘iface default inet dhcp’ with your configuration:

iface default inet static

For reference, I used the following configuration:

  • raspbian-piaware-1.13.img
  • Raspberry Pi Model B 256MB (old model)
  • Edimax EW-7811Un

It’s easier to configure WiFi if you connect to Ethernet and install wicd and an interface for it

apt-get install wicd wicd-curses

Once installed, run wicd-curses from the command line as root and it’ll make it easier for configure.

The main items to pay attention to are -

Use these settings for all networks sharing this essid
Automatically connect to this network
Use Encryption
WPA 1/2 (Passphrase) vvv
Preshared key: *************

This one works well with FA feeder :smiley: